Aller au contenu
DroneBuilds

Problème régime des moteurs (config avec Hobbywing OMNIBUSF4SD)


Messages recommandés

Bonjour à tous,

J'ai fait l'acquisition du pack combo Hobbywing omnibusF4SD, j'ai normalement tout bien configuré, etc mais j'ai le problème suivant : lorsque je mets les gaz, les moteurs accélèrent et ralentissent, accélèrent et ralentissent, ainsi de suite.

Je vous joins une petite vidéo pour être plus explicite, ainsi que le rapport de la blackbox. C'est nette, on voit bien la pogression du régime des moteurs, l'arrêt et le redémarrage ....

En testant les moteurs sous betaflight, ils tournent bien tous les 4 et régulièrement.

 

J'ai besoin de votre aide .... vraiment !

S'il vous faut d'autres infos de configuration pour m'aider au diagnostic, n'hésitez pas à me demander pour que je vous les envoie.

 

Pour la vidéo, ci -dessous, je tiens à préciser que je elle est réalisée à titre exceptionnelle pour aider à constater le problème, à ne pas refaire même si nous avions nos casque (de vélo) et visières de protection !

Lien vers la vidéo : https://photos.app.goo.gl/951Ai9jBFuNhHoXx9

 

Dans l'attente de vos retour 🙂

 

Olivier

image.png

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Il fait ça aussi quand il vole, je le tenais juste pour bien montrer le problème.

J'ai pensé au AIRMODE mais il est déactivé.

Modifié (le) par olyvfpv
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

J'ai flashé les ESCs et calibrer l'accéléromètre avec BetaFlight configurator.

Apparemment le gyro est configuré automatiquement à la mise sous tension.

Il y a un condo sur les ESCs.

 

Difficile de trouver la panne :-(((

 

Ou alors la carte à un défault ?

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

J'ai ce combo

(Hobbywing Xrotor F4 G3 Flight Controller OSD & 60A 3-6S Blheli_32 DSHOT1200 Brushless ESC)

image.png.9a4e07c4c9c2252c69025c644cd3733f.png

 

Sur la doc fourni il est indiqué : Firmware: OMINIBUSF4SD

Modifié (le) par olyvfpv
Lien à poster
Partager sur d’autres sites

SAlut, dans ce genre de situation, je commence toujours par "flasher" le firmware (effacement complet) pour repartir sur une base saine.

Lien à poster
Partager sur d’autres sites
il y a 42 minutes, olyvfpv a dit :

J'ai ce combo

(Hobbywing Xrotor F4 G3 Flight Controller OSD & 60A 3-6S Blheli_32 DSHOT1200 Brushless ESC)

 

 

Sur la doc fourni il est indiqué : Firmware: OMINIBUSF4SD

Oui, mais dans ton message tu dis...

Il y a 23 heures, olyvfpv a dit :

Cible AIRB/OMNIBUSF4SD(STM32F405)

C’est une « cible » Airbot !? C’est pour ça que je te parle de Legacy pour le flash ! Maintenant c’est peut-être une cible pour les 2 modèles ?Et tu n’as peut-être pas d’autre choix !?

Dans la définition du sens de rotation des moteurs, tu es en standard (avant à l’intérieur, arrière à l’extérieur) ?

Lien à poster
Partager sur d’autres sites

Effectivement, j'ai mis les deux dans mes messages.

Désespéré que ça ne marche pas, j'ai essayé les 2 versions de firmware Air et Legacy. Par contre toutes les deux dans leur versions les plus récentes.

image.png.b27054a435eadb05e40195ea0ce82291.png et  image.png.23d6fc180440fc22f78efdb01e4eb182.png

Devrais-je essayé avec des versions plus anciennes ?

Lien à poster
Partager sur d’autres sites
il y a 12 minutes, olyvfpv a dit :

Devrais-je essayé avec des versions plus anciennes ?

Éventuellement 3.5.7 c’est une base stable.

sinon Emuflight, c’est une base betaflight 3.5.7...

  • +1 1
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
il y a 10 minutes, Attafr a dit :

Et le sens de rotation des moteurs?

Oui sens de rotation des moteurs en standard avant à l’intérieur, arrière à l’extérieur

Modifié (le) par olyvfpv
Lien à poster
Partager sur d’autres sites
Il y a 7 heures, olyvfpv a dit :

Oui sens de rotation des moteurs en standard avant à l’intérieur, arrière à l’extérieur

C'est soit extérieur ou intérieur pour les 4, tu t'es mal exprimé ?

 

sens motor inv.jpg

sens motor n.jpg

Lien à poster
Partager sur d’autres sites

 Bon, j'ai avancé sur le problème.

Donc, quand le VTX est débranché le drone vol nickel, on vol à vue par contre on veut faire du FPV 🙂 .... donc on continue à chercher !

Lorsque je branche le VTX, j'ai à nouveau les à-coup moteur.

Le VTX que j'ai pris est le : AKK X2-ultimate International 25mW/200mW/600mW/1200mW 5.8GHz 37CH FPV Transmitter with Smart Audio.

Lorsque j'ai réalisé les tests avec le VTX, il y avait dans le masque le message : RX LOSS ?

Est-ce que ça vous dit quelque chose ?

Lien à poster
Partager sur d’autres sites

Un conflit entre le VTX et le RX ? Ton VTX SmartAudio est connecté sur quel port TX ?

une mauvaise position du RX dans la frame ?

un problème d’alimentation (tu as un condo) ton VTX est alimenté via la lipo ?

Lien à poster
Partager sur d’autres sites

On a avancé encore sur le problème .... hier soir on été focalisé sur le VTX qui une fois connecté avait un effet bizzard comme indiqué précédemment et cela dû au message RX LOSS qui nous a fait pensé au VTX..

Le drone marchait bien avec le VTX déconnecté mais le condo était aussi déconnecté et on n'y a pas prêté attention.

 

Au début, on avait soudé le condo directement sur les câbles du XT60 sur la carte (comme vu sur un tuto)  et le VTX aussi (comme vu dans un tuto également)

 

Aujourd'hui, le condo on l'a ressoudé sur la carte des ESC là oui était à l'origine avec les câbles pour le déporter: On ne voulait pas le laisser là problème de place !

Donc il est là (si on regarde de près on voit quand même que ces connexions sont connectées au connection du XT60 sur la carte)

image.png.c1a12007cb4d589693162a5c7517abdc.png

 

Donc maintenant on a le condo connecté là et le VTX conncté sur le FC.

 

Après essai on a eu une fois le RX LOSS, .... on réfléchit encore .....

 

Du coup on a éloigné les antennes du VTX et du RX qui était trop proche, depuis, ça a l'air de marcher 🙂 Avant de crier trop fort victoire, on verra les essais demain au club .... à suivre ......

 

En tout cas, je tiens d'avance à TOUS vous remercier pour vos échanges sur le forum et si nos modifs se confirment, Attafr tu étais sur la bonne piste avec l'alim et le condo; A confirmer demain avec les essais au club 🙂  On vous tiens au jus !

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...