Aller au contenu
DroneBuilds

Bind R9M ACCST & RX OTA ACCES


Messages recommandés

Bonjour à tous.

J'ai un problème pour Binder mes nouveaux RX :    R9 Mini récepteur OTA 915Mhz & FrSky R9 Slim + Slim plus OTA 

Je n'avais jamais eu de problème avec mes anciens RX du même type (No OTA & qui sont ACCST) qui "Bindent" parfaitement même après la mise à jour du firmware du R9M.

J'ai bien flashé le R9M en FW-R9M-ACCST-20190117 et mis le RX en FW-R9Slim+OTA-ACCST_20200403 & pour l'autre FW-R9MM-ACCST_v20190201.

J'ai fait les manipes à partir de ma Frsky Taranis X9d Plus que j'avais aussi mis à jour avec opentx-x9d+-flexr9m-lua-fr et le bon disque qui va avec.

Les RX s'allument rouge et vert fixe et sans clignotements et idem en position de Bind ils restent pareil .. J'ai comme l'impression que ce n'est pas les bons Firmwares ?

Précision : je suis en mode FCC.

J'avoue que je ne pige pas ..

image.png.ac12511396d3784512e05306ce4a6b94.pngimage.png.ab3064b52e248eca45555eacbfceb510.png

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites
  • Réponses 55
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

C'est bizarre, et très con en effet 😕  D'un autre côté, c'est rassurant qu'on puisse encore trouver des RX qui sont tout de même flashables et fonctionnent avec notre vieux matos. Je me rassure a

Le mieux est de creer un soft serial sur pad leds ou ppm (si dispo et si tu as) et mettre ton smartaudio dessus.  Et ainsi , profiter pleinement de ton UART 3 pour le R9mm en F-port ( Effectiveme

Bonne nouvelle ! 🙂  Maintenant la question est : est-ce que ça vient du fichier téléchargé, qui est pourri dans l'archive, est-ce que seul le F.Port marche, ou bien est-ce que le fichier s'est co

Posted Images

Ah.... Shit... C'est justement la question que je me posais ces derniers temps. À savoir, quel R9mm acheter pour que cela puisse fonctionner en ACCST. 

Sachant que Frsky ( fumier de lapin!) continue de verrouiller leur Protocole exclusivement avec la formule ACCESS ! 

Je n'ai hélas, pas de solution à te proposer à chaud. Je pense et j'espere que la solution existe. 

Que tu sois en FCC ou EU-LBT, là n'est pas le problème. Du moment que tu tapes le firmware qui va avec la bande de fréquences. 

Je reste attentif sur ce sujet épineux et...De M...de! 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Merci @CriTof j'avais espéré que tu ais une solution, mais je me doutais d'un brink du mode ACCESS ...Font vraiment chier ! Ils pourraient au moins prévenir de la non-comptabilité des ACCESS OTA qu'ils vendent avec les anciens R9M ACCST, je pense que les nouveaux fonctionnent avec, mais seront-ils compatibles avec les anciens RX en ACCST ou pourrait-on flasher ceux-ci en ACCES ?????

En tous cas ils ont l’autocollant ACCESS

image.png.24b89ccc349075575d856d7d4a6ae828.png

Edit correction ACCST ..

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites

Je vais tenter si j'ai le temps de rechercher aussi de mon côté. Cela devient impératif ! 

Casi persuadé d'une solution FW qui va bien. 

Une idée @Jerome  ou @Dujack vous aussi possesseur du R9M en ACCST...? 

Modifié (le) par CriTof
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Je suis déjà bon pour reflasher les RX, mais je vais chercher à partir de lundi, ce WE c'est pêche 😉

Franchement ça donne la haine envers Frsky ! Ils n'y gagnent pas !

PS j'avais tenté de flasher le R9m en ACCESS, ben ça marche pas !

@CriTofJ'ai quand même commandé celui là pour 32€ :

Compatibilité: série R9 (ACCST/ACCESS) et série TD

Il a l'air compatible sur les deux modes et pour le prix d'un slim ...J'ai plus qu'à patienter 2 mois !

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Je viens de commander 2 R9 mm ota que je compte bien bind en Accst avec mon r9m accst et ma bonne vieille x9d.

Normalement c'est censé marcher après flash du rx en accst, mais pas encore testé 😉

Lien à poster
Partager sur d’autres sites
il y a 35 minutes, Jerome a dit :

Je viens de commander 2 R9 mm ota que je compte bien bind en Accst avec mon r9m accst et ma bonne vieille x9d.

Normalement c'est censé marcher après flash du rx en accst, mais pas encore testé 😉

A SUIVRE  !! 😛 Merci d'avance. 

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Jerome a dit :

Je viens de commander 2 R9 mm ota que je compte bien bind en Accst avec mon r9m accst et ma bonne vieille x9d.

Normalement c'est censé marcher après flash du rx en accst, mais pas encore testé 😉

C'est qu'est-ce que j'ai fait ...Mais une fois les RX flashés en ACCST, ils ne fonctionnent plus et restent fixes  sans possibilités de blind. Mais si tu trouves ..

Modifié (le) par spid99
Orto
Lien à poster
Partager sur d’autres sites
il y a 12 minutes, spid99 a dit :

C'est qu'est-ce que j'ai fait ...Mais une fois les RX flashés en ACCST, ils ne fonctionne plus et reste fixent  sans possibilités de blind. Mais si tu trouves ..

J'ai commandé chez BG dc ca va pas arriver tout de suite, mais je crois que j'en avais un d'avance, je check ca a mon retour de vacances  ! 

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

J'en profite pour une autre question que je me suis posée en montant les R9, avec les nouveaux firmwares en Flex OTA, de ce que j'ai compris on peut mettre le "F-port" sur un RX afin d'avoir tout (RSSI & SBus) sur le même fil. Sur mes cartes j'utilise tous les TX, exemple je met le Smart-audio sur TX3, puis-je utiliser le RX3 pour le "F-port" ? Ou peut-on le mettre sur le "S-bus" de la carte ?

Modifié (le) par spid99
Orto
Lien à poster
Partager sur d’autres sites

Le mieux est de creer un soft serial sur pad leds ou ppm (si dispo et si tu as) et mettre ton smartaudio dessus. 

Et ainsi , profiter pleinement de ton UART 3 pour le R9mm en F-port ( Effectivement tu as tout dessus avec un seul fil ! Je crois même qu'il propose les popcorns et le KF, c'est te dire ! 🤪)

Modifié (le) par CriTof
  • +1 1
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Si tu veux pouvoir profiter de tout en F.Port (signal, RSSI, télémétrie) il faut un TX. Sur un RX, y a ptetre moyen (je crois que j'avais testé par erreur y a longtemps, sur un r9 mm accst) mais tu perds la télémétrie.

Un UART (dc RX et TX) ne peut être utilisé que pour une seule fonction, a moins de créer des ports softserial, mais ce n'est vraiment pas recommandé pour les signaux exigeants, comme le signal radio. La solution de @CriTof est la meilleure approche.

Le Sbus de la carte est un RX (avec inversion), donc pas de souci normalement.

  • Merci ! 1
Lien à poster
Partager sur d’autres sites
Il y a 7 heures, CriTof a dit :

Le mieux est de creer un soft serial sur pad leds ou ppm (si dispo et si tu as) et mettre ton smartaudio dessus. 

Me parles pas en Chinois stp  😉 Après 4 heures de batailles avec ces R9, j'ai mal au crane !

Il y a 7 heures, Jerome a dit :

Le Sbus de la carte est un RX (avec inversion), donc pas de souci normalement.

Donc je peux mettre le F-Port sur le Sbus de la carte (Uart1) et conserver UART1 dans Béta. J'ai du mal avec ces TX-RX Uart etc ... 🤔

Si je comprends bien le "SBus" de la carte est en fait RX1 ? Pourquoi l'ont pas appelé RX1?? Ah oui, j'oubliais, comme ce n'est pas assez compliqué on a ajouté les "Invers" ou "No-Invers" !

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites
il y a 2 minutes, spid99 a dit :

Donc je peux mettre le F-Port sur le Sbus de la carte (Uart1) et conserver UART1 dans Béta. J'ai du mal avec ces TX-RX Uart etc ... 🤔

RX pour Recevoir, TX pour Transmettre (et aussi recevoir lors de comm bidirectionnelle). Donc sur un RX tu pourras recevoir les signaux du R9mm mais pas envoyer la télémétrie. Il me semble que le fport peut fonctionner sur un RX (sans la télémétrie donc), mais à vérifier 😉

Sur ta FC, a priori Sbus = RX de l'Uart1, avec de l'inversion logique (parce que les signaux FrSky sont inversés)

Lien à poster
Partager sur d’autres sites
Il y a 7 heures, Jerome a dit :

RX pour Recevoir, TX pour Transmettre (et aussi recevoir lors de comm bidirectionnelle)

J'adore cette logique !

  • Haha 1
Lien à poster
Partager sur d’autres sites

Bonjour, bon avant de partir, une dernière question car je commence à ne plus rien comprendre ..(Mais est-ce que j'ai déjà compris une fois ? 🤔)

@Jerome Dans ton tuto  (que j'ai eu plaisir à lire) tu dits :

Citation

Pour connecter le R9MM à votre quad, 3 câbles suffiront : 5V, GND et Uninverted S.Port en direction d’un port TX (très important, ne pas utiliser un port RX). En général ils sont nommés TX1, TX2, TX3, etc. sur la FC. Le numéro du port correspond au numéro de l’UART associée.

Donc je reviens sur ma question ... Puis-je mettre le "F-Port" (est-ce bien le "Uninverted S.Port" ?)  sur le TX3 (en sachant que j'utilise déjà le RX3)

Ou j'oublie et je le mets sur le SBus ..Point barre ?

Le jour ou tout le monde donnera un seul nom aux choses, je serais moine ! 😉

Lien à poster
Partager sur d’autres sites

Sur le r9mm tu as un pad nommé S.port, c’est celui là qu’il te faut cabler sur le Tx. 
Je te laisse lire le post que j’avais ouvert et grosso modo sur ma fc clracing f4 ca n’a jamais fonctionné sur le Tx3 mais aucun pb sur un autre Tx. Il te faut aussi taper des commandes dans le cli, elles sont dans mon post.

 


image.png.4e9b0c6d9760e6d16754b99ba4d07f7f.png

Modifié (le) par Dujack
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Dujack a dit :

ca n’a jamais fonctionné sur le Tx3

merci @Dujack oui j'avais eu ce problème sur le TX3, mais c'est pas la même carte, on verra ..:)

Lien à poster
Partager sur d’autres sites
Il y a 3 heures, spid99 a dit :

Donc je reviens sur ma question ... Puis-je mettre le "F-Port" (est-ce bien le "Uninverted S.Port" ?)  sur le TX3 (en sachant que j'utilise déjà le RX3)

Même réponse qu'hier : une fonction par UART physique, c'est la règle. Donc pas de F.Port sur TX3 si l'UART 3 (RX3) est déjà utilisé pour autre chose.

Sur le R9MM, le pin dédié au F.Port et celui labellisé S.Port. C'est le fait de flasher le RX en F.Port qui fait que le S.Port devient en fait F.Port. L'aspect non inversé vient s'ajouter par dessus tout ça. Avec un R9MM tu as bien 2 pins F.Port, le premier qui est inversé (standard FRSky) et le second qui est non-inversé (que FrSky a souvent la brillante idée d'appeler inverted S/F.Port 🤯).

Il y a 3 heures, spid99 a dit :

Ou j'oublie et je le mets sur le SBus ..Point barre ?

Si tu n'as pas besoin de la télémétrie, alors tu peux tenter d'utiliser le F.Port sur un RX (SBUS), ca devrait marcher en théorie, à retester en pratique. Il faudra ajuster les lignes à passer dans le CLI selon que tu utilises le pin inversé ou pas.

Enfin, l'intérêt d'utiliser le F.Port sans profiter de la télémétrie est relatif. Dans ce cas là, pour rester dans un cas d'utilisation standard, tu peux aussi rester en SBUS et passer le RSSI par un canal de la radio. Ca fera autant de fils, mais ça monopolise un canal, c'est vrai.

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

@CriTof (Pour mes anciens R9) Après tous ces tests, je pensais que c'était bon, les lumières vertes étant allumées, j'avais remis le firmware ACCST-Flex dans le RM9 et suis parti voler  ..

Sauf que non, le firmware "Flex" ne passe pas sur les  ma Jumper ... Je viens de flasher le R9M avec le FCC simple et tout est bien revenu dans l'ordre, je suppose que pour ceux en LBT ce doit-être pareil, font chier chez FRsky ..

Modifié (le) par spid99
Lien à poster
Partager sur d’autres sites
Il y a 3 heures, spid99 a dit :

@CriTof (Pour mes anciens R9) Après tous ces tests, je pensais que c'était bon, les lumières vertes étant allumées, j'avais remis le firmware ACCST-Flex dans le RM9 et suis parti voler  ..

Sauf que non, le firmware "Flex" ne passe pas sur les  ma Jumper ... Je viens de flasher le R9M avec le FCC simple et tout est bien revenu dans l'ordre, je suppose que pour ceux en LBT ce doit-être pareil, font chier chez FRsky ..

Euhhh.... 

Rien à changé avec ma jumper T12. 

Juste Re blindé mon ensemble déjà en Flex ACCST EU-LBT et tout fonctionne Instantannement. 

Modifié (le) par CriTof
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

A moins que 🤔...Je n'avais pas flasher les RX en Flex ..

Ils doivent -être en FCC.

Ça doit-être ça. 🌟

Je les laisse pour l'instant, trop chiant de flasher les RX ..Du moment que ça fonctionne ..

Je ferais ça le jour ou je reçois le nouveau R9M

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Bon, je viens de recevoir le nouveau module, et c'est la déception 😒

Tous ça vient des radios ! Tous les modèles ACCST sortie avant fin 2019 ne sont tout simplement plus compatibles avec les RX ACCESS (R9), que se soit des Jumper ou des Frsky ..

Bref la seule solution est de changer de radio pour une ACCESS ! Ou tentez d'acheter les quelques RX encore en ACCST qui restent ...

Pour nous achever, les RX en ACCESS ne sont pas "flashable" avec les firmwares ACCST ...Cool Frsky ! Va falloir regarder les TBS finalement ..

A voir https://oscarliang.com/frsky-access-protocol/

Citation

 

Compatibilité matérielle descendante

Autant que je sache, ACCESS sera pris en charge sur certains des récepteurs Frsky existants, il vous suffirait de flasher un nouveau firmware pour prendre en charge ACCESS. Cependant, vous devrez acheter une nouvelle radio pour utiliser ACCESS, je ne pense pas que les anciennes radios ACCST supporteront ACCESS.

Vous aurez besoin de l'une de ces radios Frsky récemment publiées:

 

  •  
Modifié (le) par spid99
  • Wow 1
Lien à poster
Partager sur d’autres sites

Fuck Frsky !! ☠️

Je suis tout autant concerné... C'est juste un pur scandale de la part de ce constructeur ! 

J'espere qu'ils vont manger grave avec la concurrence entre Jumper et TBS ! 

En gros si t'as pas fait un "stock" De récepteur ACCST, ta radio tu peux la jeter!! 

Il me reste dans mes cartons un Xm+ un R-xsr un r9m mini et un R9mm ainsi que les derniers firmware qui vont bien. Ouf... 

Mais degouté pour ceux qui ont une Taranus ACCST et pas de backup RX radio

Fuck Frsky ! 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Tu m'as fait une frayeur, sachant que j'ai pour une centaine d'euros de R9 MM OTA en route vers chez moi 😅

Du coup je me suis motivé, j'avais un R9 MM OTA qui attendait dans son sachet depuis qques temps, je viens de tester : aucun problème pour l'utiliser avec ma vieille X9d et son module R9M de première génération en ACCST 🙂 J'ai poussé le vis jusqu'à le souder sur une vieille FC qui traînait pour être absolument certain que tout fonctionnait et RAS !

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...