Aller au contenu
DroneBuilds

OSD avec DJ"AÏE" / Cadxx low-power...


Messages recommandés

Bonjour a tous ceux qui me lirons.

Je suis à bout, j'en ai marre, des nuits presque blanches à chercher pourquoi...

J'ai monté mon premier drone, avec un Cadxx vista sur un F4/F55 de T-motor. J'ai galérer en apprenant sur le tas, mais ça peut "voler" !

Le hic aujourd'hui, c'est que j'ai réussi à avoir l'OSD dans les lunettes DJI 1 fois, après les manips betaflight d'UART, activé l'OSD, télémétrie etc. Une seule et p*tain de fois. Je n'ai pas volé, il était 3h du matin, j'ai armé, fait rebondir le drone (quel joie de le voir vivre la première fois), puis désarmé, débranché la batterie, finir les réglages GPS sur betaflight. Et puis je remet une batterie, plus d'OSD...

 

J'ai tout remis à jour tout ce qui pouvais être possible, lunette, cadxx, carte de vol. J'ai changer de soudure d'UART, inversé les fils trois fois Rx/Tx, refait les réglage betaflight 10 fois. Toujours rien... Au secours??

Un autre problème également, c'est une message d'erreur dans les lunettes DJI. Low-power mode. Unable . Qui s'enclenche dès la mise sous tension du quad (et le cadxx ce met a chauffer grave en à peine 2min, impossible de le toucher). Là ou mon premier OSD ce message n'apparaissait pas (enfin je crois, car javais le message armed/disarmed à la place en réponse à la radiocommande). Un lien entre tout ça, une solution? Cadxx HS?

 

Je vous avoue que j'ai les boules, pour un premier pas 1200 boules au total pour une vidéo HD mais sans infos batteries , gps, etc, je ne suis pas près de l'envoyer voler...

Aidez moi. Pitié haha. Merci d'avoir lu, et désolé si certaine fautes d'écritures vous choque ;)

Lien à poster
Partager sur d’autres sites

T'inquite pour les fote d'écriture 😄

Plusieurs sujets sur ce fofo devraient t'apporter un brin de lumière. 

Je laisse la main aux possesseurs de DJ"aïe" Pour que tu puisses enfin dormir sereinement avec les pouces sur ta radio commande 😎

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, CriTof a dit :

T'inquite pour les fote d'écriture 😄

Par contre... https://forum.wearefpv.fr/15-présentation/

À très vite 😉

J'ai finalisé la présentation en même temps que ton message je pense 😁. Si longtemps que je n'ai pas été sur des forums que je n'ai pas fait dans l'ordre.

  • Merci ! 1
Lien à poster
Partager sur d’autres sites
  • 4 weeks later...

Bonjour. 

Un message en guise de UP, mais aussi pour ajouter des informations.

J'ai fait flambé ma carte de vol en la manipulant après un crash. Un court circuit qui m'a fait fondre le câble de masse branché sur le cadxx, et une belle fumé blanche du dessous de la carte de vole. Donc j'ai changé de stack, de marque aussi, j'ai tout remonté en espérant que... Mais toujours pas d'osd (et du coup rebelote, changer d'uart, inversé etc). Le vista serait il défectueux de base (et abîmé du coup maintenant..?) Parce qu'un affichage une fois, un crash (j'avais aussi un fil HS du coup après autopsie). Pourtant le retour vidéo est nickel.

Du coup, deux grandes questions, je me demande comment je peux voir qu'il y a bien une sortie de signal au cul du vista entre le Rx et le Tx? Ça me permettrait de savoir si c'est un problème électronique, ou logiciel (car dans les info "device" des lunettes, la version du vista et de la caméra n'apparaissent pas...)

L'autre question c'est, à la limite voler sans osd c'est pas un soucis, mais sur une Tango 2 à jour, c'est possible d'avoir une alerte vocal pour la batterie, et les coordonnées GPS en cas de crash? (la télémétrie c'est ça ?) J'ai vu ça en fouillant sur youtube, sur des taranis.

Si une bonne âme peut prendre le temps de me répondre... Merci infiniment.

Lien à poster
Partager sur d’autres sites

Tu as activé le MSP du bon uart dans betaflight?

Et le "custom osd" dans les lunettes dji? 

il met quelques secondes a s'afficher dans les lunettes (de mémoire)

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a une heure, nochamo a dit :

Tu as activé le MSP du bon uart dans betaflight?

Et le "custom osd" dans les lunettes dji? 

il met quelques secondes a s'afficher dans les lunettes (de mémoire)

Hello et merci pour ta réponse 🙂

 

Oui bien sûr, j'ai déjà réussi à avoir l'affichage une fois, une seul fois... Pour moi le cablage est bon, le bon uart est activé, le custom osd des lunette, la télémétrie dans betaflight, les mises à jour pour tout...

 

Encore que si je ne l'avais jamais eu, je me dirais que je suis mauvais. Mais là, impossible de l'avoir de nouveau...

 

Le point positif avec ce problème, c'est que je connais bien betaflight maintenant, du moins c'est devenu familier 😅.

 

(D'ailleurs au passage, le low-powered disparaît avec l'armement du drone. Mais j'aurais aimé au moins le niveau de batterie, et les info GPS pour un jour pouvoir faire du long range. Et si je par sur l'achat d'un nouveau cadxx, pour un même résultat, je vais péter un câble et y foutre le feu🔥...)

 

Je dois être l'un des rares à avoir ce problème, et ça, ça fait chier 😅.

Lien à poster
Partager sur d’autres sites

C’est étrange effectivement.. tout est bien configuré dans la table des ports du coup j’imagine (screenshot et photo de ton cablage pour être sûr et éliminer cette possibilité ?)
Ton caddx est peut être effectivement abîmé (la masse avait quand même fondu) mais difficile à dire sans pouvoir tester avec un autre.
Ce que je trouve bizarre, c’est qu’à voir tu n’a même pas les infos du voltage batterie sur l’OSD DJI natif c’est bien ça ? Ce qui laisse penser que le caddx n’est pas capable de lire les données transférées via le smart audio..

Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Jon a dit :

C’est étrange effectivement.. tout est bien configuré dans la table des ports du coup j’imagine (screenshot et photo de ton cablage pour être sûr et éliminer cette possibilité ?)
Ton caddx est peut être effectivement abîmé (la masse avait quand même fondu) mais difficile à dire sans pouvoir tester avec un autre.
Ce que je trouve bizarre, c’est qu’à voir tu n’a même pas les infos du voltage batterie sur l’OSD DJI natif c’est bien ça ? Ce qui laisse penser que le caddx n’est pas capable de lire les données transférées via le smart audio..

Bonjour Jon et merci d'avoir pris le temps.

L'UART 5 est bien activé dans betaflight (j'ai même flasher sur emuglight, au cas où, on ne sais jamais)

En testant un truc ce matin, j'ai remarqué qu'il y avait un contact entre le GND et le Rx, avec une résistance de 6.3ohm. j'ai coupé le câble du GND pour vérifier mes soudures sur la FC. Le contact est bien sûr le vista. Si tu as (ou si quelqu'un à) la possibilité de faire ce test, ça pourrait être une piste si c'est anormal ou non ?

Et effectivement je n'ai pas d'infos également dans le natif DJI. Chose que je n'avais pas remarqué, cherchant absolument à avoir cet OSD...

 

IMG20201011105630.jpg

IMG20201011105601_03.jpg

Lien à poster
Partager sur d’autres sites

Je suppose que le vista est connecté sur le haut de la FC sur la première photo c’est bien ça ? C’est quoi comme FC ? Je vois pas les marquage sur le groupe de 4 pads regroupés.
Après, je ne suis pas un expert en soudure mais il me semble qu’elles sont limites (d’autres plus expérimentés pourrons mieux s’exprimer là-dessus).
Tu as bien branché le TX du vista sur le RX de la FC et vice versa ? Désolé mais je pose la question pour éliminer toutes les possibilités.

Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Jon a dit :

Je suppose que le vista est connecté sur le haut de la FC sur la première photo c’est bien ça ? C’est quoi comme FC ? Je vois pas les marquage sur le groupe de 4 pads regroupés.
Après, je ne suis pas un expert en soudure mais il me semble qu’elles sont limites (d’autres plus expérimentés pourrons mieux s’exprimer là-dessus).
Tu as bien branché le TX du vista sur le RX de la FC et vice versa ? Désolé mais je pose la question pour éliminer toutes les possibilités.

Le vista est connecté sur le Rx5 et Tx5 sur le milieu de la photo. Connectant le Rx du vista (câble jaune) sur le tx5 du la FC (qui est une mamba f722).

 

Sinon oui, mes soudure sont limites, mais mieux que sur la première FC que j'ai grillé 😅. Mais une fois le drone sous tension, j'obtiens une tension de 2,9v entre le Rx5 et le Tx5. Donc j'ai bien une sortie de signal non?

Lien à poster
Partager sur d’autres sites

La mesure doit se faire entre rx et masse et aussi entre tx et masse. Comme c’est un uart, la tension doit etre de l’ordre de 3.3v crête mais n’est pas de type continue et ne se mesure pas avec un mulitmetre mais un oscillo. Avec un multi ca te dira seulement s’il y a un signal mais pas forcement s’il est correct.

Lien à poster
Partager sur d’autres sites
Il y a 7 heures, Dujack a dit :

La mesure doit se faire entre rx et masse et aussi entre tx et masse. Comme c’est un uart, la tension doit etre de l’ordre de 3.3v crête mais n’est pas de type continue et ne se mesure pas avec un mulitmetre mais un oscillo. Avec un multi ca te dira seulement s’il y a un signal mais pas forcement s’il est correct.

Salut Dujack. Merci pour cette précision.

Je vais tenter de trouver quelqu'un avec un oscillo la semaine prochaine. Mais ça finira dans l'achat d'un nouveau caddx je pense... Depuis le retour de ce problème je n'ai pas revolé, et aujourd'hui après configuration, je vois que le low-power machin ne disparaît pas à l'armement. Donc le système caddx et dji ne détecte plus non plus l'armement du drone. C'est donc de pire en pire. J'ai un retour vidéo et c'est tout. Même la mise a jours pour du 50mbps ne change pas (je plafonne a 25,4mbps..)

Affaire à suivre donc. Reste plus qu'à trouver un caddx en promo 😁

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...