Aller au contenu
DroneBuilds

Pas d'info OSD


Messages recommandés

Bonjour,

 

Je ne parviens pas à avoir les infos de l'OSD dans mon masque..

Je viens de terminer le montage de mon drone : Une frame Vega FX HD, 4 moteurs flywoo 2450 kv, une stack complète T-MOTOR F4 HD + FA PRO II, un récepteur FrSky R-XSR, le système DJI pour voir quelque chose de correct, un module GPS BEITIAN BN-220 et le tout contrôlé par une Taranis QX7.

La doc dit " Uart 4 - Rx need connecting esc's telemetry to read data " mais dans l'onglet "Ports" sur BF, je ne sais pas si je dois mettre quelque chose dans la colonne " Sortie télémétrie " ou dans " entrée capteur ".. ou les deux??

Pourriez-vous m'aider s'il vous plaît!

 

Merci d'avance. ✌️

Lien à poster
Partager sur d’autres sites

Salut,

as-tu quand même les infos du voltage de la batterie ?

si non, as-tu sélectionné « msp » dans le tableau « ports » de Betaflight pour l’UART 4 ?

ensuite pour l’OSD, une fois que le msp est configuré correctement, tu dois aller dans le menu « display » des lunettes et cocher « custom OSD » « ON »

Lien à poster
Partager sur d’autres sites

Salut, Merci de m'aider 🙂

 

J'ai juste les info du système DJI ( voltage batterie lunette, qualité de réception,...) mais rien qui vient de l'OSD..

J'ai coché, dans Uart 4, la colonne "config. MSP" et dans les lunettes custom OSD ON mais ça n'a rien changer..

Il me semblait qu'il fallait mettre quelque chose dans l'Uart 4 dans la colonne "télémétrie/ Capteur ou périphérique" je me trompe?

Lien à poster
Partager sur d’autres sites
il y a 9 minutes, Tanguy a dit :

Il me semblait qu'il fallait mettre quelque chose dans l'Uart 4 dans la colonne "télémétrie/ Capteur ou périphérique" je me trompe?

Oui, juste MSP.

Tu as bien croisé TX(dji)—>RX(fc) RX(dji)—>TX(fc).

Lien à poster
Partager sur d’autres sites

Si tout ce qu’on a dit est bien correcte, as-tu bien configuré ton OSD dans l’onglet OSD de Betaflight ? (Je pose quand même la question)

tu coches les éléments que tu veux voir apparaître et tu les positionnes où tu veux.

si tu as le voltage de la batterie dans tes lunettes sur l’OSD DJI c’est déjà bon signe, ça veut dire que le air unit reçois bien les infos

Il y a 2 heures, Tanguy a dit :

Il me semblait qu'il fallait mettre quelque chose dans l'Uart 4 dans la colonne "télémétrie/ Capteur ou périphérique" je me trompe?

Non pas besoin pour avoir l’OSD

pour l’inversion RX et TX, je pense que tu utilise le plug prévu à cet effect dans la stack T-motor pour connecter le air unit. Donc ça devrait être bon

Modifié (le) par Jon
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
Le 06/11/2020 at 15:41, Attafr a dit :

Oui, juste MSP.

Tu as bien croisé TX(dji)—>RX(fc) RX(dji)—>TX(fc).

Okey, et oui comme dit Jon, j'utilise le plug prévu sur la stack.

Le 06/11/2020 at 17:40, Jon a dit :

Si tout ce qu’on a dit est bien correcte, as-tu bien configuré ton OSD dans l’onglet OSD de Betaflight ? (Je pose quand même la question)

 

Oui j'ai configurer l'OSD.

Donc dans Port, j'ai coché "configuration/MSP" sur l' uart 4 .

Dans configuration, j'ai coché OSD dans "autre fonctionnalités"

Et dans OSD j'ai cocher les infos que j'aimerais avoir dans mes lunettes.

Y a autre chose?

Le 06/11/2020 at 17:40, Jon a dit :

si tu as le voltage de la batterie dans tes lunettes sur l’OSD DJI c’est déjà bon signe, ça veut dire que le air unit reçois bien les infos

 

J'ai le voltage de la batterie des lunettes, pas du drone. J'ai aussi la qualité de réception entre le air unit et les lunettes, j'ai la fréquence de rafraichissement et No SD cart.

Je n'ai aucune info du drone, juste l'image.

Je comprend pas pq j'ai rien..

 

Encore merci de prendre le temps pour m'aider 🙂

Lien à poster
Partager sur d’autres sites

Hello,

 

Là il parle de Caddix vista. Moi j'ai le aire unit et il dit que c'est quand les personnes on eu l'OSD et l'on perdu.

Moi j'ai encore jamais eu l'OSD dans mon masque.

Je pense plus à un problème de config mais je comprend pas quoi.

Lien à poster
Partager sur d’autres sites

Tu as retiré le fil du SBus qui vient du Vista ?

Tu as bien mis/remis les dernières MàJ ?

Tu peux poster tes Page betaflight: port, configuration, OSD

Lien à poster
Partager sur d’autres sites
Il y a 4 heures, Attafr a dit :

Tu as retiré le fil du SBus qui vient du Vista ?

Tu as bien mis/remis les dernières MàJ ?

Tu peux poster tes Page betaflight: port, configuration, OSD

Non je n'ai pas retiré le fil du SBus qui vient de l'air unit. Il faut le retirer?

Aire unit et Vista c'est pareil?

Les Màj sont bonnes.

 

 

Port.PNG

Config.PNG

Config 2.PNG

Config 3.PNG

OSD.PNG

OSD 2.PNG

Lien à poster
Partager sur d’autres sites
il y a 9 minutes, Tanguy a dit :

Non je n'ai pas retiré le fil du SBus qui vient de l'air unit. Il faut le retirer?

Sauf si tu as une radio DJI !

uart serial 5, c’est ton RX ?

Oublie le GPS dans un premier temps!

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Tanguy a dit :

Non j'ai une Taranis QX7 😄

Il me sufit juste de couper le fil?

Tu peux le sortir avec un cutter en soulevant les petite languette blanche du connecteur de la nappe, des 2 côtés.

8CDFC68E-9538-41E8-85F4-ECC62A3831D7.jpeg.5587d5a06791d642cb1e0fe2578e620b.jpeg
 

en moins propre tu peux couper !

Modifié (le) par Attafr
  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 29 minutes, Attafr a dit :

Tu peux le sortir avec un cutter en soulevant les petite languette blanche du connecteur de la nappe, des 2 côtés.

8CDFC68E-9538-41E8-85F4-ECC62A3831D7.jpeg.5587d5a06791d642cb1e0fe2578e620b.jpeg
 

en moins propre tu peux couper !

Le fil est retiré mais l'OSD n'a pas apparut.

Se que j'ai mis dans port, configuration, OSD est correct?

Lien à poster
Partager sur d’autres sites

Oui, apparemment tout est juste, pour le GPS je n’en ai jamais utilisé, alors je peux pas aider.

Dans ton OSD, avant de mettre TOUT, utilise seulement quelques variables, par exemple désarmé et tension lipo... il y a peut-être un conflit? Je sais que tu ne peux pas avoir toutes les options avec dji... je crois que viseur fonctionne, mais pas le reste 

Lien à poster
Partager sur d’autres sites

Je viens de tester l'OSD juste avec la tension et désarmé et je ne voit toujours pas dans les lunettes.. et j'ai test juste avec la tension et juste avec désarmé et toujours rien...

Ça commence à me casser les cou***** 🥵

Je  comprend pas pourquoi j'ai rien..

HEEELLPPP 😭

Lien à poster
Partager sur d’autres sites
Il y a 13 heures, Tanguy a dit :

Je viens de tester l'OSD juste avec la tension et désarmé et je ne voit toujours pas dans les lunettes.. et j'ai test juste avec la tension et juste avec désarmé et toujours rien...

Ça commence à me casser les cou***** 🥵

Je  comprend pas pourquoi j'ai rien..

HEEELLPPP 😭

j’ai une stack T-Motor (mais F7) sur un de mes quad avec un air unit. Dès que j’ai un peux de temps, je vais tenter de comparer ta config et la mienne. Mais ce sera pas avant un moment :S 

Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Jon a dit :

j’ai une stack T-Motor (mais F7) sur un de mes quad avec un air unit. Dès que j’ai un peux de temps, je vais tenter de comparer ta config et la mienne. Mais ce sera pas avant un moment :S 

Ok top! Merci!

Lien à poster
Partager sur d’autres sites

Okey les gars, c'est moi qui suis une grosse mer** 😅

 

Après avoir regarder sur Luunet, je me suis dis que j'allais tester de cocher "MSP" sur tout les Uart (un à la fois) et BIM!! comme par magie, l'Uart 2 me montre l'OSD.

Je comprend pas pourquoi ils disent dans la doc "Uart 4 - Rx need connecting esc's telemetry to read data ". C'est pour quoi? La télémétry c'est bien les infos que montre l'OSD?

 

Mais effectivement sur la prise qui va de la stack au air unit il y a Uart2 tx et rx.

Comme tu disais, on ne sait pas tout avoir sur l'OSD...

Je ne sais pas voir la boussole ni la ligne horizontale.

Le GPS fonctionne bien, je l'ai mis juste pour avoir la position Lat. , long. et la vitesse (max 127 km/h testé se matin 😁)

 

Encore merci d'avoir pris le temps de m'aider! 🙂✌️

  • Haha 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...