Aller au contenu
DroneBuilds

Flash FC Iflight SUCCEX D 20A AIO impossible


Messages recommandés

 Bonjour,

Je n’arrive pas à flasher mon FC Iflight SUCCEX D 20A AIO dans BF. Suite à une première tentative qui a échoué mon FC ne peut plus se connecter et je ne peux plus rien faire 😞

J’arrive à le mettre en DFU en appuyant sur le bouton boot avant de connecter en USB. J’ai utilisé avant IMPULSE RC pour MAJ des drivers STM32 (si j’ai bien suivi).

Pour la cible je ne peux pas choisir exactement la SUCCEX D F4, BF ne me propose que la SUCCEX E F4 : Est ce un problème?

Si ce n’est pas le problème, je peux lancer le flashage de la FC en cochant no reboot sequence, full chip erase et manual baud rate 256000.

L’effacement se fait sans problème puis le flashage démarre et s’arrête en plein milieu. En haut à gauche il est indiqué « périphérique USB fermé avec succès »

La barre de progression est stoppée au milieu et plus rien ne se passe. Si quelqu’un est capable de m’aider je suis preneur !

 

20A6DD9A-0E1A-4B99-91A1-310598D2E89B.thumb.jpeg.949e18f071bdad1cdabd97c3a25a7c16.jpeg

4EB4B664-F9AB-4E23-92DE-3D71D7052808.jpeg

Modifié (le) par FLOWR-PV
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Maintenant j’ai un autre problème 🙂 

La FC est pour un iflight A85HD.

J’ai donc pu flasher la FC. J’ai repris le CLI fourni sur le site iflight pour mon modèle et mes moteurs. 

J’ai bindé ma Tango 2 avec le quad. Lumières vertes OK. Les moteurs tournent. Par contre les sticks de la radiocommande ne marchent pas dans BF. A priori l’UART sélectionné pour le RX est le bon (UART 2 pour le serial RX). J’ai aussi essayé avec l’UART 1.  Mais les sticks ne bougent pas. Je continue mes recherches mais si vous avez des idées ! J’ajoute quelques copies d’écran 

 

IMG_0181.png

IMG_0182.png

IMG_0183.png

IMG_0184.png

IMG_0185.png

Modifié (le) par FLOWR-PV
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a 15 minutes, FLOWR-PV a dit :

J’ai repris le CLI fourni sur le site iflight pour mon modèle et mes moteurs. 

Comment as tu bindé ton RX, tu es passé par TBS AgentX pour mettre à jour ta tango et éventuellement exécuter le bind ?

tu as définis les inputs/mixer sur le modèle de ta radio ?

Je ne connais pas la tango, mais j’ai cru comprendre que cela ressemble à une radio openTX !

j’ai été voir le dump, tout correspond (je suis étonné du bidirectional dshot, mais cela a l’air juste) je pense qu’il faut regarder du côté de la radio, il doit y avoir de mauvais paramètres... CRSF, SBUS etc....

Lien à poster
Partager sur d’autres sites

Yes Tango 2 mise à jour via TBS AGENT ainsi que le crossfire interne de la Tango et bind avec le RX qui a été mis à jour lors du bind.

Je précise que cela avait marché avant que j’ai un problème avec un moteur. J’avais mis à jour les ESC avec BLHELI avant finalement de changer le moteur défectueux. Depuis les sticks ne fonctionnent plus. J’avais imaginé du coup après pas mal de manip remettre tout à 0, flasher la FC, remettre le CLI d’origine, flasher les ESC. 

Quand je lance le quad tout semble OK. Mais rien ne s’affiche dans BF concernant les sticks. 

En précision j’ai aussi un HGLRC SECTOR 150 et avec lui tout marche bien. 

Lien à poster
Partager sur d’autres sites
il y a 8 minutes, FLOWR-PV a dit :

En précision j’ai aussi un HGLRC SECTOR 150 et avec lui tout marche bien. 

Tu as essayé de croiser les RX entre les deux ? C’est peut-être un problème de ce côté ?

Lien à poster
Partager sur d’autres sites
il y a 21 minutes, Attafr a dit :

Tu as essayé de croiser les RX entre les deux ? C’est peut-être un problème de ce côté ?

Tu veux dire échanger physiquement la tbs nano rx du sector et celle du iflight ?  Si tu penses à ça non

la nano pourrait se connecter et pourtant ne pas fonctionner ? Il 

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

J’ai fini par faire le test et d’échanger les 2 nanos TBS. Ca ne fonctionne pas non plus. Le FC est peut être HS. J’ai testé tout ce que j’ai pu trouver. Ceci dit j’ai appris plein de trucs. Je pense tenter de changer le FC.

Modifié (le) par FLOWR-PV
Lien à poster
Partager sur d’autres sites
Le 06/01/2021 at 00:50, Joelamoule a dit :

Tente cette manip en cli et save ensuite

 

set serialrx_inverted = OFF

Merci mais déjà tenté et non ça ne marche pas. 

J’ai changé le FC au final...ou comment rentrer dans le monde FPV en achetant un BNF pour voler rapidement et au final devoir démonter complètement le quad, tout dessouder...et le remonter, souder le nano XF, le XC30 et les moteurs sur un petit FC avec des petits pads supers proches... plugguer le caddx, la caméra, configurer dans BF, utiliser BLHELI etc...Mais c’était bien j’ai énormément appris. J’ai eu une galère sur les moteurs que j’ai pu résoudre via BLHELI (flash de la dernière version et inversion du sens de rotation de 2 moteurs sur 4) et au final ça vol !

  • J'aime 2
Lien à poster
Partager sur d’autres sites

C'est sûr que tu y passe plus de temps mais aufinal je me demande si j'aime pas autant bidouillé mon build que voler avec, parce que au final ça fait parti du hobby

  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Joelamoule a dit :

C'est sûr que tu y passe plus de temps mais aufinal je me demande si j'aime pas autant bidouillé mon build que voler avec, parce que au final ça fait parti du hobby

Oui tu as raison. J’aurais pas cru mais il y a un vrai côté sympa à bidouiller et essayer de trouver une solution. C’est assez gratifiant quand tu la trouves ! Et au final je pense que tu vols mieux si tu es confiant sur le fait de savoir réparer ton quad, tu as moins peur et tu te tentes plus de trucs. 

  • J'aime 1
  • +1 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...