Aller au contenu
DroneBuilds

R-XSR bindé Taranis QX7 mais pas de réponse sur Bétaflight


Messages recommandés

Hello guys,

Vous êtes mon seul espoir... Ca fait un an que j'essaye de monter ce drone, j'y suis presque mais je bloque là. Après avoir décollé qq secondes et un atterrissage légèrement brusque j'ai eu un Rx Lost. J'étais bien bindé mais aucune réaction sur bétaflight. Alors j'ai changé mon Frsky Xm+ pour un R-XSR tout d'abord en SBUS. Je précise que ma carte de vol est une MAMBA f405 MK2. Même problème...

Alors j'ai décidé d'essayer en F.port, ce qui ne change rien, tjrs bindé mais rien sur BT.

J'ai flashé ma Taranis avec "XJT_ACCST_2.1.0_LBT.frk" et mon Rx avec "RXSR_ACCST-2.1.0_Fport_LBT.frk". Sur Bétaflight je suis bien en Rx série type Frsky Fport. Dans le CLI j'ai essayé les deux commandes set serialrx_inverted = off et aussi =on.

Pensez-vous que le problème vient des circuits de la carte de vol qui seraient "grillés" ?

Vous trouverez ci-dessous mon cv et mon curri... une photo de ma connection R-XSR et FC. (Attention la photo est trompeuse, le noir est bien soudée sur le GND. Le F.port sur PPM et le positif sur le petit carrée. oui j'ai utilisé un fil rouge pour le F.port)

136435741_218837343239955_6965357594592718192_n.jpg.86c5c8a71bc08cbda39452991245a47e.jpg136089021_745634846082412_7756526502414794821_n.jpg.baa4f5fe7c7bddd3e395bbeb2b672772.jpg

Au plaisir de pouvoir voler un jour avec vous ! Bonne année !!

Lien à poster
Partager sur d’autres sites

J'ai essayé sur le SBUS même résultat. Donc là je devrais connecté le F.port au TX1 par exemple? il n'existe pas présent sur ma carte, ou ce que je peux soudé mon F.port d'après toi et quelles sont les modifications à faire sur les port dans bétaflight? Merci pour ton aide Joelamoule 😉

136376092_408680613787230_2756258636273609053_n.jpg.3aab9e0b4754904bfcb9ed2267f60e74.jpg2_b407e904-2a0b-4693-8104-94b9e77468e4.j

Lien à poster
Partager sur d’autres sites
il y a 17 minutes, emino a dit :

J'ai essayé sur le SBUS même résultat. Donc là je devrais connecté le F.port au TX1 par exemple? il n'existe pas présent sur ma carte, ou ce que je peux soudé mon F.port d'après toi et quelles sont les modifications à faire sur les port dans bétaflight? 

 

T'es sur que le PAD TX1 n'existe pas ??? 😉 (Dixit ton document joint)

Capture d’écran 2021-01-08 à 12.27.31.jpg

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Et pour répondre à ta question @emino "ou ce que je peux soudé mon F.port d'après toi et quelles sont les modifications à faire sur les port dans bétaflight? "

Tu prends le pad LED que tu passes en Softserial pour ton smartaudio VTX . Ainsi tu libères un TX pour ton F-Port .

Aussi simple que ça ! 😉

Modifié (le) par CriTof
  • Wow 1
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

N'écoute pas @CriTof il te complique la vie 😁 (d'ailleurs c'est Oscar Luang qui le dit ici)

How to Setup FPort?

The “SmartPort” pin on your receiver becomes “FPort” output.

Connection

Simply connect the receiver’s SmartPort pin to a free UART TX pin on your flight controller.

Don’t use soft-serial for FPort! It’s okay for SmartPort Telemetry, but it’s too slow for RC links. If you absolutely have no way to connect FPort, just go with the good old SBUS and SmartPort.

déjà sur ta photo le pad tx1 n'existe pas en effet malgré ton schema qui dit le contraire tu ne dois pas avoir la bonne version de stack mais c'est pas grave.

Soude ton récepteur sur le tx6 ainsi que l'alim et la masse ça fera plus propre au même endroit et cela t'évitera de passer au softserial.

ensuie dans betaflight tu passé ton uart 6 en serial RX et dans l'onglet configuration tu passé bien en protocole fport.

enfin pour le fun dans le cli tu tape ça :

set serialrx_halfduplex = ON

set serialrx_inverted = OFF

save

Et la ça devrait aller

PS:install vite un buzzer autonome ça sera toujours plus safe pour le retrouver.

 

Lien à poster
Partager sur d’autres sites
il y a 36 minutes, Joelamoule a dit :

N'écoute pas @CriTof il te complique la vie 😁 (d'ailleurs c'est Oscar Luang qui le dit ici)

 

PS:install vite un buzzer autonome ça sera toujours plus safe pour le retrouver.

 

 

Vraiment pas compliqué pour un F-Port aux 'ptits oignons !! Mais alors... vraiment pas compliqué ! (Tuto Oscar Liang, évidement !) 

Et un gros +1 pour le buzzer autonome. 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites
il y a 20 minutes, emino a dit :

Merci CriTof et Joelamoule 🙂, mais ça marche toujours pas haha ! J'ai essayé le soudage Tx6 avec masse et alim comme tu as dis !

Sans dec, t'as soulevé l'étiquette papier qui traverse ta FC  pour aller découvrir le Pad TX1 ... ? 

J'ai tout donné sur ce coup 😁. J'en reste Là.  Je viens de me faire une MK2 mini ET une MK2 standard ces 3 dernières semaines, en F-port, ça fonctionne parfaitement du premier coup ! Aussi bien sur le TX1 que par le pad led remappé  Sorftserial pour liberer un TX (Le 3 précisément) 🤟

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites

Et onglet config c'est bien en fport?

Sinon ton RX est peut être en mode ppm

SBUS/CPPM output (BLUE LED stay lit indicates R-XSR in SBUS mode, otherwise in CPPM mode)

How to switch SBUS and CPPM signal: Long press the F/S button on the receiver for 4 seconds, the BLUE LED will flash three

times, indicating the switch is complete

  • +1 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...