Aller au contenu
DroneBuilds

Je n'arrive plus à activer "Serial RX" sur l'UART2.


Messages recommandés

Bonsoir à tous,
 
Dans un premier temps, pour améliorer le retour FPV, j'ai changé la caméra d'origine de mon "Green Hornet" par une "CADDX Baby Ratel". Le premier weekend, j'ai effectué plusieurs vols et tout fonctionnait très bien. Mais le week-end suivant au premier décollage, je constate que l'OSD avait disparu. De retour à la maison, je suis rentré dans la configuration et en cherchant une piste, j'ai décoché par erreur le "Serial RX". Depuis je n'arrive plus à le re activer, je parviens à le faire sur tous les UART, sauf sur l'UART2 sur lequel est réellement branché le "RX"!
J'ai essayé en ne laissant que "USB VCP" sur la ligne 1 et "Serial RX" sur l'UART2. Quand j'enregistre, la carte redémarre et positionne systématiquement "Serial RX" sur l'UART6.
En photo jointe, c'est ma configuration d'origine, que je n'arrive plus à rétablir.
J'ai vraiment besoin de vôtre aide, je suis débutant et donc carrément paumé sur le coup.

uart.jpg

Lien à poster
Partager sur d’autres sites
il y a 6 minutes, DunceDrone a dit :
Bonsoir à tous,
 
Dans un premier temps, pour améliorer le retour FPV, j'ai changé la caméra d'origine de mon "Green Hornet" par une "CADDX Baby Ratel". Le premier weekend, j'ai effectué plusieurs vols et tout fonctionnait très bien. Mais le week-end suivant au premier décollage, je constate que l'OSD avait disparu. De retour à la maison, je suis rentré dans la configuration et en cherchant une piste, j'ai décoché par erreur le "Serial RX". Depuis je n'arrive plus à le re activer, je parviens à le faire sur tous les UART, sauf sur l'UART2 sur lequel est réellement branché le "RX"!
J'ai essayé en ne laissant que "USB VCP" sur la ligne 1 et "Serial RX" sur l'UART2. Quand j'enregistre, la carte redémarre et positionne systématiquement "Serial RX" sur l'UART6.
En photo jointe, c'est ma configuration d'origine, que je n'arrive plus à rétablir.
J'ai vraiment besoin de vôtre aide, je suis débutant et donc carrément paumé sur le coup.

uart.jpg

Quand tu définis l’uart 2, tu fais bien un save ?!

Tu peux donner un lien, ou la description de ta FC...

A+

Lien à poster
Partager sur d’autres sites

Merci pour ton aide.

Oui quand je fais un save, la carte redémarre et me positionne systématiquement "Serial RX" sur l'UART6.

C'est celle- ci : SucceX-E Mini F4 2-6S Flight Controller

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Fais un backup : dump all et diff all, tu sauves les 2 dans un fichier text (.txt)

Après tu réinitialise ta carte... ensuite tu peux la re configurer en re injectant ton diff all

4E7F54C4-5953-4A9F-9F2A-094C07C50C3A.jpeg.50356206a5dfc75c97d0b8f0ea46dafb.jpeg

Modifié (le) par Attafr
  • J'aime 1
Lien à poster
Partager sur d’autres sites

1 - J'ai fais mes 2 backup (dump all et diff all) dan 2 fichiers texte.

2 - J'ai réinitialisé les réglages.

Avant de restaurer, j'ai essayé d' activer le "Serial RX" sur  UART2, la carte persiste à le positionner sur UART6.

Lien à poster
Partager sur d’autres sites
il y a 9 minutes, DunceDrone a dit :

Je viens de restaurer mon "diff_all" et le soucis persiste toujours.


Tu peux poster le DUMP ALL !

Tu as déjà flashé une FC ?

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Non jamais flashé de FC, c'est la première fois que je vais aussi loin dans "betaflight configurateur" 🥴

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites

Tu peux regarder cette série de vidéos (la deuxième explique comment flasher sa FC) Tu pourras même la flasher en 4.2.6 !

Si tu as des questions n’hésite pas avant de te lancer !

Je pense que c’est un problème de firmware, je vois mal un problème matériel!

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Super !

J'ai réussit à effectuer la mise à jour vers la version 4.2.6, j'ai pu recharger mon dernier diff et re configurer les ports comme d'origine. 

image.thumb.png.dcd9c9e34c5895cf2f7abafe47e78b1b.png

Mais le RX ne reçois pas d'information de la télécommande, faut-il refaire le "bind' ?

Et je n'ai pas de retour vidéo.

Lien à poster
Partager sur d’autres sites
il y a 57 minutes, DunceDrone a dit :

Mais le RX ne reçois pas d'information de la télécommande, faut-il refaire le "bind' ?

Non pas besoin de bind, peut-être sur la page configuration de betaflight remettre serialrx... + SBUS 

 

normalement tu devrais simplement pouvoir re injecter ton diff all (pas le dump)...

Modifié (le) par Attafr
  • J'aime 1
Lien à poster
Partager sur d’autres sites

Ce matin j'ai repris les investigations.

Dans tous les cas, même si le drone ne re décolle pas, tu m'auras énormément fait évoluer sur le sujet.

Petit récapitulatif des tests de ce matin :

1 - Je remet la FC en configuration par défaut.

2 - Je me re connecte et j'ai un message d'avertissement à propos de l'accéléromètre et du protocole moteur.

3 - Je recharge mon backup diff. (j'ai également testé cette procédure complète avec le dump).

4 - Je recalibre l'accéléromètre et je re configure les ports (j'ai également testé sans les re configurer).

5 -  J'ai également testé avec les 5 protocole pour le récepteur.

image.png.2188789e6022f0da1dfc4c3d90afe751.png

Toujours pas de récepteur actif et toujours pas de retour vidéo.

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites

RX série (SPEKTRUM...) c’est bon, en dessous tu mets SBUS !

Tu es sûr que ton XM est bindé à ta radio ? (Led qui change d’état quand tu éteins la radio) Il est bien connecté sur nR2 de ta radio ? Quand tu fais les tests, tu as bien une lipo ? Sinon le rx n’est pas alimenté.

Tu as du souder quelque chose pour changer ta caméra ?

Tu peux faire tourner tes moteurs (sans hélices) depuis BF ?

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Je viens de démonter les hélices (une première pour moi) pas évident et j'arrive à faire tourner les 4 moteurs.

Le XM clignote en rouge au démarrage du drone et passe en vert quand j'allume la radio.

Oui je teste avec une lipo connectée.

J'ai soudé la rallonge de la nouvelle caméra sur une bonne partie des fils de l'ancienne caméra, pour être sur de ne pas toucher la FC.

Je suis un maniaque, j'essaie de travailler le plus proprement possible 😉

J'ai modifié selon tes recommandations

Citation

RX série (SPEKTRUM...) c’est bon, en dessous tu mets SBUS !

Génial ! J'ai retrouvé le RX, j'arrive enfin à armer.

Il ne me reste plus qu'a retrouver le VTX. J'ai bien vérifié, je suis sur la bonne fréquence.

image.png.99b2cfd6f237b2972e73d4dfb46686e8.png

Il reste sur périphérique non prêt alors que la lipo est branchée ?

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites

Tu as regardé le protocole de transmission vidéo (NTSC,PAL,AUTO) met sur AUTO !

Tu as bien définis la table VTX ? Enlève « faible puissance d’émission » OFF

verifier que l’osd est activé.

  • J'aime 1
Lien à poster
Partager sur d’autres sites

La table VTX provient du site du fabriquant.

Dans l'onglet configuration L'OSD est activé.

Affichage des infos sur l'écran (OSD)

J'ai positionné sur Off "Faible puissance ..."

Je ne trouve pas ou configurer le protocole de transmission (NTSC,PAL,AUTO) .

Est-ce que mon périphérique est bien configuré au niveau des ports ?

image.thumb.png.74294b156da91c2a191e33fccf8a5557.png

Toujours pas de retour vidéo.

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites
Il y a 2 heures, DunceDrone a dit :

Est-ce que mon périphérique est bien configuré au niveau des ports ?

Oui, si tu es en Tramp... contrôle si tu n’es pas en Smartaudio ?

les ESC, tu peux enlever, ça sert à rien !

B6EB1991-C07F-49D3-A285-2E367FE3EC2B.jpeg.dd286414e39e2dd94a63c884bd3d1e22.jpeg

peut-être aussi au niveau de la caméra... apparemment elle a un OSD 

OSD de la caméra

Spearte OSD

 

Tu devrais avoir un bidule dans le style...

1FC1D926-3E30-4F1F-9FC7-FC13C2DBA65B.jpeg.afe9f3b3b7330909ef4ff882a0347bf7.jpeg

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Je te confirme, ma camera à bien un OSD avec une petite télécommande, mais comme pour le moment je n'ai pas de retour vidéo, je ne peut pas le consulter.

Je n'ai pas de section "Format Video" dans l'onglet OSD.

image.png.23338dc56a1b5c5c0152d10b8a60e615.png

Si c'est bien dans l'onglet "Emetteur vidéo" que je dois consulter le mode, je suis bien en "Tramp".

image.png.c391f73619bc55036f08d6175c8f44e6.png

Modifié (le) par DunceDrone
Lien à poster
Partager sur d’autres sites
Il y a 1 heure, DunceDrone a dit :

je suis bien en "Tramp".

C’est le VTX (sa marque, son modèle) qui définis si tu dois être en Tramp ou Smartaudio ! Comme cela fonctionnait avant, j’en déduis que tu es bien en Tramp !

L’OSD de ta CAM peut avoir une incidence sur ton signal vidéo. Tu as deux solutions, 1) tu remets ton ancienne CAM pour voir si cela résout ton problème. 2) Tu configures l’OSD de ta nouvelle CAM en « dehors » de ton qwad... il te faut un écran RGB où tu branches directement ta CAM (signal et moins sur une prise idoine pour te connecter à l’écran et une alimentation pour la caméra!).

Sur BF, en haut à droite, tu as un « switch » EXPERT MODE, tu peux cocher ça, voir si cela t’offre les options NTSC/PAL...

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Suivant tes préconisations, je remonte la camera d'origine, je teste et toujours pas de retour vidéo.

Comme la frame est ouverte, je décide de désassembler la stack et là je constate que le fil rouge (+5V) et bien en place mais semble en son extrémité plus souple que les autres. Je tire légèrement dessus et il se détache instantanément du VTX, je le ressoude et je récupère enfin le signal vidéo et l'OSD. Pour le moment, je laisse la caméra d'origine en attendant de trouver une solution pour accéder à l'OSD de la CADDX.

C'est infernal cette série de concours de circonstances : perte de l'OSD, puis quelques temps plus tard perte du signal vidéo, ensuite impossible de réactiver le RX.

Sans toi mon "Green Hornet" n'était pas prêt de re voler, tout ceci à été très très instructif pour moi.

Je vais faire un dump et un diff, puis profiter de mon drone 😉

Merci encore pour ta pédagogie et tout ce temps que tu m'a consacré.     

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...