Aller au contenu
DroneBuilds

BOOTGRACE malgré attente


Messages recommandés

Bonjour,

Je n'arrive vraiment pas à comprendre pour Betaflight (ou OSD) m'affichent "BOOT_GRACE_TIME" (ou "BOOTGRACE") lorsque j'essaye d'armer. J'ai beau attendre 15 secondes ou rentrer dans le CLI pour attribuer la valeur 1 à "pwr_on_arm_grace", l'erreur persiste.

Quelqu'un aurait-il une explication ? Me conseillerez-vous de flasher le firmware et repartir à 0 ? J'suis vraiment perdu...!

 

Merci d'avance

Lien à poster
Partager sur d’autres sites

C'est pour un TinyHawk II BNF et une Taranis X9 Lite (avec module XJT). J'avais essayé d'être exhaustif sur les infos dans un autre topic, mais un topic plus "généraliste" est peut être préférable.

# Betaflight / STM32F411 (S411) 4.2.6 Jan  5 2021 / 19:07:43 (a4b6db1e7) MSP API: 1.43

 

Malgré mes recherches et essais rien à y faire, j'dois passer à coté de quelque chose

Lien à poster
Partager sur d’autres sites
il y a une heure, kawsay a dit :

J'ai beau attendre 15 secondes ou rentrer dans le CLI pour attribuer la valeur 1 à "pwr_on_arm_grace", l'erreur persiste.

En bientôt 8 ans de drone, j’ai jamais touché ce paramètre... je savais même pas que cela existait !

Pour ta culture betaflight...


 

Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Attafr a dit :

Pour ta culture betaflight...

Merci, j'regarderai ça !

 

Ce soir je me penche sur interprétation du clignotement des LED (si le débit internet le permet), le TinyHawk clignote rouge et c'est sûrement pas insignifiant. J'vous tiens informé

Modifié (le) par kawsay
format
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Vous me conseilleriez de flash et repartir à zéro si cette check list est exhaustive et qu'j'arrive toujours pas à armer ?

La doc de BetaFlight n'a pas solutionné le problème non plus (https://github.com/betaflight/betaflight/wiki/Arming-Sequence-&-Safety)

J'ai fait des essais en activant / désactivant l'option  `enable_stick_arming` (OFF par défaut ?) via le CLI, sans résultat 😕...

J'vais suivre la FAQ et voir c'que ça donne (https://github.com/betaflight/betaflight/wiki/Frequently-Asked-Questions#why-wont-my-fc-board-arm-after-upgrading-the-firmware-)

Lien à poster
Partager sur d’autres sites

F***ck yeaaa, it works !

 

J'ai suivi la FAQ, notamment la procédure du constructeur https://emaxusa2.freshdesk.com/support/solutions/articles/19000108267-tinyhawk-rtf-bnf-manual-firmware-cli-binding-for-v1-v2

L'erreur initial venait d'un mauvais flashage, j'ai sûrement dû aller trop vite et sélectionner la mauvaise version du firmware.

Merci Attafr et WZ pour les tutos !

Morale: RTFM 🙂

  • J'aime 1
  • +1 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...