Aller au contenu
DroneBuilds

Perte de puissance


Messages recommandés

Bonjour,

Après un vol avec le tiny Hawk, j'ai eu la brillante idée de le faire tomber dans une flaque, sans qu'il soit trop mouillé non plus, mais depuis j'ai une sorte de perte de puissance.

Quand je mets les gaz à fond d'un seul coup il se coupe direct.

Quand je le fais monter doucement, puis redescendre, puis je veux remonter là il galère.

J'avais remarqué que le moteur 2 ne démarrait pas bien, je l'ai soupçonné de ralentir pendant le vol et donc de faire tomber le drone, je l'ai changé et j'ai toujours ce même problème.

Mais en fait sur Betaflight j'ai regardé l'allure des moteurs, quand je mets à fond et que je redescend les gaz le moteur 2 reste à fond.

Et voici ce que donne le drone quand je mets à fond d'un coup :

 

 

Et quand j'essaie de le faire monter doucement :

 

Voilà le petit soucis du jour 🙂

Si vous pouvez m'aider c'est top, ça m'est arrivé au deuxième vol c'est un peu dommage, mais on apprend sur le tas comme on dit ^^

Bonne journée à vous

Sébastien

Modifié (le) par Seb23
Lien à poster
Partager sur d’autres sites

Il faudrait inverser deux moteurs.
Sa te permettra de voir si ton problème vient du moteur ou de l'esc (enfin FC puisque c'est du tout en un)
Malheureusement, je ne pense pas que le problème vienne des moteurs...

Modifié (le) par Lap
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Hello,

J'ai flashé le tiny en fait et pas ma FC, je me suis planté 😕

Maintenant je n'ai plus le gyro et l'accéléromètre.

Quand je branche le quad les diodes ne s'éclairent plus mais il est reconnu sur BF.

Je n'ai plus les entrées UART.

Il est parti en vrille le tiny...

Voici ma version : ERREUR NO CONFIG FOUND c'est quoi ?

version.thumb.jpg.23364f9d872bbb73acf0efbf0de0ceb1.jpg

Le programme s'est bien installé :

flash.thumb.jpg.555f4175f256b7545305374ee11be83e.jpg

Pas de gyro et accéléro détectés :

278157147_pasdegyro.thumb.jpg.7211744fca475b13b1c9b9a144a83e2f.jpg

Pas d'UART :

UART.thumb.jpg.4628ad9d2c923306cb452e2b24e99f60.jpg

J'ai essayé plusieurs versions de microprogramme, j'ai pris des plus anciens et j'ai toujours le même soucis.

J'avais sauvegardé ma version qui n'était pas si dégueu comparé à ça, je dois la réinstaller ? Si oui comment faire ?

Désolé pour ces galères ! Si vous pouvez m'aider c'est top 🙂

Je vous remercie par avance

Sébastien

Modifié (le) par Seb23
Lien à poster
Partager sur d’autres sites
il y a 24 minutes, Seb23 a dit :

Si vous pouvez m'aider c'est top 🙂

Regarde ça, en particulier la deuxième.

Tu dois choisir la bonne FC (pas STMxxxx)

c’est quoi comme FC ?

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
il y a 23 minutes, Seb23 a dit :

Pourquoi c'est STM32F411 sur la page version alors 😕

STM32F411 si tu veux c’est un “kernel” un système d’exploitation comme windaube mais qui n’a aucun périphérique....

Tu lui donne le NOM de ta FC (Matekxyz) et cela te configure tes périphériques, sorties ESC, map des UART etc...

Lien à poster
Partager sur d’autres sites

Les ESC ou FC sont indépendant (bien que l'on puisse flasher les ESC depuis la FC).
Si sous BF ta FC est mal / pas reconnu, le problème ne vient surement pas des ESC.

Tu avais un dump ou diff de ta configuration précédente Betaflight ?
Au moins pour verifier que tu est sur un firmware qui correspond à ta FC ?

(Voir tu peux essayer d'en trouver sur le web pour comparer les valeurs / infos)

Modifié (le) par Lap
Lien à poster
Partager sur d’autres sites
Le 17/02/2021 at 13:20, Seb23 a dit :

Par contre même en ayant flashé la FC j'ai toujours le même problème. 

Tu as sélectionné quel firmware exactement ?

Tu as bien fait comme dans la deuxième vidéo du lien que je t’ai donné précédemment ?

Lien à poster
Partager sur d’autres sites

Bonsoir,

Excusez-moi pour mon retour tardif, pas mal de taf en ce moment.

Alors j'ai bien fait comme le tuto pour flasher la carte, j'avais sauvegardé ma version est j'ai bien à nouveau Matek411RX quand je vais voir ça dans l'onglet CLI.

Voici ma nouvelle version

72130671_nouveauprogramme.thumb.jpg.a864209b42c23833ba14ec25685fa1cf.jpg

 

Mon ancienne

BTFL_cli_20210212_113034.txt

Par exemple sur Amazon ils mettent que c'est une Matek411RX :

https://www.amazon.fr/Max-Tinyhawk-Control-16000KV-Support/dp/B083PSGZN6

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...