Aller au contenu
DroneBuilds

Tyro69 et TX200U


Messages recommandés

Bonjour. J'ai chercher sur le forum mais pas moyen de trouver une solution.

Je voulais modifier mon Tyro pour lui mettre une meilleur cam ainsi qu'un nouveau VTX. J'ai opté pour une runcam nano 2 et un TX200U pour le VTX

Pour la video pas de soucis, j'ai bien le retour. En revanche, je n'ai aucun osd d'affiché. J'ai connecté le cable vert du vtx sur TX1, et changé le protocol pour IRC tramp dans beta flight mais aucun resultat.

Quelqu'un a une idée?

Merci

Lien à poster
Partager sur d’autres sites

Intelligente modif ! 

 Protocole IRC Tramp Ok pour ce VTX.

Fil Smartaudio (Vert pour ta part) relié à un TX OK . 

T'es sur que le TX1 sur l'onglet BETA est bien activé ? Mais surtout, t'es certain que ce même TX n'est pas déjà utilisé... ? Souvent le premier UART est lié au RX radio.

T'as essayé tout simplement sur un autre UART si tu en disposes?  Sinon à défaut d'UART libre,  créer un softsérial avec le pad led ou ppm. 

Modifié (le) par CriTof
  • +1 1
Lien à poster
Partager sur d’autres sites

Salut, je crois qu'on a tous fait pareil avec nos Tyro69...la caméra est vraiment mauvaise et le VTX limité à 25mW.

Normalement, ça marche direct, comme avec l'original.

Le remplacement s'opère en deux étapes:

1 - La connextion

Vérifie que tu as fais les connexions comme si-dessous. La caméra se connecte désormais directement sur la FC (avant c'était sur le VTX). Le VTX, pour smartaudio ou tramp, c'est TX2.

image.thumb.png.64f638c6d6a0c06569d7e25cffc22240.png

2 - La configuration Betaflight

  • Onglet "Ports", UART2, périphérique VTX (IRC Tramp)

image.thumb.png.17383eee5228ef18081f3cde18b34ec5.png

  • Onglet "Configuration", activer OSD

image.thumb.png.a300e4bbb777ea85519bb4bb487f005a.png

  • Onglet "Emetteur vidéo", les infos sur ton VTX...

image.thumb.png.623d67d570577602ad6b7e1314e871d2.png

  • Onglet "OSD", Ce que tu veux... voila le miens par example :

image.thumb.png.fc63fcf77e727e935fd3447864dc9a42.png

Bon travail. 

Modifié (le) par CC06
  • J'aime 2
Lien à poster
Partager sur d’autres sites

J'ai essayé le fils vert sur TX2, tjs pas de resultats.

Mais mon cablage est differents. La camera est branché sur le vtx, et le 5v et gnd du vtx est branché sur la fiche "camera"de la FC. Je n'ai pas les connectique qu'il faut, j'ai recyclé celle fourni avec le vtx et la cam de base. Mais la connectique du VTX de base n'a que 2 fils connecté,vtx et TX2. Et du coup, je n'ai pas l'onglet émeteur video dans Betaflight

Donc dans l'idée, il faudrait que je connecte la camera directement sur la fiche cam de la FC, sans passer pas le VTX, que je connecte le fil vert sur TX2 et que je trouve un 5v et gnd sous la FC?

Les 6 pads à gauche, c'est bien pour VTX et CAM? 5v en haut, Analog au millieu et GND en bas? Donc en en me repiquant sur les pads tout a gauche, mon vtx devrait etre reconnu. RIGHT?

Untitled-1.jpg

Untitled-2.jpg

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a 29 minutes, myal02 a dit :

J'ai essayé le fils vert sur TX2, tjs pas de resultats.

Mais mon cablage est differents. La camera est branché sur le vtx, et le 5v et gnd du vtx est branché sur la fiche "camera"de la FC. Je n'ai pas les connectique qu'il faut, j'ai recyclé celle fourni avec le vtx et la cam de base. Mais la connectique du VTX de base n'a que 2 fils connecté,vtx et TX2. Et du coup, je n'ai pas l'onglet émeteur video dans Betaflight

Donc dans l'idée, il faudrait que je connecte la camera directement sur la fiche cam de la FC, sans passer pas le VTX, que je connecte le fil vert sur TX2 et que je trouve un 5v et gnd sous la FC?

Les 6 pads à gauche, c'est bien pour VTX et CAM? 5v en haut, Analog au millieu et GND en bas? Donc en en me repiquant sur les pads tout a gauche, mon vtx devrait etre reconnu. RIGHT?

Untitled-1.jpg

Untitled-2.jpg

Non c'est plutôt en haut à gauche câble vidéo qui va au vtc, haut droite vidéo qui va à la caméra

Les 2 du milieu sont les 5v

Les 2 du dessous sont les masses gnd

C'est écris juste a droite des pads

Donc tu gardes ta connectique pour avoir la Télémétrie du vtx en tx2 et ton vidéo vers vtx, et tu soude le 5v et la gnd sur le dessous de la FC

Modifié (le) par Joelamoule
  • +1 1
Lien à poster
Partager sur d’autres sites
à l’instant, myal02 a dit :

Ha ok, donc de haut en bas, vid, 5v et GND?

Oui au pire vérifié avec un multimètre l'alimentation de ces pads 5v et gnd pour être sûr.

Lien à poster
Partager sur d’autres sites
à l’instant, myal02 a dit :

Ha ok, donc de haut en bas, vid, 5v et GND?

C’est ce que je comprends des pads, la flèche qui t’envoie sur la description !

  • +1 1
Lien à poster
Partager sur d’autres sites
il y a 18 minutes, myal02 a dit :

Ha ok, donc de haut en bas, vid, 5v et GND?

Au lieu de souder, pourquoi n'utilises-tu pas les connecteurs sur l'autre coté ?

Si tu n'as pas de retour video pour l'OSD, c'est normal, ton montage envoie directement la vidéo de la camera au VTX. La caméra doit se connecter à la FC, et la FC au VTX... refais ton cablage et tout fonctionnera...

... et de préférence utilise les connecteurs comme je te l'ai montré sur le schéma, c'est super simple et ça t'évitera des problèmes !

  • +1 2
Lien à poster
Partager sur d’autres sites

Le soucis avec les connecteurs, c'est que celui du VTX d'origine à 4 broches, et seulement 2 fils sont connecté (VTX et TX2). le 5v et GND n'ont pas de fils, et je n'ai pas d'autre connecteur sous la main.

Lien à poster
Partager sur d’autres sites

Ok, mais au cas ou tu trouves un connecteur, voila ton banchement à associer au schéma que je t'ai posté avant...

J'ai l'habitude de garder tous les connecteurs que tu peux recabler en utilisant une épingle pour retirer les broches des connecteurs... et cela fait ensuite un montage toujours plus propre et démontable à souhait.

image.png.8174ba35541e3b4278c781a46b181b0f.png

 

Sinon, pour compléter la photo de @Attafr, Voila ou il faut souder ton TX2 sur l'autre coté de la FC... ça fait un beau bor@#$el !

image.png.614de95113e79509c602a9895ee9ca28.png

Modifié (le) par CC06
  • +1 1
Lien à poster
Partager sur d’autres sites

Pour être bien sur, je me retrouve avec un câblage comme ca. Avec la camera connecté directement sur la fiche cam de la fc. Et le vtx recupere la video par le cable jaune connecté au PAD VTX. Le 5v et gnd qui allait du VTX a la camera ne serve plus a rien.

Untitled-3.jpg.db0a575b623b3303c7067c29233e95f3.jpg

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Il y a 6 heures, myal02 a dit :

Pour être bien sur, je me retrouve avec un câblage comme ca. Avec la camera connecté directement sur la fiche cam de la fc. Et le vtx recupere la video par le cable jaune connecté au PAD VTX. Le 5v et gnd qui allait du VTX a la camera ne serve plus a rien.

Oui, tout cela ça me parait correct.

Lien à poster
Partager sur d’autres sites
Il y a 9 heures, myal02 a dit :

Pour être bien sur, je me retrouve avec un câblage comme ca. Avec la camera connecté directement sur la fiche cam de la fc. Et le vtx recupere la video par le cable jaune connecté au PAD VTX. Le 5v et gnd qui allait du VTX a la camera ne serve plus a rien.

Untitled-3.jpg.db0a575b623b3303c7067c29233e95f3.jpg

vas y envoie la sauce !

Lien à poster
Partager sur d’autres sites

Merci, ca fonctionne.

Finalement, j'ai récupéré la connectique du VTX pour connecter "vtx" et TX2 dessus, et j'ai connecter le 5v et gnd sur les pad LED (les pad vtx etait trop petit, je ne m'en sortais pas).

Ca change la vie d'avoir une bonne camera. J'ai pas encore testé la distance mais le VTX semble mieux fonctionner que celui d'origine.

Merci la communauté!!!!!

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...