Aller au contenu
DroneBuilds

Pas de retour récepteur sur betaflight


Messages recommandés

Bonsoir, je monte mon premier quad et je suis rendu à la partie du paramétrage de la radio au niveau de betaflight. Mais jusqu’à maintenant je n'es toujours pas trouvé de solution. car je n'es aucun retour sur betaflight quand je bouge quels sticks et auxiliaires que ce soit.

Radio: Taranis X9 Lite s (access) Dernier firmware à jour pour l'os: firmware open TX 2.3.12 / module interne: ISRM-S-X9LiteS_2.1.6

Récepteur: R-Xsr firmware: RXSR_ACCESS_2.1.0

FC: Kakute F7 version 4.2.6

Donc je me suis mis en s-port, le récepteur et la radio sont binder. j'ai essayer, avec une batterie pour être sur que la le récepteur était bien alimenter et à peu près toutes les autres possibilités que j'ai pu voir en me renseignent.(Voir capture d'écrans ci-dessous)

J'ai aussi essayer avec les différents ordres de voies.

Je suis vraiment bloquer, merci d'avance !

Capture d’écran 2021-02-13 194235.png

Capture d’écran 2021-02-13 194445.png

Capture d’écran 2021-02-13 194505.png

Fichier_000.jpeg

Lien à poster
Partager sur d’autres sites
il y a 11 minutes, Quartorns a dit :

Donc je me suis mis en s-port

Il ne faut pas mettre FrSky FPort sur la page configuration, mais SBUS !

pourquoi uart6 pour ta connection RX ? Tu n’as pas un pad SBus ? (Souvent uart1)

c’est cette FC ? Je (quand tu dis version 4.2.6, tu parles de BF ?)

fais un get serialrx  et version depuis le CLI BF 

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
il y a 28 minutes, Attafr a dit :

Il ne faut pas mettre FrSky FPort sur la page configuration, mais SBUS !

pourquoi uart6 pour ta connection RX ? Tu n’as pas un pad SBus ? (Souvent uart1)

c’est cette FC ? Je (quand tu dis version 4.2.6, tu parles de BF ?)

fais un get serialrx  et version depuis le CLI BF 

Je vois, mais du coup je soude le fil vert du récepteur sur la FC et pas le jaune. Et sur la doc il conseil de mettre en uart 6 mais de toute façon tout les uarts détecte de ce que j'ai compris. Et oui c'est bien la version BF.

J'avais aussi essayer de passer le rx en mode s-bus en appuyant 4 sec sur le bouton du rx mais ça ne fonctionnait pas.

Capture d’écran 2021-02-13 210456.png

Capture d’écran 2021-02-13 210538.png

Lien à poster
Partager sur d’autres sites
il y a 46 minutes, Quartorns a dit :

J'avais aussi essayer de passer le rx en mode s-bus

EDIT, tu as regardé dans capteur de ton modèle si tu as des capteurs détecté ?

Tu as bien configuré Input/Mixer sur ton modèle ?
 

Tu es en SBus sûrement, en access pas de led bleue...

Donc si j’ai bien compris tu veux utiliser ton R-XSR en FPort !

Pour cela tu dois connecter la sortie (3) de ton RX (S.Port/FPort) la couleur est jaune 

Tu dois connecter cette sortie à un TX, pas un RX, donc pour toi TX6 !

Tes paramètres serialrx sont correctement configuré !

B88BE76F-110F-4B55-ABED-4294D918F0D3.jpeg.afdb24b5eb39f80d4777fe10eae06689.jpeg

 

Pour le reg/bind, suivre cette procédure :

Suivez l'étape ci-dessous pour terminer la procédure d'enregistrement et de liaison:
 1. Mettez le module émetteur / émetteur en état [Reg].
 1.1 Pour Taranis X-Lite Pro par exemple, allumez l'émetteur, allez au MENU-MODEL SETUP-PAGE 2, choisissez Internal ou External RF, et sélectionnez [Reg].
 2. Connectez la batterie au récepteur tout en maintenant le bouton F / S sur le récepteur.  La LED ROUGE et la LED VERTE sur le récepteur seront allumées, indiquant dans l'état [Reg].  Sélectionnez [ENTRER] sur l'émetteur, la LED ROUGE et la LED VERTE clignoteront et l'émetteur affichera [Registration ok].
 3. Éteignez le récepteur.
 4. Déplacez le curseur pour sélectionner le récepteur 1 [Bind].
 5. Connectez la batterie au récepteur, la LED VERTE clignotera, indiquant l'état [Bind].  Sélectionnez le RX, le VERT restera allumé et l'émetteur affichera [Affectation réussie].
 6. La sortie de l'émetteur [Bind], la LED VERTE restera allumée, la LED ROUGE sera éteinte, indiquant Fonctionnement normal.

EDIT 2 :

Comment changer le F.Port
 - Pour Taranis X-Lite Pro par exemple, sélectionnez le récepteur, appuyez sur le bouton ENTRÉE, sélectionnez Options et sélectionnez F.Port.

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
Il y a 16 heures, Attafr a dit :

EDIT, tu as regardé dans capteur de ton modèle si tu as des capteurs détecté ?

Tu as bien configuré Input/Mixer sur ton modèle ?
 

Tu es en SBus sûrement, en access pas de led bleue...

Donc si j’ai bien compris tu veux utiliser ton R-XSR en FPort !

Pour cela tu dois connecter la sortie (3) de ton RX (S.Port/FPort) la couleur est jaune 

Tu dois connecter cette sortie à un TX, pas un RX, donc pour toi TX6 !

Tes paramètres serialrx sont correctement configuré !

B88BE76F-110F-4B55-ABED-4294D918F0D3.jpeg.afdb24b5eb39f80d4777fe10eae06689.jpeg

 

Pour le reg/bind, suivre cette procédure :

Suivez l'étape ci-dessous pour terminer la procédure d'enregistrement et de liaison:
 1. Mettez le module émetteur / émetteur en état [Reg].
 1.1 Pour Taranis X-Lite Pro par exemple, allumez l'émetteur, allez au MENU-MODEL SETUP-PAGE 2, choisissez Internal ou External RF, et sélectionnez [Reg].
 2. Connectez la batterie au récepteur tout en maintenant le bouton F / S sur le récepteur.  La LED ROUGE et la LED VERTE sur le récepteur seront allumées, indiquant dans l'état [Reg].  Sélectionnez [ENTRER] sur l'émetteur, la LED ROUGE et la LED VERTE clignoteront et l'émetteur affichera [Registration ok].
 3. Éteignez le récepteur.
 4. Déplacez le curseur pour sélectionner le récepteur 1 [Bind].
 5. Connectez la batterie au récepteur, la LED VERTE clignotera, indiquant l'état [Bind].  Sélectionnez le RX, le VERT restera allumé et l'émetteur affichera [Affectation réussie].
 6. La sortie de l'émetteur [Bind], la LED VERTE restera allumée, la LED ROUGE sera éteinte, indiquant Fonctionnement normal.

EDIT 2 :

Comment changer le F.Port
 - Pour Taranis X-Lite Pro par exemple, sélectionnez le récepteur, appuyez sur le bouton ENTRÉE, sélectionnez Options et sélectionnez F.Port.

Donc, j'ai refait toute la procédure de bind ainsi que les réglages sur la radios après est ce que ce sont les bons ?(voir photos ci-dessous)

Je suis bien en SBUS à présent mais toujours rien. Je vais finir par me demander si cela ne viens pas de la carte en elle même, pourtant il n'y a pas de raison.

Voici le lien vers la doc de la FC pour ceux que ça intéresse:http://www.holybro.com/product/kakute-f7-v1-5/

En tout cas merci de m'aider dans la résolution de ce problème.

Fichier_000.jpeg

Fichier_0001.jpeg

Fichier_0002.jpeg

Fichier_0003.jpeg

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
il y a 22 minutes, Quartorns a dit :

Je suis bien en SBUS

En SBUS la configuration est différente...

Pourquoi avoir changé ?

En SBus, tu dois utiliser un RX depuis SBus OUT du RX... modifier les set serialrx_...., modifier le protocole dans configuration FrSky FPort —> SBUS 

Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Attafr a dit :

En SBUS la configuration est différente...

Pourquoi avoir changé ?

En SBus, tu dois utiliser un RX depuis SBus OUT du RX... modifier les set serialrx_...., modifier le protocole dans configuration FrSky FPort —> SBUS 

Ah ok je pensais qu’il fallait se remettre en s bus mais du coup je reste en s port

Lien à poster
Partager sur d’autres sites
il y a 20 minutes, Quartorns a dit :

Ah ok je pensais qu’il fallait se remettre en s bus mais du coup je reste en s port

Donc en FPORT tu as bien changé ça !

Comment changer le F.Port
 - Pour Taranis X-Lite Pro par exemple, sélectionnez le récepteur, appuyez sur le bouton ENTRÉE, sélectionnez Options et sélectionnez F.Port.


En F.Port Essaye de jouer avec ça... tu test les possibilités ON/OFF

set serialrx_halfduplex = ON

set serialrx_inverted = ON

save

Y’a pas de raison que cela ne fonctionne pas !

Lien à poster
Partager sur d’autres sites
il y a 57 minutes, Attafr a dit :

Donc en FPORT tu as bien changé ça !

 

Comment changer le F.Port
 - Pour Taranis X-Lite Pro par exemple, sélectionnez le récepteur, appuyez sur le bouton ENTRÉE, sélectionnez Options et sélectionnez F.Port.


En F.Port Essaye de jouer avec ça... tu test les possibilités ON/OFF

set serialrx_halfduplex = ON

set serialrx_inverted = ON

save

Y’a pas de raison que cela ne fonctionne pas !

Alors bonne nouvelle ça marche parfaitement, il faut juste que je change l'ordre des voies sur la radio mais ça c'est pas un problème. Encore un grand merci

le seul truc petit truc c'est que la télémétrie est ultra instable un un coup je l'ai et la seconde d'après je ne l'ai plus.

Lien à poster
Partager sur d’autres sites
il y a 4 minutes, Quartorns a dit :

le seul truc petit truc c'est que la télémétrie est ultra instable un un coup je l'ai et la seconde d'après je ne l'ai plus.

Certainement que lors de tes tests, ta radio est bien trop prête de ton kwad. 😁

Lien à poster
Partager sur d’autres sites
il y a 16 minutes, Quartorns a dit :

Alors bonne nouvelle ça marche parfaitement,

Tu peux s’il te plait détailler ce que tu as finalement fait pour que cela fonctionne!

Lien à poster
Partager sur d’autres sites
il y a 26 minutes, Attafr a dit :

Tu peux s’il te plait détailler ce que tu as finalement fait pour que cela fonctionne!

Alors j'ai tout simplement suivis tes instructions je suis allé dans les options du rx et j'ai mis sur S-Port et c'est tout 😉

C'est fou comment on peut bloquer sur un tout petit truc à la con.

Merci encore

Lien à poster
Partager sur d’autres sites
il y a une heure, Attafr a dit :

Alors pour finir l’explication, c’est pas S.Port, mais FPort=S.Port+SBUS sur le même fil !

bon vol

Merci pour tout, c'est la meilleure commu fr ici c'est un truc de ouf

Modifié (le) par Quartorns
  • J'aime 1
Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Quartorns a dit :

Merci pour tout, c'est la meilleure commu fr ici c'est un truc de ouf

C'est vrai que @CriTof et @Attafr gèrent bien le sav ici 😂😂, pour la r et d faut voir avec @CC06 et enfin la direction c'est @Motard Geek et @Qnnk

PS: par contre ne cherche pas de review de quad BNF ici, c'est pas le genre de la maison. 🤭🤭

  • J'aime 1
  • Haha 2
  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 7 heures, Joelamoule a dit :

C'est vrai que @CriTof et @Attafr gèrent bien le sav ici 😂😂, pour la r et d faut voir avec @CC06 et enfin la direction c'est @Motard Geek et @Qnnk

PS: par contre ne cherche pas de review de quad BNF ici, c'est pas le genre de la maison. 🤭🤭

Kafteur 🤣

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...