Aller au contenu
DroneBuilds

Drone ne s'envole pas et s'eteint lorsque je pousse le throttle à fond


Messages recommandés

Bonjour à tous,

J'ai vu que le problème a déjà été poser dans la FAQ mais je n'ai pas pu résoudre mon problème avec les éléments existants.

D. Moteurs et comportement en vol :

  1. Mon quad saute dans les airs ou se retourne au premier coup de gaz

C'est un drone que j'ai assembler moi-même à l'aide d'un controleur de vol avec le firmware MATEKF405 et un ESC 4-en-1        , des moteurs emax ECO série 2306. J'utilise la radiocommande FlySky fs-i6 avec un recepteur fs-ia6B.

Le problème est que le drone saute et s’éteint ou s’éteint juste tout simplement en poussant les gaz et seulement avec le throttle.

Le drone se comporte normalement dans betaflight (le modèle 3D), le sens est bon et les mouvements du drone correspondent totalement. J'ai vérifier le sens des moteurs OK, les hélices selon les informations que j'ai vu sur le forum aussi, j'ai enlever l'Airmode. J'ai vérifier les logs aussi à l'aide de Blackbox explorer mais je n'ai pas réussi à cerner le logiciel si ce n'est que le Gyro Yaw fais des 360 sans même que le drone tourne.

 

Je joins 2 vidéos, l'une ou je montre que je peux bouger le drone côté Pitch et Roll sans problème et une ou j'essaie de pousser les gaz sans succès.

Merci à vous de prendre le temps de me lire.

Lien à poster
Partager sur d’autres sites

Si le drone ne décolle pas normalement, y'a pas 36 solutions :

  1. Vérifier que le gyro réponde bien aux mouvements demandés depuis Betaflight
  2. Effectuer un remappage moteurs
  3. Vérifier que le bon numéro de moteur démarre bien comme attendu par BF
  4. Vérifier le sens des hélices

👌

Modifié (le) par Feisar
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
il y a 27 minutes, Feisar a dit :

Si le drone ne décolle pas normalement, y'a pas 36 solutions :

  1. Vérifier que le gyro réponde bien aux mouvements demandés depuis Betaflight
  2. Effectuer un remappage moteurs
  3. Vérifier que le bon numéro de moteur démarre bien comme attendu par BF
  4. Vérifier le sens des hélices

👌

Merci pour le retour rapide !
J'ai déjà effectuer l'étape 1 (A la fois que le drone 3D bouge dans les bon sens et que les commandes de la radiocommande correspodent bien), l'étape 3 et l'étape 4.
Je vais donc essayer le remappage des moteurs demain en espérant que ce soit lié à ça et je ferais un retour.
 

 

il y a 24 minutes, Feisar a dit :

ah oui au passage, as-tu une raison valide pour avoir désactivé l'Airmode ? 🙏

Juste pour tester vu qu'il se comportait de manière bizarre au sol mais j'ai vu ensuite que c'était dû au fait qu'il essayait de se recalibrer constamment. Ce n'est pas censer poser de problème donc il vaut mieux le laisser activer c'est ça ?

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV


Tu peux faire 

il y a 4 minutes, Pokeko a dit :

J'ai déjà effectuer l'étape 1 (A la fois que le drone 3D bouge dans les bon sens et que les commandes de la radiocommande correspodent bien), l'étape 3 et l'étape 4.

un printscreen page configuration !

Lien à poster
Partager sur d’autres sites
il y a 29 minutes, Pokeko a dit :

Je vais donc essayer le remappage des moteurs demain en espérant que ce soit lié à ça et je ferais un retour.

Si tu a bien fait les autres étapes, dans ce cas il ne te reste plus que celle-ci, et ça va marcher 👌

il y a 30 minutes, Pokeko a dit :

donc il vaut mieux le laisser activer c'est ça ?

Exactement il faut le laisser activé, c'est un paramètre important car une fois en l'air, il corrige sa trajectoire constamment. On le désactive surtout temporairement juste le temps d'atterrir, mais bon, à ma connaissance quasi personne ne le fait

Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Feisar a dit :

ah oui au passage, as-tu une raison valide pour avoir désactivé l'Airmode ? 🙏

L'airmode activé permanent n'est pas obligatoire. 

 

@Pokeko débrouille toi pour placer tes 2 antennes du RX "perpendiculaire". Une verticale, l'autre horizontale. Tu optimiseras ainsi au maximum sur ces deux plans, la réception signal radio 😉

IMG_20200415_145519.jpg

Modifié (le) par CriTof
  • +1 3
Lien à poster
Partager sur d’autres sites

Je reviens vers vous aujourd'hui du coup après avoir tout essayer en vain ! Cette fois, le drone s'envole au début et puis s'éteint.. Il reste stable pourtant, pas de roll ou quoique ce soit mais il s'éteint comme s'il y avait une sécurité. Le problème peut-il venir de la radiocommande ?
 

Il y a 16 heures, Attafr a dit :


Tu peux faire 

un printscreen page configuration !

image.thumb.png.97cb6617acb9e84ecd57c99b2bbd02ba.png

image.thumb.png.7a723a28a399206289c2a816fb4f9dc5.png

image.thumb.png.f02647cd3a1e5775b967b663ce81dea9.png

Merci encore pour votre aide 🙏

Modifié (le) par Pokeko
Lien à poster
Partager sur d’autres sites

Essaie dejà en descendant ta boucle PID à 4,00kHz ! Et désactive le Magnetometre  (Tu n'en as pas sur cette FC)

Modifié (le) par CriTof
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
à l’instant, CriTof a dit :

Essaie dejà en descendant ta boucle PID à 4,00kHz ! Et désactive le Magnetometre  (Tu n'en as pas sur cette FC)

Toujours la même chose sauf que le drone à l'air plus réactif/vif mais il s'éteint tout aussi vite. C'est possible qu'il y ai un failsafe dans ma radiocommande qui s'active par défaut ?

Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Pokeko a dit :

Toujours la même chose sauf que le drone à l'air plus réactif/vif mais il s'éteint tout aussi vite. C'est possible qu'il y ai un failsafe dans ma radiocommande qui s'active par défaut ?

Maintiens déjà ces réglages et décolle nous tes antennes l'une contre l'autre ! Ca sent le failsafe radio ta panne. 

Modifié (le) par CriTof
Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Pokeko a dit :

ma radiocommande

Tu as bien contrôlé les courses et centrages depuis betaflight ?

Que sur la page récepteur de BF il bouge correctement ?

Tu es en mode Horizon ou angle ?

Tu as pas une erreur dans l’OSD ?

 
Calibré les sticks sur ta radio ?

  • +1 1
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

J'ai virer les antennes et même résultat. J'augmente le throttle et le drone finit par s'emballer et sauter, que j'y aille d'une traite ou progressivement c'est pareil.

à l’instant, Attafr a dit :

Tu as bien contrôlé les courses et centrages depuis betaflight ?

Que sur la page récepteur de BF il bouge correctement ?

Tu es en mode Horizon ou angle ?

Tu as pas une erreur dans l’OSD ?

 
Calibré les sticks sur ta radio ?

J'ai juste vérifier que tout bouger correctement et que les valeurs était à priori similaire sans modifier quoique ce soit sur la radiocommande.
image.thumb.png.1e492ba8fe5c5950aedb293b16250ee6.png

En mode Horizon par défaut mais avec un switch pour le mode Angle.
Je n'ai pas calibrer les sticks sur la radio vu que le rendu était correct dans betaflight lorsque je contrôlais le drone avec la radiocommande sur l'interface.

Pour l'OSD, je n'ai pas encore ajouter la caméra vu qu'il ne décolle pas mais je vais essayer de la brancher et voir le rendu.
Je regarde du côté de la radiocommande ? J'ai pensais à ça aussi vu que tout fonctionne correctement sauf que je met les gaz mais j'en ai aucune idée en réalite

Modifié (le) par Pokeko
Lien à poster
Partager sur d’autres sites

Alors... 

Premiere chose:  Comme te l'a stipulé @Attafr  Imperatif de calibrer les sticks  de ta radio !

Deuxieme chose : Helices retirées !!! Aller sur Betaflight et contrôler le sens de rotation de TES moteurs. Comme @spid99, J'ai un ENORME DOUTE .

Troisième chose: Tes hélices sont semble t'il ... TOUTES à l'envers 😁

Commence déjà par là et reviens nous vite 😉

Modifié (le) par CriTof
  • Merci ! 1
Lien à poster
Partager sur d’autres sites
il y a 10 minutes, CriTof a dit :

Deuxieme chose : Helices retirées !!! Aller sur Betaflight et contrôler le sens de rotation de TES moteurs. Comme @spid99, J'ai un ENORME DOUTE .

Troisième chose: Tes hélices sont semble t'il ... TOUTES à l'envers 😁

Commence déjà par là et reviens nous vite 😉

En même temps c'est pas comme si j'en avais déjà parlé dans mon tout premier post.. 😅

La solution se trouve forcément déjà dans une (ou plusieurs) solution(s) qui n'ont pas été vérifiés comme il se doit.

  • J'aime 2
Lien à poster
Partager sur d’autres sites

Lors de mes premiers essais, le RX semblait s'éteindre a la mise en puissance juste avant le stationnaire.

Essaye de déplacer ton rx loin des câbles de puissance et du châssis carbone si possible. Cela a marcher pour mon quad.

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Les hélices me semblent dans le bon sens, on les voit bien sur la seconde vidéo.

  • Que disent les tests de continuité et de smoke stopper ?
  • Vérifie tes soudures moteurs
  • Vérifie qu'aucune vis moteurs ne vienne toucher les bobinage
  • Teste tes moteurs sous BF : vérifie le sens et monte un peu les gaz pour voir si ça se coupe pareil. Regarde s'ils chauffent (si oui, revérifie les 2 points précédents)
  • Quand tu fais ton test avec hélices, regarde dans les lunettes si tu as un message dans l'OSD qui te dit "RX LOSS".
  • J'ai l'impression qu'il manque 4 entretoises sur ta frame nan ? la frame résonne bcp plus et peut affoler le gyro.

La position de tes antennes RX n'est pas optimale mais il n'y a pas de raison que ca cause de failsafe.

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Hello !

Je reviens vers vous avec le problème résolue. Alors, j'ai vérifier le sens des moteurs sur betaflight mille fois, j'ai fini par passer sur BlHeli Configurator où j'ai fais plusieurs modifications (2 moteurs en reverse et 2 en normal) et ca n'a rien changer mais en mettant tous les moteurs en reverse, miracle, tout fonctionne..

Désolé pour les dernières réponses, j'ai pu me replonger dessus seulement aujourd'hui et effectivement, c'était un problème de sens de moteur.

 

Le 17/02/2021 at 17:18, Feisar a dit :

En même temps c'est pas comme si j'en avais déjà parlé dans mon tout premier post.. 😅

La solution se trouve forcément déjà dans une (ou plusieurs) solution(s) qui n'ont pas été vérifiés comme il se doit.

Effectivement et j'en suis désolé ! Je me doutais bien que je vérifais pas les choses forcément correctement mais j'ai finis par voir la différence et la régler.

 

 

Le 18/02/2021 at 09:45, spid99 a dit :

En revoyant la vidéo, je viens de penser à un truc, c'est quels moteurs tes Emax ECO 2306 ?

Les 1700KV ou les 2400KV ? Si tu utilise une 6S la question est primordiale ..

Ce sont les 2400KV et j'utilise une 4S pour le coup
 

 

Le 18/02/2021 at 10:20, Jerome a dit :

Les hélices me semblent dans le bon sens, on les voit bien sur la seconde vidéo.

  • Que disent les tests de continuité et de smoke stopper ?
  • Vérifie tes soudures moteurs
  • Vérifie qu'aucune vis moteurs ne vienne toucher les bobinage
  • Teste tes moteurs sous BF : vérifie le sens et monte un peu les gaz pour voir si ça se coupe pareil. Regarde s'ils chauffent (si oui, revérifie les 2 points précédents)
  • Quand tu fais ton test avec hélices, regarde dans les lunettes si tu as un message dans l'OSD qui te dit "RX LOSS".
  • J'ai l'impression qu'il manque 4 entretoises sur ta frame nan ? la frame résonne bcp plus et peut affoler le gyro.

La position de tes antennes RX n'est pas optimale mais il n'y a pas de raison que ca cause de failsafe.

Merci pour les infos, j'ai quand même fais le tour, particulièrement pour les entretoises que je n'avais pas toutes fixés.

Bref, problème résolue. Merci beaucoup d'avoir pris le temps de me répondre, je vais pouvoir en profiter avec le beau temps qui se ramène !

  • J'aime 1
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Cool, content que tu puisse enfin profiter 🙂 

T'inquiètes pas, ça m'est arrivé deux fois aussi, j'avais bêtement oublié de remapper les moteurs et à chaque fois c'est pareil, ca part en vrille direct dès qu'on lève un peu le throttle 😅 j'ai abimé un bras ou deux, quelques tpu et hélices sur des quads tout neufs fraichement montés juste à cause de cette non vigilance 😞 

Depuis, je me suis noté ces règles d'or avant toute tentative de premier essai, et niquel 👌

Bon vol 🙏

  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...