Aller au contenu
DroneBuilds

Drone qui part sur le côté en roll


Messages recommandés

Bonjour à tous

J'ai un souci sur plusieurs de mes drones qui me pourrit un peu (beaucoup !).

Après les réglages réglementaires (calibration, modes de vol, etc...), et en mode angle, j'arme le drone, je pousse les gaz, et à environ la moitié de la course du stick, le drone décolle, pas de souci...

Le problème, c'est que très vite, il commence à pencher d'un côté, sur le roll, et part donc en drift. Au début du vol (5s peut-être) c'est léger, mais très vite, il part clairement sur le côté en s'inclinant très franchement sur le roll. Et rapidement, ça devient difficilement pilotable et il faut stopper là.

Je ne comprends pas ce qui se passe, car ça n'arrive pas sur un drone en particulier, mais sur plusieurs (petits ou grands), et ce n'est pas systématique sur tous mes drones (mais quand ça arrive sur un drone, ça persiste).

Sur BF, j'ai réglé la course des voix à 1000-1500-2000 en passant par le CLI (méthode Bardwell).

J'ai également tenté de mettre une petite "zone morte", mais ça n'a eu aucun effet.

Et évidemment, j'ai effectué une correction de l'accéléromètre, mais ça n'a strictement aucun effet : au début, ça semble marcher, mais très vite, ça recommence à drifter...

Bref, je suis sûr que j'oublie un détail, mais je ne vois pas quoi...

Je pourrais vous donner des détails sur la config, mais ça arrive sur des config très différentes (F4, F7, toothpicks, 5"...etc...).

Vous auriez une ou des idées ? Je suis désespéré :'-(

Merci pour votre aide.

Modifié (le) par Jerome
Lien à poster
Partager sur d’autres sites
il y a 18 minutes, zentrad a dit :

Bonjour à tous

J'ai un souci sur plusieurs de mes drones qui me pourrit un peu (beaucoup !).

Après les En mode "angle" (oué, je sais, c'est mal, mais dans mon salon, c'est plus prudent ;)),  

ÉDIT : ton post est en doublon ! Et si tu le modifie alors que l’on a déjà répondu... ben on est à côté de la plaque... 🤪


Calibration 1) Accéléromètre 2) Radio 3) Endpoint

https://oscarliang.com/adjust-tx-channel-mid-end-point/
 

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites
  • Jerome changed the title to Drone qui part sur le côté en roll.

Salut,

As-tu essayer de regler les "I" dans les PID? je ne sais pas si ça va fonctionner mais au moins essaye ou sinon essayer de calibrer ta télécommande c'est peut être ceci.

Sinon bonne chance et bons vols si ça fonctionne.

Lien à poster
Partager sur d’autres sites
Le 24/02/2021 at 11:49, Ulysse a dit :

Salut,

As-tu essayer de regler les "I" dans les PID? je ne sais pas si ça va fonctionner mais au moins essaye ou sinon essayer de calibrer ta télécommande c'est peut être ceci.

Sinon bonne chance et bons vols si ça fonctionne.

Ah non, j'ai pas encore essayé ça... Je vais tester et je vous dirai.

Quant à la radio... Pour moi elle est calibrée, mais je vais vérifier tout de même. 

J'ai vu souvent des posts sur ce genre de souci, mais jamais pu trouver de réponse qui marche... Dans tous les cas, je vous dirai... 

Merci ☺️😉😊

Lien à poster
Partager sur d’autres sites

Si ca arrive sur tous tes quads, j'aurais tendance à penser que ça vient de la radio.

Dans BF, quand tu regardes l'onglet récepteur avec le RX alimenté, est-ce que la voie du roll reste à 1500 ? (+ ou - 2 pts)

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
Il y a 11 heures, Jerome a dit :

Si ca arrive sur tous tes quads, j'aurais tendance à penser que ça vient de la radio.

Dans BF, quand tu regardes l'onglet récepteur avec le RX alimenté, est-ce que la voie du roll reste à 1500 ? (+ ou - 2 pts)

Ben justement, non, ça ne me le fait pas sur tous mes drones, et j'en ai une tartinée...
Quant au roll, je viens de le régler au poil, et il est pile à 1500 au neutre...j'ai donc refait un essai de vol, et...il continue à partir sur le côté gauche (toujours le même coté pour le moment).

Je devrais voir avec un exorciste ? :S

Merci 😉

zentrad

Lien à poster
Partager sur d’autres sites

Vraiment incompréhensible mon histoire de roll...

Les curseurs sont pile entre 1000-2000, avec le mid à 1500. J'arme, je mets les gaz, le quad se lève gentiment. Puis il se met à s'incliner en roll sur la gauche (ça aurait pu être droite, pour le moment, je ne vois pas pourquoi un côté serait '"favorisé")...Je le remets au milieu, et ça repart en roll, encore plus fort...et à chaque fois que je remets le stick du roll au milieu, il repart encore plus fort sur la gauche, et c'est très net.

Ca me le fait même si je corrige l'accéléromètre avec la radio ou si je compense au trim...il continue à partir à gauche.

J'ai beau chercher sur gogole, je trouve pas...je veux bien qu'un accéléromètre soit défectueux sur une carte, mais que ça me le fasse à plusieurs reprises, sur plusieurs cartes, j'y crois pas...Je dois passer à côté de quelque chose...

Ah, au passage...ça me fait pareil en mode horizon, mais pas en acro, évidemment...

Je suis preneur de toutes les idées que vous pourriez avoir...je lâcherai pas l'affaire, je suis têtu...et ça pourrait servir à d'autres que moi 😉

merci 🙂

Modifié (le) par zentrad
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...