Aller au contenu
DroneBuilds

Paramétrage R-XSR avec Taranis Q-X7


Messages recommandés

Je monte actuellement mon 1er 5"

J'ai su régler les soucis que mon 85x ne m'avait pas encore fait :

- Neige énorme sur le VTX
-Assignation des moteurs dans betaflight
-Flashé le R-XSR avec ma taranis qui doit avoir autant de puissance de calcul qu'un micro-onde. Grace a cette vidéo :

Mais voilà, j'ai bindé la Taranis et le R-XSR et dans betaflight je n'avait pas le canal RSSI comme a mon habitude. Pour le principal les voies étaient bien configurés pas de soucis.
Dans les lunettes, j'ai le message " low-rssi" et de plus pas de telemetrie dans la taranis.
Pour le montage je me suis référé aux instruction de la FC, une F722 HGLRC. carte-de-vol-zeus-f722-3-6s-dji-hglrc-di

Alors je me suis bien dit qu'il y'avait une baleine sous le gravillon, sur le schéma le S.PORT ( que je suppose désigné le Smartport ) n'est pas branché au TX1.
J'ai donc mis le S.Port sur TX1, SBUS sur RX1.

Pour régler cette histoire de RSSI j'ai suivi cette vidéo et compris que le S.Port se branche seul. https://www.youtube.com/watch?v=OvbLC5fNKyA.
J'ai donc viré le fil vert ( il a rejoint le blanc en boule dans une gaine thermo ).
Après moulte essais sur Betaflight la seule chose que j'arrive a tiré de cette configuration est la télémétrie, mais j'ai aucune voie fonctionnelle.

Juste les gars j'en peut plus je comprend pas SBUS PPM FPORT SMARTPORT LBT EU LBT NONEU FCC INVERTED machin NONINVERTED truc...
Je sais bien qu'il faut y passer par tous ça, mais il y a trop de contenu, parfois daté et plus valable parfois daté et encore valable, je suis perdu au secours,
y'a-t-il moyen, avec le matériel que j'ai choisi d'avoir les commandes les voies et la télémétrie , sans alertes ? Si oui comment, Sinon quel a été mon erreur dans mes choix.

Merci de m'avoir lu.




 

Lien à poster
Partager sur d’autres sites
il y a 13 minutes, Cypher a dit :

J'ai donc mis le S.Port sur TX1, SBUS sur RX1.

L’un ou l’autre tu ne peux pas utiliser le même uart pour smartport et signal...

En plus si ta FC est une F4, tu dois utiliser le uninverted S.Port... dans ce cas, tu peux passer ton R-XSR en FPort

Fais une recherche sur le fofo, il y a deux post qui en parlent dans les dix derniers jours, un c’est « tyro69/79 » l’autre je sais plus...

99495607-18A2-4013-A288-60502BF7E72B.jpeg.f233836794eb570765cb7cf638e6739f.jpeg

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Comme j'ai une F7 je concidère avoir une F4 ?

Si je branche Sbus out sur RX1 avec UART 1 et S.Port sur Tx 5 ( par exemple ) avec uart 5 ( en f.port ou s.port ? ) sa marcherai ?

Modifié (le) par Cypher
Lien à poster
Partager sur d’autres sites
il y a 41 minutes, Cypher a dit :

Comme j'ai une F7 je concidère avoir une F4 ?

Non, si tu as une F7, tu fais comme tu dis, en SBus out—>FC:RX1 (serial RX sur UART1dans BF:port) et S.Port sur FC:TX5 (smartport sur UART5 dans BF:port)

Si tu es en FPort, tu utilises S.Port—>FC:TXn(1ou5)

Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Bon j'ai un peu avancé.

J'ai compris que le sbus et le s.port ne sont pas des mode de fonctionnement mais deux éléments distinct qui on besoin d'un uart chacun. Mettons.

Voici mon nouveau montage.

J'ai mis le s.port sur l'uart DJI qui ne me sert pas. En effet j'ai les commandes + la telemetry.

Mais le f.port c'est quoi au final ?

J'ai le même problème de rssi.

 

P_20210301_185852.jpg

Lien à poster
Partager sur d’autres sites
il y a 1 minute, Cypher a dit :

Mais le f.port c'est quoi au final ?

Avec UN SEUL FIL (hors alim + et - évidement) tu as... TOUT ! 😎 (Au lieu d'avoir un S-Bus(RX) + un TX)

Lien à poster
Partager sur d’autres sites

Ben c'est ça que j'essaye de faire ..

Comment on met que un fil alors ?

Lien à poster
Partager sur d’autres sites
il y a 1 minute, Cypher a dit :

J'ai le même problème de rssi.

Tu as le rssi dans la télémétrie de ton modèle (dernière page du menu MDL de ta radio) tu n’as pas besoin d’attribuer de Chanel à RSSI.

le FPort c’est un « protocol » qui permet de passer signal(« SBus ») + S.Port(telemetry) sur un seul uart !

Lien à poster
Partager sur d’autres sites
il y a 1 minute, Cypher a dit :

Ben c'est ça que j'essaye de faire ..

Comment on met que un fil alors ?

Comme je te l’avais expliqué plus haut ! Il faut que ton R-XSR soit flashé en FPort...

  • +1 1
Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Attafr a dit :

En plus si ta FC est une F4, tu dois utiliser le uninverted S.Port... dans ce cas, tu peux passer ton R-XSR en FPort

ah c'était surement a ce moment ..
Mais après tu m'a dit " nan t'a une F7 alors fait ça "xD

Donc si je veut utilisé le Fport je doit me piqué sur un univerted , refaire un flash du rx MAIS j'ai que un fil.

Au final je crois que ca marche comme ça. il faut que je gratte un peu ce RSSI mais je vois déjà quoi faire .. enfin je pense.
Est ce si important le Fport ? en admettant que l' UART DJI ne m'est pas nécessaire dans l'immédiat ?


 

Lien à poster
Partager sur d’autres sites
il y a 23 minutes, Cypher a dit :

Est ce si important le Fport ? en admettant que l' UART DJI ne m'est pas nécessaire dans l'immédiat ?

j’avais oublié que tu avais une F7...


Non, le FPORT n’est pas nécessaire, si tu n’as assez d’UART (F4) c’est pratique d’en utiliser qu’un ! C’est plus réactif que le SBUS !

Tu as la télémétrie sur ta radio ?

Modifié (le) par Attafr
Lien à poster
Partager sur d’autres sites

Je vient de tomber sur ça sur le forum, dans mes recherches je voyais que le cas d'une F4 donc je matchai pas. Je serait tenté de dire que s'a m'aurait sauvé la journée si je l'avait vu plus tôt, mais je viens seulement de comprendre ce qu'est le Fport.

Si effectivement sur une F7 il n'y pas besoin de faire de soudure sur la petite pastille du Rx je vais surement tout reprendre du début, mais demain xD

Pour la télémétrie, a l’état actuel oui je l'ai mais un shmol avec le RSSI, si j'ai bien compris dans le model je doit ajouté une entrée ( ou une voie je ne me souvient plus du terme ) allez cherché le RSSI comme source et lui attribué une voie, quelque chose comme dans ce gout là. Ceci dit je ne l'avait pas fait pour le Whoop et j'ai pas eut ce genre de soucis alors je ne sais pas, peut etre que j'ai fait de la merde avec la radio en flashant le Rx ce matin.

En tous cas merci pour les réponses, je vous tient au courant, et si je suis chaud je vous cause de mon gps en mode sapin de noel mais qui fou rien xD

 

Citation

Le F.Port permet de passer le signal radio, la télémétrie et le RSSI sur un seul fil, la latence est un couilla meilleure.

  • flasher le R-XSR avec le firmware F.PORT
  • souder ce fil en provenance du "S.port" sur un TX dispo sur la FC (le fil SBUS ne sert plus à rien)
  • Dans Betaflight, passer la fonction Serial RX sur l'UART choisit
  • Dans la partie Configuration,  choisir F.Port à la place de SBUS
  • Dans le CLI, taper (pour une F7) :
    • set serialrx_halfduplex = ON
    • set serialrx_inverted = ON
    • save
Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Cypher a dit :

Pour la télémétrie, a l’état actuel oui je l'ai mais un shmol avec le RSSI, si j'ai bien compris dans le model je doit ajouté une entrée ( ou une voie je ne me souvient plus du terme ) allez cherché le RSSI comme source et lui attribué une voie, quelque chose comme dans ce gout là. Ceci dit je ne l'avait pas fait pour le Whoop et j'ai pas eut ce genre de soucis alors je ne sais pas, peut etre que j'ai fait de la merde avec la radio en flashant le Rx ce matin.

Tu fais rien ! Tu n’attribues PAS de Chanel pour le RSSI, il est directement utilisable dans la télémétrie et l’osd !

Lien à poster
Partager sur d’autres sites

Mais il a une valeur genre a 5 et j'ai " Low RSSI " qui clignotte partout...

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

okay,

J'ai reflashé le r-XSR en Fport.
Refait le montage a un seul fil
Configuré betaflight comme il se doit et bam tout fonctionne ! Merci beaucoup a vous

On peut mettre ce sujet au fin fond du forum xD

Modifié (le) par Cypher
  • J'aime 1
  • Merci ! 1
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...