Aller au contenu
DroneBuilds

Plusieurs problèmes : Mes moteurs ne tournent pas, batterie non reconnue, impossible de flasher mes esc


Messages recommandés

Salut, j'ai récupéré un drone avec une fc naze 32, 4 moteurs grand turbo et 4 esc brushless motor de 20 ampères chacune. La carte de vol est parfaitement reconnue sur cleanflight j'avais déjà configuré mon drone mais il volait pas droit du coup j'ai refait tous le châssis sauf qu'une esc s'est cassée. Je l'ai donc changé et là quand je suis allé sur cleanflight aucun moteur ne tourne et la batterie n'est pas reconnue (il y a un bip répétitif et une led verte qui clignote et la led bleu qui est constante).

Je ne sais pas quel est le problème et je n'arrive pas à flasher mes esc le message suivant s'affiche sur blheli suite 32 : "initialization of serial 4way interface failed ! please check cleanflight revision for support of BLHeli32 serial 4way interface ! " Que dois je faire ? Pourtant avant mêmes avec les esc qui n'étais pas flashé les moteurs tournaient...  

IMG_20210530_204551.jpg

IMG_20210530_204555.jpg

IMG_20210530_204605.jpg

IMG_20210530_212455.jpg

IMG_20210530_204539.jpg

Lien à poster
Partager sur d’autres sites

Salut,

Tu vas pas quand même nous faire toutes les rubriques du forum avec ton sujet, rassure nous !!!

Et t'as p'tete oublié quelque chose à l'issue de ton inscription sur ce forum...

A très vite !

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

je m'étais trompé de forum et je ne savais pas comment le déplacer sauf que je n'arrive pas a supprimer le message sur l'autre rubrique. Qu'est ce qu'il manque à mon inscription ? 

Autrement, avez vous une idée qui puisse m'aider pour mon drone @CriTof

Modifié (le) par Ronan 14
Lien à poster
Partager sur d’autres sites
Le 30/05/2021 at 21:43, Ronan 14 a dit :

Salut, j'ai récupéré un drone avec une fc naze 32, 4 moteurs grand turbo et 4 esc brushless motor de 20 ampères chacune. La carte de vol est parfaitement reconnue sur cleanflight j'avais déjà configuré mon drone mais il volait pas droit du coup j'ai refait tous le châssis sauf qu'une esc s'est cassée. Je l'ai donc changé et là quand je suis allé sur cleanflight aucun moteur ne tourne et la batterie n'est pas reconnue (il y a un bip répétitif et une led verte qui clignote et la led bleu qui est constante).

Je ne sais pas quel est le problème et je n'arrive pas à flasher mes esc le message suivant s'affiche sur blheli suite 32 : "initialization of serial 4way interface failed ! please check cleanflight revision for support of BLHeli32 serial 4way interface ! " Que dois je faire ? Pourtant avant mêmes avec les esc qui n'étais pas flashé les moteurs tournaient...  

IMG_20210530_204551.jpg

IMG_20210530_204555.jpg

IMG_20210530_204605.jpg

IMG_20210530_212455.jpg

IMG_20210530_204539.jpg

C'est peut-être bete, mais est ce que tes ESC sont compatible avecc le BLheli 32 ??? 

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
Il y a 12 heures, Oliviem a dit :

C'est peut-être bete, mais est ce que tes ESC sont compatible avecc le BLheli 32 ??? 

Oui justement je ne pense pas, elles communiquent en Simon K mais je n'ai pas trouvé sur internet d'autre moyen que blhelisuite pour flasher des esc.

D'ailleurs update, j'arrive  à faire tourner comme avant les 3 moteurs mais celui relié à la nouvelle esc ne tourne pas et j'ai identifié que le bip répétitif vient de cette nouvelle esc que j'ai installé (exactement la même que les autres pourtant et j'ai bien fait les soudures normalement...)

Modifié (le) par Ronan 14
Lien à poster
Partager sur d’autres sites
Youtube WE are FPV
Le 30/05/2021 at 22:02, Ronan 14 a dit :

Qu'est ce qu'il manque à mon inscription ?

La case présentation

Modifié (le) par Oxonium
  • +1 1
Lien à poster
Partager sur d’autres sites
Le 30/05/2021 at 21:43, Ronan 14 a dit :

Je ne sais pas quel est le problème et je n'arrive pas à flasher mes esc le message suivant s'affiche sur blheli suite 32 : "initialization of serial 4way interface failed ! please check cleanflight revision for support of BLHeli32 serial 4way interface ! " Que dois je faire ? Pourtant avant mêmes avec les esc qui n'étais pas flashé les moteurs tournaient...  

Lorsque j'ai commencé, j'avais construit un quadcopter avec des ESC d'avion RC. J'ai voulu les update pensant que tout été compatible avec BLhéli 32 (pour ma défense j'étais débutant) et en faisant cela j'ai effacer les Target + firmware des mes ESC. Et c'est alors que j'ai ce message d'erreur.

Sache que BLheli_suite et BHheli32 sont 2 interfaces différentes. BHheli32 est "payant" car tu le paies quand tu achètes tes esc (quelques centimes), d'où le fait qu'il n'est pas compatible avec tous les esc contrairement à BLhéli_suite qui avec un peu de bidouille permet de flasher tous ESC.

Lien à poster
Partager sur d’autres sites
Le 30/05/2021 at 21:43, Ronan 14 a dit :

IMG_20210530_204555.jpg

 

 

Bon au moins avec cette image je vois que tu utilises les BEC de tes ecs pour alimenter ta fc. déjà tu as éviter de griller ta fc en l'alimentant avec tous les +5V (4x 5V).

Mais je vois 4 gaines thermo (je suppose que tu as alors fait cette manip pour les 4 ESC). As tu laissé 1 seul +5V pour alimenter ta fc ? Parce que comme cela j'ai l'impression que tu n'alimentes plus ta fc.

Modifié (le) par Oliviem
Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Oliviem a dit :

 

 

Bon au moins avec cette image je vois que tu utilises les BEC de tes ecs pour alimenter ta fc. déjà tu as éviter de griller ta fc en l'alimentant avec tous les +5V (4x 5V).

Mais je vois 4 gaines thermo (je suppose que tu as alors fait cette manip pour les 4 ESC). As tu laissé 1 seul +5V pour alimenter ta fc ? Parce que comme cela j'ai l'impression que tu n'alimentes plus ta fc.

J'ai essayé avec un seul +5V et avec tous cela ne change presque rien... De plus je ne sais vraiment pas pourquoi mais je n'ai que deux moteurs qui tournent maintenant impossible d'utiliser les autres. Et cleanflight ne détecte toujours pas ma batterie et je n'ai trouvé personne qui avait eu ce problème sur internet. Le problème des moteurs est assez embetant il baisse de vitesse n'importe comment rien est homogène pourtant j'ai déjà fait une manip pour essayer de les reboot(gaz au max, branchement de la batterie et gaz au min, il s'en suit une petite musique ). 

Capture.PNG

Lien à poster
Partager sur d’autres sites
il y a 5 minutes, Ronan 14 a dit :

J'ai essayé avec un seul +5V et avec tous cela ne change presque rien... De plus je ne sais vraiment pas pourquoi mais je n'ai que deux moteurs qui tournent maintenant impossible d'utiliser les autres. Et cleanflight ne détecte toujours pas ma batterie et je n'ai trouvé personne qui avait eu ce problème sur internet. Le problème des moteurs est assez embetant il baisse de vitesse n'importe comment rien est homogène pourtant j'ai déjà fait une manip pour essayer de les reboot(gaz au max, branchement de la batterie et gaz au min, il s'en suit une petite musique ). 

Capture.PNG

As tu calibré tes esc après les avoir modifier avec le blhéli 32 ? Mais honnêtement, ce qui m'embête c'est que tu as plusieurs points qui m'inquiètes:

>capteur de tension

>sortie PWM qui selon toi font n'importe quoi

>Ton baromètre n'est pas lisible

J'ai peur que cela vient de ta carte qui ne doit pas être toute jeune.

 

Parce que tes ESC N'ont pas à être modifier sur logiciel et ils ont l'air de fonctionner lorsque la carte le veux.

 

Dernière hypothèse avant de changer ta fc, est que ton problème vient de toutes tes prises >>> qui augmente le risque de faux contact. Surtout si elles sont utilisées depuis longtemps. Alors je ne garantie pas de miracles mais essaie peut-être de souder tes esc à ta fc.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)
Le 02/06/2021 at 22:23, Oliviem a dit :

As tu calibré tes esc après les avoir modifier avec le blhéli 32 ? Mais honnêtement, ce qui m'embête c'est que tu as plusieurs points qui m'inquiètes:

>capteur de tension

>sortie PWM qui selon toi font n'importe quoi

>Ton baromètre n'est pas lisible

J'ai peur que cela vient de ta carte qui ne doit pas être toute jeune.

 

Parce que tes ESC N'ont pas à être modifier sur logiciel et ils ont l'air de fonctionner lorsque la carte le veux.

 

Dernière hypothèse avant de changer ta fc, est que ton problème vient de toutes tes prises >>> qui augmente le risque de faux contact. Surtout si elles sont utilisées depuis longtemps. Alors je ne garantie pas de miracles mais essaie peut-être de souder tes esc à ta fc.

J'ai réussi à régler plusieurs problèmes il m'en reste plus que un seul, je vais refaire un sujet ce soir car ce n'est plus du tout le même sujet. En conclusion, le problème de mes moteurs qui tournaient pas sur betaflight c'était simplement car les becs des esc pour alimenter la fc étaient pas tous dans le même sens (il fallait la masse vers le haut) donc après tous les moteurs ont tourné. 

Ensuite, pour la batterie c'est tout simplement que j'ai un bec à brancher sur la fc pour que toute les informations s'affichent.

Enfin pour flasher les esc comme les becs étaient dans le mauvais sens je ne pouvais pas toutes les flasher. Une fois dans le bon sens pour les flasher comme je suis pas en blheli j'ai juste à mettre les gaz au max sur betaflight puis à brancher ma batterie et à baisser les gaz (tous ceci accompagné de deux petites musiques avec le buzzer). Voilà donc tous mes moteurs et mes esc ainsi que ma fc fonctionnent parfaitement !! 

Et c'est là que je me heurte à un autre problème, je vous ferai part de mon nouveau problème ce soir ! 

Modifié (le) par Ronan 14
Lien à poster
Partager sur d’autres sites
il y a 24 minutes, Ronan 14 a dit :

J'ai réussi à régler plusieurs problèmes il m'en reste plus que un seul, je vais refaire un sujet ce soir car ce n'est plus du tout le même sujet. En conclusion, le problème de mes moteurs qui tournaient pas sur betaflight c'était simplement car les becs des esc pour alimenter la fc étaient pas tous dans le même sens (il fallait la masse vers le haut) donc après tous les moteurs ont tourné. 

Ensuite, pour la batterie c'est tout simplement que j'ai un bec à brancher sur la fc pour que toute les informations s'affichent.

Enfin pour flasher les esc comme les becs étaient dans le mauvais sens je ne pouvais pas toutes les flasher. Une fois dans le bon sens pour les flasher comme je suis pas en blheli j'ai juste à mettre les gaz au max sur betaflight puis à brancher ma batterie et à baisser les gaz (tous ceci accompagné de deux petites musiques avec le buzzer). Voilà donc tous mes moteurs et mes esc ainsi que ma fc fonctionnent parfaitement !! 

Et c'est là que je me heurte à un autre problème, je vous ferai part de mon nouveau problème ce soir ! 

bonne nouvelle, bravo à toi 🙂

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Ronan 14 a dit :

Et c'est là que je me heurte à un autre problème, je vous ferai part de mon nouveau problème ce soir ! 

Quel suspens....

  • Haha 3
Lien à poster
Partager sur d’autres sites
Le 04/06/2021 at 21:21, Attafr a dit :

Quel suspens....

Finalement j'ai pu tout régler le drone vole bien !! 

Pour avoir les moteurs qui tournent tous à la même vitesse il fallait que je configure les pitch, roll et yaw de ma mannette sur betaflight (pour qu'ils soient bien à 1500, de base certain étaient à 1400 ce qui expliquait la différence de vitesse de rotation). 

Voilà, merci beaucoup à tout ceux qui ont répondu pour m'aider !!  

  • Merci ! 2
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...