Aller au contenu
DroneBuilds

Pas de retour stick tx16s et RXSR sur nazgul5 sous betaflight


Messages recommandés

Bonjour, 

 

Je suis débutant, et je me permet de créer un post car malgré tout ceux créés sur ce sujet je ne parviens toujours pas à résoudre mon problème. J'ai une radio tx16s qui est binder avec le rxsr mais je ne reçois rien sous betaflight quand je bouge les sticks.

J'ai donc reçu il y a peu mon nazgul5 v2 avec un récepteur rxsr en eu lbt avec un firmware en 2.1.0, je n'arrivais pas à binder avec ma radio j'ai donc fait les mises à jour.

je suis passé de opentx 2.3.9 -> 2.3.11 et pour le firmware multi module 1.3.1.36 -> 1.3.2.77 qui m'a permis d'appairer la radio au rx. Malheureusement je n'ai pas de retour de stick sur betaflight. J'ai mis le récepteur en mode sbus (les leds bleu et verte), toutes les entrées/mixeurs/sorties de la radio sont paramétrées. J'ai réglé le receiver mode sur serial base receiver, le serial receiver provider sur frsky f.port, activé la telemetry, et dans le CLI j'ai set serialrx_porvider=FPORT, serial rx_inverted=ON, serialrx_halfduplex=OFF comme indiqué sur la fiche fournie avec le drone. Le serial RX est coché sur l'UART2. Sur la radio dans la partie capteur je n'ai que le TRSS, TQly, RSSI et BtRx ou je reçois des valeurs. Malgré tout rien ne bouge dans betaflight.

Merci à ceux qui prendront le temps de bien vouloir m'aider, je m'excuse si jamais je rate quelques chose d'évident.

Modifié (le) par spawox
Lien à poster
Partager sur d’autres sites
Il y a 8 heures, spawox a dit :

frsky f.port

Comment est flashé ton R-XSR ? Il y a un firmware ‘’spécifique’’ pour le FPort RXSR_LBT_v2.1.1_Fport.frk
ensuite tu dois utiliser le S.Port uninverted (pad P) si ta FC est une F4 ! à connecter sur le TX d’un UART !

4B9752DC-32EA-4B64-8E06-66B50BE82EBA.jpeg.8f45b50e3bd6af7a8c51fa28482d7a75.jpeg

Lien à poster
Partager sur d’autres sites

J'ai suivi cette vidéo ou apparement un des cables était sur le sbus out et pas sur le S.Port, j'ai donc fait sa manip, et j'ai également flashé le RX avec le firmware que vous avez mentionné et j'ai enfin eu des retour des sticks dans beta. Merci beaucoup pour les indications !

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...