Aller au contenu
acheter dji air unit o3
DroneBuilds

Nazgul Evoque - Configuration du GPS


Jo72190

Messages recommandés

Bonjour a tous,

Je suis relativement new dans le fpv, j'ai cherché un peu partout sur internet mais je n'arrive pas a régler mon dernier problème.

Le GPS de mon Nazgul Evoque ne marche pas. (il s'agit du GPS pré-installé, ca n'est pas moi qui l'ai monté)

Je pense pourtant avoir tout bien paramètre mais n'étant vraiment pas un expert, la je bloque..

Sur la page Setup de BF je vois bien mon GPS, par contre le GPS 3D Fix est false ... je ne sais pas trop ce que ça signifie...

Sur la page Port : j'ai mis le GPS en auto sur le UART4, il revient à 57600 quand j'enregistre

Sur la page config j'ai activé le GPS.

J'ai une led rouge fix sur le GPS, et quand je vole, sur l'OSD toutes les données lié au GPS ne bougent pas

Je n'arrive pas a trouver ce que je loupe, une idée ?

Merci d'avance pour votre aide

Capture d’écran 2022-03-02 à 14.47.51.png

Capture d’écran 2022-03-02 à 14.48.16.png

Capture d’écran 2022-03-02 à 14.48.04.png

Lien vers le commentaire
Partager sur d’autres sites

Je suis pas sur Betaflight... Emu parce que j'adore.

Et surtout, coche le petit onglet "Enable expert mode " ! Car tu n'as pas toutes les infos que peut t'offrir le configurateur.

Enfin, envoie nous la capture d'écran dans le CLI de ton  Get GPS 

Lien vers le commentaire
Partager sur d’autres sites

J'ai modifié le mode expert en effet ca apporte plus de chose.

Voila le résultat du CLI:

 

# Get GPS
###WARNING: NO CUSTOM DEFAULTS FOUND###
gps_provider = UBLOX
Allowed values: NMEA, UBLOX, MSP
Default value: NMEA

gps_sbas_mode = NONE
Allowed values: AUTO, EGNOS, WAAS, MSAS, GAGAN, NONE

gps_sbas_integrity = OFF
Allowed values: OFF, ON

gps_auto_config = ON
Allowed values: OFF, ON

gps_auto_baud = ON
Allowed values: OFF, ON
Default value: OFF

gps_ublox_use_galileo = OFF
Allowed values: OFF, ON

gps_ublox_mode = AIRBORNE
Allowed values: AIRBORNE, PEDESTRIAN, DYNAMIC

gps_set_home_point_once = OFF
Allowed values: OFF, ON

gps_use_3d_speed = OFF
Allowed values: OFF, ON

gps_rescue_angle = 32
Allowed range: 0 - 200

gps_rescue_initial_alt = 50
Allowed range: 20 - 100

gps_rescue_descent_dist = 200
Allowed range: 30 - 500

gps_rescue_landing_alt = 5
Allowed range: 3 - 10

gps_rescue_landing_dist = 10
Allowed range: 5 - 15

gps_rescue_ground_speed = 2000
Allowed range: 30 - 3000

gps_rescue_throttle_p = 150
Allowed range: 0 - 500

gps_rescue_throttle_i = 20
Allowed range: 0 - 500

gps_rescue_throttle_d = 50
Allowed range: 0 - 500

gps_rescue_velocity_p = 80
Allowed range: 0 - 500

gps_rescue_velocity_i = 20
Allowed range: 0 - 500

gps_rescue_velocity_d = 15
Allowed range: 0 - 500

gps_rescue_yaw_p = 40
Allowed range: 0 - 500

gps_rescue_throttle_min = 1100
Allowed range: 1000 - 2000

gps_rescue_throttle_max = 1600
Allowed range: 1000 - 2000

gps_rescue_ascend_rate = 500
Allowed range: 100 - 2500

gps_rescue_descend_rate = 150
Allowed range: 100 - 500

gps_rescue_throttle_hover = 1280
Allowed range: 1000 - 2000

gps_rescue_sanity_checks = RESCUE_SANITY_ON
Allowed values: RESCUE_SANITY_OFF, RESCUE_SANITY_ON, RESCUE_SANITY_FS_ONLY

gps_rescue_min_sats = 8
Allowed range: 5 - 50

gps_rescue_min_dth = 100
Allowed range: 50 - 1000

gps_rescue_allow_arming_without_fix = OFF
Allowed values: OFF, ON

gps_rescue_alt_mode = MAX_ALT
Allowed values: MAX_ALT, FIXED_ALT, CURRENT_ALT

gps_rescue_use_mag = ON
Allowed values: OFF, ON

frsky_gps_format = 0
Allowed range: 0 - 1

osd_warn_no_gps_rescue = ON
Allowed values: OFF, ON

osd_warn_gps_rescue_disabled = ON
Allowed values: OFF, ON

osd_gps_speed_pos = 2361
Allowed range: 0 - 15359
Default value: 234

osd_gps_lon_pos = 2080
Allowed range: 0 - 15359
Default value: 234

osd_gps_lat_pos = 2048
Allowed range: 0 - 15359
Default value: 234

osd_gps_sats_pos = 2068
Allowed range: 0 - 15359
Default value: 234

osd_gps_sats_show_hdop = OFF
Allowed values: OFF, ON

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Comme souvent la solution a un problème est plus simple que le problème que l'on se crée. J'ai attendu 5min dans le jardin et boom il s'est mis a chercher et trouver des satellites, les données GPS sont apparu sur l'osd. Problème résolu ! Merci pour l'aide

Modifié (le) par Jo72190
Lien vers le commentaire
Partager sur d’autres sites

  • 5 months later...

Je rebondis sur ce sujet même s'il ne s'agit pas forcément du GPS,  mais des settings d'origine sur le Evoque sous Betaflight.

En grand débutant que je suis je n'ai pas sauvegardé ma configuration d'origine sur mon Evoque avec un diff, mais apvec l'interface backup and restore.
Et je viens d'apprendre qu'en faisant cela, il ne sauvegarde pas certaines données, notamment la config des moteurs.

Et c'est bien le cas car après avoir flash la dernière version de Betaflight, j'ai un warning comme quoi il lui faut une config moteur.

Serait-il possible à quelqu'un qui a un Nazgul Evoque de me filer ce que le diff sort comme réglages d'origine ? Car je partirais bien sur ceux-ci pour commencer...

Merci beaucoup d'avance ! 

Lien vers le commentaire
Partager sur d’autres sites

  • 2 months later...

Je me retrouve avec le même problème que toi, a savoir que le GPS de mon Nazgul evoque reste à False sur le 3D Fix.
Et le GPS reste avec les led rouges.
Je précise que le drone a mangé un arbre, ca n'aide probablement pas.

Sous Beta, je l'ai bien configuré sur l'UART4 et il apparait bien en jaune sur l'icone. Pour le reste j'ai la même config que toi sur tes screenshots

GPS HS vous pensez ?

Capture.png

IMG20221114125634.jpg

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...