Aller au contenu
acheter dji air unit o3
DroneBuilds

BF ne reçois pas de signaux de ma radiocommande DJI fpv.


Aerofort
Aller à la solution Résolu par Aerofort,

Messages recommandés

Bonsoir a tous,

Après avoir galérer plusieurs semaine sur le montage de mon premier quad en numérique sous cadxx vista. (même si j'ai eu aussi beaucoup de satisfaction).

J'ai l'impression de toucher au but mais me voila bien coincé. J'ai revérifier et refait toute les soudure un nombre incalculable de fois. Tout est a jour et bindé. Je reçois le signal de ma radiocommande dans mon osd et même les info de la batterie. Mais les infos de la radiocommande se transmette pas a la fc et a l'osc et donc rien ne se passe dans la partir receiver de BF.

J'ai bien mis le même protocole sbus et sbus baud fast entre le masque et la FC. Qui est d'ailleur un stack Zeus F748 48A.

Si quelqu'un a une ombre d'idée je le lui en serai grandement reconnaissant.

Bonne soirée et avec la hâte de vous lire,

 

 

Capture d’écran 2022-03-09 à 23.49.37.png

Capture d’écran 2022-03-09 à 23.50.10.png

Capture d’écran 2022-03-09 à 23.49.51.png

IMG_0028.HEIC IMG_0030.HEIC

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Ça pourrai venir du mode fast bus qui est mal paramétrer?

J'ai vu quelque part que si on le fesait pas BF ne reconnaitrait pas la RC.

J'ai juste taper la commande set bus_baud_fast=ON dans CLI je ne sais pas si il y a d'autre chose a faire.

@Motard Geek Je ne suis pas sur de comprendre la question. Mais le receiver est sur le UART1.

Lien vers le commentaire
Partager sur d’autres sites

il y a 25 minutes, spid99 a dit :

TX4 &RX4 @Motard Geek C'est correcte ...

Il a mis 1 dans BF.

il y a 13 minutes, Aerofort a dit :

Mais le receiver est sur le UART1.

Qui dit vrai / juste du coup ?

Lien vers le commentaire
Partager sur d’autres sites

Je ne comprend pas tout donc j'ai surement fait des erreur.

Voila ce que dit la doc:

1.URAT1 uses the receiver
2.URAT2 uses GPS
3.URAT3 uses VTX image transmission
4.URAT4 uses DJI
5.URAT6 uses ESC telemetry

et ce que j'ai fait:

J'éspère que l'on distingue mieux. Merci beaucoup en tout cas!

170192456_Capturedecran2022-03-10a17_59_23.thumb.png.750d90f7edf8cece0ebfaf0ea92645bd.png

1942592360_Capturedecran2022-03-10a17_59_28.thumb.png.8494bc5874e725201f4b8b234f5c1ee4.png

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, Aerofort a dit :

J'ai juste taper la commande set bus_baud_fast=ON dans CLI je ne sais pas si il y a d'autre chose a faire.

Pour le Fast Bus il faut aussi lui dire dans les lunettes 😉https://david840709.gitbook.io/transtec/tech/untitled

image.png.958b004e7c9c9dfb93e55c8fa8b8630f.png

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, Aerofort a dit :

Merci beaucoup oui je l’ai déjà mis dans les lunettes. Ça n’a malheureusement pas réglé ce problème ci.

Tu es bien sur d'avoir branché rx sur tx(fc) et tx sur rx(fc) pas rx sur rx et tx sur tx...par hasard 🤔

Modifié (le) par MystoganFPV
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

J'ai aussi beaucoup beugé la dessus car les couleurs des câble était pas les même que ceux de la doc. J'ai intervertie plusieurs fois, et quoi que j'essaye d'autre, je perd les infos de la batterie. Je trouve cela bizarre que en débranchant le rx je perd les infos de batterie dans l'osd mais souate.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 5 heures, spid99 a dit :

Y'a pas de différence avec les RX "Normaux"

Non, mais il pourrait tout à fait utiliser un autre UART. Comme je ne voyais pas l'UART sur lequel il a soudé sur la photo, je demandais juste, pour être sûr que ce soit bien le 1 comme paramétré dans BF 😉 

Lien vers le commentaire
Partager sur d’autres sites

il y a 17 minutes, Aerofort a dit :

Merci! Après avoir revérifier je suivait le mauvais shéma j'avais bien inversé. Mais après avoir ré inverser, non seulement le problème persiste, mais en plus je perd les données de la batterie dans l'osd. C'est a n'y rien comprendre..

Ouh lalala ça sent la saucisse grillée ton histoire 😜

Quel schema as tu suivi pour connaître un peu plus de détails ?

Et dis nous, si tu te souviens les erreurs que tu as commises , je veux dire par là, où as tu branché les fils exactement ?

J'espère pas que tu as envoyé du 5 volts ou du 9 volts sur un tx ou rx ou un truc du genre...

Modifié (le) par MystoganFPV
Lien vers le commentaire
Partager sur d’autres sites

J'ai suivi celui la sauf que au début  J'ai pris les couleurs en référence et sur mes câble, Le sbus est en bleus et gnd qui est a coté en vert. j'ai donc inverser avec rx et tx qui sont eux blanc et jaune. Mais il me semble pas avoir mis le 9v autre part. Mais maintenant que tu me le dit je suis a deux doigt d'essayer avec le cadxx de mon autre quad pour être sur de n'avoir rien griller.

422446_Capturedecran2022-03-11a13_41_06.png.2b05a76abce2447be4b2fc15ffd09304.png

Lien vers le commentaire
Partager sur d’autres sites

Je ne me fie plus aux connecteurs depuis que j'ai reçu un Vista avec alim inversé chez HOMFPV... C'est plus prudent de vérifier l'ordre et la destination des fils 🙂 

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Si je me fit a la doc et après avoir rererevérifier tout est bon.

Mais si elle est mauvaise Devrai-je essayer de faire une soudure "manuelle" direct sur la fc comme sur la photo et si oui comment faire?

Ou devrai-je plutôt m'assurer que je n'ai rien griller en essayant sur un autre caddx?

IMG_0040.HEIC

Merci beaucoup pour votre réactivité et le temps que vous prenez pour me répondre.

Lien vers le commentaire
Partager sur d’autres sites

il y a 29 minutes, Aerofort a dit :

Devrai-je essayer de faire une soudure "manuelle" direct sur la fc comme sur la photo

Si tu peux mettre la photo ? car ton truc en PJ ...On ne peut l'ouvrir ..Un Copier/coller suffit si ce n'est pas trop gros

Modifié (le) par spid99
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...