Aller au contenu
acheter dji air unit o3
DroneBuilds

Bug pendant un flip "rapide" (video et blackbox)


AunA
Aller à la solution Résolu par AunA,

Messages recommandés

Bonjour,

Ca fait pas très longtemps que j'ai commencé ce hobby et je n'ai pas l'habitude de demander de l'aide mais cette fois ci je bloque.

Pour faire court j'ai des réactions anormales lors d'un flip ou même parfois lors du rattrapage d'un split-s ainsi que certains autres cas. Je précises que ce bug ne se réalise pas à chaque fois, parfois je les enchaines et parfois rien mais au moins 1 fois par lipo

Comme le bug lors du flip est le plus simple à reproduire, c'est le seul que j'ai réussi à capturer.

/!\ le flip sur la vidéo et dans la blackbox ne sont pas exactement les mêmes /!\

 

572503317_flipbug.thumb.png.31be704e457d95e832b78bc1e2b3ad10.png

J'ai aussi capturé un flip "normal" du moins, sans bug

 

86055099_flippasbug.thumb.png.19870aa78ea2ca926a290fd900b2feb3.png

J'ai rapidement remarqué le soucis dans la blackbox mais je n'arrive pas à l'interpréter pour le régler

Voici mes config betaflight

image.thumb.png.da97166b9cce47f55a95f62cf32f0456.pngrate.thumb.png.72bc7b807c1dc2fabf496bbd07c9ecc2.pngfiltre.thumb.png.bcf4e91d8b160af7f2535010772f4daf.png

J'ai déjà essayé pleins de choses, je précises aussi que c'est un drone DIY 5" 6s avec des composants plutôt haut de gammes et que ce bug n'apparait pas à chaque fois.

Je ne vois pas d'anomalies dîtes mécaniques.

Je pense avoir toujours eu ce bug mais je l'ai surtout remarqué quand j'ai augmenté mes rates. Je tiens aussi à dire que lorsque j'ai testé de changer de protocole d'esc pour passer de DSHOT600 à un protocole analogique il me faisait des flips of death, j'ai remis en DSHOT600 parce que je préfère avoir un bug rattrapable que une toupie incontrôlable.

Dans la semaine j'essayerais de changer tous mes filtres et PID en "stock" mais si quelqu'un a une suggestion, ça m'aiderai beaucoup. Merci

Lien vers le commentaire
Partager sur d’autres sites

Hello. 

Alors, vu comme ca, je dirait que 1.8 de stick reponse gain c'est un peu beaucoup et que tes pids on était réglés au pti bonheur la chance.

Pourquoi tu ne passerais pas en 4.3 pour tester, c'est vraiment top je trouve. 

Et au passage, check bien qu'il n'y ai rien qui bouge dans le drone, juste un fils qui chatouille ton gyro et ca suffit a foutre le bordel

Ah et, essayes d'héberger tes vidéos sur youtube ou streamable.com pour alléger les fofo stp

Lien vers le commentaire
Partager sur d’autres sites

Merci pour la réponse, je vais tester et bouger mes PID alors et essayer le 4.3 

Après vérification rien ne touche le gyro, il y a juste le strap lipo au dessus

il y a 14 minutes, Eve a dit :

Ah et, essayes d'héberger tes vidéos sur youtube ou streamable.com pour alléger les fofo stp

Yep je ferais attention la prochaine fois

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

prareil que @Jerome, ca ressemble a une microdesync pas trop mechante :

diminue un chouilla le rampup power des esc, et augmente le demag compensation..... et tu pourras dire adieu a ce probleme....

Lien vers le commentaire
Partager sur d’autres sites

Très bien ! là je suis passé sous betaflight 4.3 et j'ai tout laissé en stock sauf le stricte nécessaire.

Si tout vas bien durant plusieurs lipo j'essaierai avec les filtres et pid.

j'ai déjà baissé le rampup power jusqu'à 25% mais jamais touché au demag compensation, c'est bon à savoir si ça ne va toujours pas.

En tous cas merci ça m'aide à avancer. Je ferai une update si tout vas bien ou pas dans la semaine.

Lien vers le commentaire
Partager sur d’autres sites

25% ca me paraît vraiment peu, j'irais pas en dessous de 35-40% pour un 5". Tu peux aussi mettre un motor timing à 23 et passer en 48 Khz pour le PWM Frequency.

En 4.3, le Dynamic Idle peut aussi considérablement aider sur les desync, essaie avec une valeur autour de 20.

Faut dire que tes rates sont très très élevés, ça peut favoriser ces micro desyncs sur des mouvements très très secs.

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

  • Solution

Wow ! j'ai enfin eu la sensation d'avoir confiance en mon drone !! J'ai réussi à enchaîner les figures en un temps record. J'ai fais qu'une lipo mais c'est sur la bonne voie.

Ducoup c'était un vol stock (avec mes rates) et effectivement j'en avais jamais fais, 1ere fois que je ressent les rebonds et le prop wash. Ca venait alors soit du detaflight 4.2 soit de mes réglages de filtres et PID.

Je vais aussi remonter le rampup power et mieux me renseigner sur les réglages.

Dans tous les cas merci beaucoup des suggestions et bonne fin de soirée.

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

A mon avis c'était le SRG de 1.8 qui affolé tout. Si tu veux, le SRG il va anticiper ce que tu vas faire pour diminuer le temps de réponse, mais la c'était un peu beaucoup a mon avis

  • Bouillant ! 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...