Aller au contenu
DroneBuilds
Syrex

kiss BlackBox Openlog et Kiss FC : comment analyser ?

Messages recommandés

Salut à tous !

J'ai un petit problème d'oscillations avec mon quad full kiss. Le problème se retrouve à mi-gaz environ. Il est surtout présent depuis la version 1.2 de la kiss. Sur la 1.3, les oscillations sont toujours là et sous 1.1, elles sont perceptibles mais moins gênantes. J'ai vérifié la fixation de la caméra, de la FC en hard mount, des moteurs en soft mount, c'est pas çà. J'ai joué avec la valeur yaw filter, çà ne suffit pas. 

Je croyais que mes moteurs (Emax RS2205-2600) avait un coup dans le nez mais malgré leur remplacement par des TBS, j'ai exactement le même problème. 

Donc, je me suis enfin décidé à me trouver une black box, openlog chez banggood. Je l'ai cablé avec une petite prise de récupération, branché sur la FC puis j'ai modifié le fichier config.TXT en remplaçant 115200 par 250000. J'ai été sous kiss pour activer la black box. J'ai fait un test et j'obtiens effectivement un fichier log que j'arrive à ouvrir avec betaflight black box.

Mais maintenant, j'aimerai profiter de votre connaissance pour savoir ce que je dois chercher pour trouver peut etre une explication à mon problème d'oscillation ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Je sais que c'est une piste, je n'ai pas encore reçu mes autres hélices pour l'instant j'ai des king Kong 50x40x3.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai déjà joué avec le yaw filter . Je vol cet après-midi pour avoir un fichier log, je l'envoie à l'issue.

Partager ce message


Lien à poster
Partager sur d’autres sites

L'avis de Kiss :S

debug kiss.jpg

Screen Shot 2017-07-07 at 18.46.11.png

Kiss Debug 2.jpg

 

Il me demande si t'utilises le notch filter ? D'après ce log 210/100 pour le pitch et 250/150 en roll pourraient être de bonnes valeurs mais faudrait étudier ton setup avant.

T'es pas en PID defaut ? Il pense que t'es "overtuned".

T'as gardé les softmounts pour ce log ?

Tu peux refaire une description détaillée de ton quad stp ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je dois avoir un bug avec Tapatalk. Je viens de faire une réponse et elle apparaît partiellement.

bref, donc mon quad est un martian 220 (copie d'alien), un fc kiss sous 1.2 en hard mount, des esc 24a re en dShot 600, des moteurs tbs Steele 2306-2345 en soft mount plusieurs couches de scotch d'électricien, je n'utilise pas les notch filter, je suis en pid stock me semble t'il :

 

IMG_0469.JPG

IMG_0471.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

PID stock c'est pas normal ce graph...

Tu peux faire une vidéo du graph gyro dans motor test avec chacun des moteurs ?

Ton quad peut pas voler bien avec des logs pareil :S

T'as un condo ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu veux une vidéo du graph gyro dans motor test dans kiss gui ? Je peux pas en ce moment je suis en week-end 4 jours sans le PC :/

oui j'ai un condo sur une pdb matek avec osd intégré 

C'est bizarre car franchement le quad vole super bien, la vibration mi-gaz c'est à la marge. J'ai un x210 performant avec une f3 sous betaflight en pid stock et lui j'ai moins de feeling.

Je pensais que mon problème de vibrations venait des hélices,des king Kong 5040x3 pas vraiment réputées ou du support de caméra , une foxxer Monster qui pourrait entrer en résonnance à une fréquence donnée...

je me demande même si on parle du bon log car j'ai volé hier et sur la runcam 3, on ne perçoit pas les vibrations, le quad vole plutôt bien, le reste, c'est mon niveau ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Si ça ne se perçoit qu'à mid tant mieux mais le log n'est vraiment pas bon (le son non plus d'ailleurs), surtout pour du PID défaut

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, par quoi commencer ???

je vais utiliser le notch filter avec les valeurs ci dessus mais ensuite...

Partager ce message


Lien à poster
Partager sur d’autres sites

Motor test dans l'application kiss gui ? Non, dans 3 jours j'aurais un PC pour vérifier.
C'est toi qui a parlé de debug kiss, je me demandais à qui tu t'étais adressé...

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai testé avec les notch filter. Je constate une amélioration. Je viens de remarquer également c'est qu'avec la runcam 3 j'ai moins de vibrations.

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est encore moi avec mon problème de blackbox...  Je me demande si mon enregistrement est bien normal car j'ai un doute :

Par exemple, sur l'image tirée de mon log ci-dessous, je n'affiche que le graph RC Command roll, je ne comprends pas pourquoi, le graph est en "escalier "lorsque je bouge le roll, je devrais plutôt avoir un tracé lisse, non ? de plus j'ai comme des coupures, il s’arrête et reprend un peu plus loin... Pourquoi ?

Avant d'aller plus avant, dois je m'interroger si ma blackbox fonctionne correctement ?  Je crois que ma blackbox openlog est sous le firmware V2, j'ai vu qu'il existe une V3... Pour les coupures, pourrait il avoir son origine au niveau de la carte SD que j'ai utilisé... 

LOGRCCOMMAND.thumb.JPG.bed73287f262e2dfbb38f36187df0003.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca coûte rien d'essayer avec une SD plus performante.

Pour les escaliers c'est pas normal en effet...

Tes endpoints et midpoints sont bien réglés ? Pas de gigue sur tes canaux dans data output ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vais vérifier ma carte sd car pour certaines, même si elles sont performantes en vidéo hd, pour la blackbox ce n'est pas forcément vrai...

mes endpoints et midpoints sont nickel, j'ai mis un deadband dans la taranis avec une courbe pour le pitch, roll et yaw.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×