Aller au contenu
bannière promotion betafpv elrs
DroneBuilds

Ne voit pas les sticks sous betaflight


Armand_fpv

Messages recommandés

Cet aprèm j'ai soudé un EL24E à la stack de mon Nazgul5 V2. J'ai ensuite flashé ma radiomaster zorro ELRS et mon EL24. Je les ai bind et ils sont connectés mais quand j'appuie sur "tele", j'ai aucune info de télémétrie du quad. J'ai donc branché le quad sur betaflight et je ne sais pas pourquoi mais quand je bouge les stick, inters, rien ne bouge.

Merci de votre aide

Lien vers le commentaire
Partager sur d’autres sites

il y a 10 minutes, Valtor a dit :

salut tu as bien inversé tx et rx ?

Tu as bien activé sérial rx dans "port" sur le bon uart ?

Tu as bien mis "crsf" dans récepteur de Betaflight ?

Valtor

J'ai fait R ⏩ T2,       T ⏩ R2,          + ⏩ 5V       , - ⏩ GND

 

La soudure T ⏩ R2 était la moins propre mais elle fait le taf.

J'ai mais "serial RX" sur le 2ème UART

Lien vers le commentaire
Partager sur d’autres sites

Aucune info de télémétrie ça veut dire que tu n'es pas bind, sinon tu aurais au moins le télémétrie de recepteur

genre son voltage

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 5 minutes, Eve a dit :

Aucune info de télémétrie ça veut dire que tu n'es pas bind, sinon tu aurais au moins le télémétrie de recepteur

genre son voltage

Sur l'écran d'accueil de la radio j'ai la connexion (logo 4g) avec le quad lorsqu'il est allumé et je l'ai pas lorsqu'il est éteint. Pareil pour la télémétrie, lorsqu'il est allumé j'ai pas le "no data" alors que lorsqu'il est éteint j'ai "no data" et "télémétrie perdue ".Sauf que les seules données visibles sont le voltage de LA RADIO, et l'heure.

Donc je pense qu'il est bind

La soudure T vers R est pas très bien faite, cela viendrait de là ?

Et même si cette soudure était mal faite, ça n'empêcherait pas d'avoir les sticks sur betaflight  

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Chelou, ptet ton recepteur n'envoi pas ca propre télémétrie... 

Dans ce cas, si tu es certain d'etre bing ca veut dire que le recepteur ne communique pas? si t'es reglages BF sont bon dans l'onglet port (et ca a l'air d'etre le cas), peut etre vérifier les soudures (bah si ^^) ou changer d'UART

Lien vers le commentaire
Partager sur d’autres sites

@Armand_fpv, Tu as quoi comme radio ? elle est sous OpenTX ? Si oui vas dans la page Télémétrie et fais "effacer les capteurs" et "decouvrir les nouveaux capteurs".

Si pas mieux, peux tu nous confirmer que dans le script ELRS il y a bien un "C" en haut à droite et non un "-".

Modifié (le) par Loak
Lien vers le commentaire
Partager sur d’autres sites

il y a 17 minutes, Loak a dit :

@Armand_fpv, Tu as quoi comme radio ? elle est sous OpenTX ? Si oui vas dans la page Télémétrie et fais "effacer les capteurs" et "decouvrir les nouveaux capteurs".

Si pas mieux, peux tu nous confirmer que dans le script ELRS il y a bien un "C" en haut à droite et non un "-".

J'ai bien une radio sous un programme libre (edge TX). radiomaster zorro en ELRS

En faisant "add new" dans l'onglet "telemtry", il trouve 18 capteurs dont le 11ème "FM" avec une error ("!ERR*")

Modifié (le) par Armand_fpv
Lien vers le commentaire
Partager sur d’autres sites

@Armand_fpv, cool, c'est que tes tx et rx sont dans le bon sens et que tu es bien bindé (sinon tu aurais pas plus de 10 capteurs).

FM c'est pas grave c'est le fly mode, si tu n'est pas armé je crois qu'effectivement il met ERR

Regardes maintenant dans le script LUA ELRS (indispensable, j'espère que tu l'as installé sinon fais le). Ton soucis semble correspondre à un problème de "Model match". Verifie dans le script que ce paramètre est sur off.

Lien vers le commentaire
Partager sur d’autres sites

il y a 8 minutes, Loak a dit :

@Armand_fpv, cool, c'est que tes tx et rx sont dans le bon sens et que tu es bien bindé (sinon tu aurais pas plus de 10 capteurs).

FM c'est pas grave c'est le fly mode, si tu n'est pas armé je crois qu'effectivement il met ERR

Regardes maintenant dans le script LUA ELRS (indispensable, j'espère que tu l'as installé sinon fais le). Ton soucis semble correspondre à un problème de "Model match". Verifie dans le script que ce paramètre est sur off.

Le script dont tu parles est dans mon TX si ? car je ne trouve pas le "script LUA ELRS". 

Le seule script que j'ai installé était dans le configurateur après avoir choisi mon model ELRS

Imagdcde2.png

Lien vers le commentaire
Partager sur d’autres sites

il y a 16 minutes, Loak a dit :

@Armand_fpv, cool, c'est que tes tx et rx sont dans le bon sens et que tu es bien bindé (sinon tu aurais pas plus de 10 capteurs).

FM c'est pas grave c'est le fly mode, si tu n'est pas armé je crois qu'effectivement il met ERR

Regardes maintenant dans le script LUA ELRS (indispensable, j'espère que tu l'as installé sinon fais le). Ton soucis semble correspondre à un problème de "Model match". Verifie dans le script que ce paramètre est sur off.

j'ai re généré le script et je l'ai remplacé et mtn je n'ai plus accès avec "express ELRS OU elrs" sur la radio

*MY BAD  il est tout en bas de la liste

il y a 4 minutes, Loak a dit :

c'est le elrsv2, qui doit apparaitre dans ta radio sous le nom d' ExpressLRS

J'ai bien un C en haut à droite

Modifié (le) par Armand_fpv
Lien vers le commentaire
Partager sur d’autres sites

il y a 3 minutes, Armand_fpv a dit :

J'ai bien un C en haut à droite

ça c'était sûr tu as les 18 capteurs de télémétrie, que dit la ligne "Model match" dans ce script ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 10 minutes, Loak a dit :

ça c'était sûr tu as les 18 capteurs de télémétrie, que dit la ligne "Model match" dans ce script ?

Il est en OFF et quand je le change en ON il dit "télémétrie perdue", après il se désactive et dit "télémétrie retrouvée"

J'ai déco le quad et mtn j'ai réussi à mettre ON

il y a 10 minutes, Loak a dit :

ça c'était sûr tu as les 18 capteurs de télémétrie, que dit la ligne "Model match" dans ce script ?

Voici mon betaflight

image_2022-06-22_185826901.png

Imaerfrfge2.png

Imssdsage2.png

Modifié (le) par Armand_fpv
Lien vers le commentaire
Partager sur d’autres sites

Ok, il faut qu'il soit sur off.

Connectes toi à ton Rx en wifi (à la page 10.0.0.1) et vérifie que la valeur du "model match" est à 255.

Si c'est le cas c'est que ton UART est en mode sbus inversé, ça tu n'y peux rien (je crois) et tu auras 2 possibilités : changer d'UART, mais je trouves que c'est un peu comme pêcher à la dynamite et si un jour tu veux ajouter quelque chose sur cet UART tu auras le même soucis, ou alors, laisser ton rx sur cet UART et recompiler ton firmware avec l'option RCVR_INVERT_TX et le réuploader dans ton rx.

Modifié (le) par Loak
Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, Loak a dit :

Ok, il faut qu'il soit sur off.

Connectes toi à ton Rx en wifi (à la page 10.0.0.1) et vérifie que la valeur du "model match" est à 255.

Si c'est le cas c'est que ton UART est en mode sbus inversé, ça tu n'y peux rien (je crois) et tu auras 2 possibilités : changer d'UART, mais je trouves que c'est un peu comme pêcher à la dynamite et si un jour tu veux ajouter quelque chose sur cet UART tu auras le même soucis, ou alors, laisser ton rx sur cet UART et recompiler ton firmware avec l'option RCVR_INVERT_TX et le réuploader dans ton rx.

Model match est bien sur 255 et quand j'avais compilé mon firmware j'avais coché " RCVR_INVERT_TX"

image_2022-06-22_191303380.png

Lien vers le commentaire
Partager sur d’autres sites

si tu parles de RCVR_INVERT_TX  et ben ... j'en ai en fait aucune idée, enfin pas une idée précise.

J'ai l'impression que certains rx travaillent avec des impulsions négatives (sûrement en tension)  et d'autres positives, mais là ça n'est que conjectures. Certaines FC proposent un UART avec Tx1 IR1 Rx1, le IR1 étant le Tx1 inversé. Le compilateur ELRS te permet de définir ça du côté du récépteur. Mais bon ce que je dis est à prendre avec de grandes pincettes.

Mais par défaut, il me semble que ce paramètre est décoché, non ? tu y as touché lors de ta première compil' ?

Modifié (le) par Loak
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...