Aller au contenu
DroneBuilds

Le quad oscille après changement de la FC


Nicette
Aller à la solution Résolu par Nicette,

Messages recommandés

Bonjour,

Je possède un Sector X5 de HGLRC.

La FC F722 mini ne fonctionnant plus, j'ai commandé et remplacé celle-ci par une F722 normale (pas mini).

Les trous de fixation étant du 30x30 et plus du 20x20, j'ai aussi changé l'ESC 4-1 par une 60A.

Après avoir fait toute la configuration dans Betaflight, j'ai monté les hélices et j'ai fait un essai.

Je mets les gaz, et là, le quad monte d'un coup à 50cm et il coupe les gaz.

Ensuite, j'ai enlevé les hélices, démarré les moteurs sans pousser les gaz.

Dès que je soulève le quad de quelques centimètres en le tenant par la batterie, il se met à osciller horizontalement sur l'axe du yaw avec des amplitudes de plus en plus grandes.

Un d'entre vous pourrait-il m'éclairer sur l'origine du problème ?

Merci

Lien vers le commentaire
Partager sur d’autres sites

Effectivement ya un probleme !!

 

 

 

 

Bon sinon plus sérieusement, c'est un probleme de config a tous les coups. refait la config de 0, ne tune pas avant d'avoir régler RX, moteurs, etc. pour moi c'est un mini fly away, donc probleme de pid/filter.

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, Nicette a dit :

Dès que je soulève le quad de quelques centimètres en le tenant par la batterie, il se met à osciller horizontalement sur l'axe du yaw avec des amplitudes de plus en plus grandes.

c'est tout à fait normal ça !

Lien vers le commentaire
Partager sur d’autres sites

J'ai fait le test avec mes autres quads, c'est normal qu'ils réagissent mais là c'est vraiment pas le même comportement, on dirait qu'il part en résonnance droite gauche.

Lien vers le commentaire
Partager sur d’autres sites

Merci Oxonium,

J'ai re-flashé la FC, mis la config par défaut proposée par betaflight pour cette carte, paramétré le RX, vérifié les moteurs et c'est tout, aucun tuning.

C'est pareil, le drone décolle puis saute à 50cm et retombe.

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Ce matin, j'ai mis les lunettes pour avoir l'OSD, dès que je décolle et qu'il retombe, j'ai le message "FLYAWAY".

Lien vers le commentaire
Partager sur d’autres sites

Bon ca nous donne pas grande piste, peux tu nous faire des screens de ta config? un flyaway, vu qu'il décolle, c'est déja que les hélices sont dans le bon sens !

Tous les Flyaway que j 'ai pu avoir c'est une petite merdouille dans la config, généralement pour moi c’était le sens des hélices/moteurs qui étaient mauvais (motuers config en props out, mais en props in dans BF par exemple), ou un probleme de filtres

Lien vers le commentaire
Partager sur d’autres sites

Voilà mes captures de Betaflight.

J'ai un autre problème : quand je teste sans hélice, je pousse le Throttle puis je le ramène mais le drone garde la vitesse de rotation rapide et ne revient pas à celle de l'armement.

 

00 Installation.PNG

01 Ports.png

02 Configuration.PNG

03 PID-1.PNG

03 PID-2.PNG

03 PID-3.PNG

04 Récepteur.PNG

05 Modes.PNG

06 Moteurs.PNG

Lien vers le commentaire
Partager sur d’autres sites

  • Solution

Bonjour Eve,

Moteurs d'origine du Sector X5 : HGLRC AEOLUS 2306.5 - 1900KV

Batterie Zeee 4S 1500mAh mais ça fait pareil avec des Tatu 6S 1300mAh.

J'ai remplacé la stack d'origine Stack ZeusF745 V2 BLheliS - HGLRC (HGLRC - Stack ZeusF745 V2 BLheliS (studiosport.fr)) par ça Zeus 722 F7 3-6S - HGLRC (Contrôleur de vol HGLRC Zeus 722 F7 (3-6S) (studiosport.fr)) et ça ESC Forward 60A 3-6S BLHeil32 4 en 1 - HGLRC (ESC Forward 60A 3-6S F0 BLHeil32 4 en 1 - HGLRC (studiosport.fr)

Je m'arrache les cheveux, je vais finir par penser que la FC que j'ai reçue était naze.

J'ai flashé la dernière version en vérifiant bien la référence de la carte.

J'ai fait le paramétrage minimum, à savoir RX et moteurs, et depuis, j'ai ce problème de moteurs qui ne reprennent plus leur vitesse d'armement et dès que je décolle, le quad monte de 50cm à une vitesse disproportionnée puis retombe avec un FLYAWAY dans l'OSD.

Je suis trop NUL...

J'avais défini le sens de rotation de mes moteurs pour que le sens des hélices repousse les branches au lieu de les ramenées vers le quad.

J'avais juste oublié de dire à Betaflight que j'avais inversé le sens des hélices...

Pour ce qui est de la vitesse de rotation qui restait élevée au retour des gaz, j'ai désactivé l'AIRMODE.

Reste à savoir pourquoi, mais je vole.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...