Aller au contenu
DroneBuilds

Moteurs chauds / RPM Filter


ManuBBXX

Messages recommandés

Salut à tous ! 
j'ai effectué mes 2 premiers vols sur mon Nazgul evoque ( et sans crasher haha ! ) Quel bonheur 
Je suis déja amoureux de votre monde, que dis-je, de NOTRE monde ! 🙂

En revanche, j'ai remarqué que mes moteurs sont vraiment chauds après une petite session de vol.
J'ai cherché un peu  et ai vu déja sur un tuto que activer le RPM filter pourrait bien aider ! 

Ce que je me suis empressé de faire sous Betaflight dernière version ( j'ai aussi vérifié mes ESC, j'ai bien le dernier fw blHeli ).

J'ai donc  activé le D-SHOT bi-directionnel.
La ou sont mes questions :
 

- Lorsque je teste les moteurs sous beta avec le DSHOT bidirectionnel, j'arrive quand même à un taux d'erreur de 1% lorsque je dépasse 70% du max des moteurs. En DSQHOT600 comme en DSHOT300. En revanche la charge CPU ne dépasse jamais vraiment 15% donc ca doit aller de ce coté la. Comment faire pour cela ?
- Alors le problème du taux d'erreur est peut être ici : j'ai lu que si je suis en DSHOT600, il faut être a 8 kHz en fréquence de rafraichissement de gyro et boucle PID. Me concernant, je ne peux pas dépasser 3.20 kHz sur le gyro et la liste déroulante est grisée de toutes les façons. Et 3 kHz et quelques max pour les boucles PID. Comment puis-je mettre 8K comme préconisé avec un DSHOT 600 ? 
Je fournis une capture pour illustrer
- Est ce que l'activation de ce RPM filter va aider pour la température de mes moteurs trop haute, d'après votre expérience ?

Edit : je viens de monter la fréquence de boucle PID a 3.2 kHz, mais c'est le max que je puisse mettre ! Ni 4K et encore moins les 8K que l'on voit parfois sur les tuto. Pourquoi suis-je si limité ? 
Ensuite, depuis que j'ai monté a 3.2 kHz, la charge CPU est passée de 14 à 27%. Jusqu'ici rien d'anormal je dirais.
Concernant le taux d'erreur moteur, c'est bizarre, car de 0 à 50% enviton, aucune erreur
Puis de 50 à 80%, des erreurs qui peuvent monter jusque 1%
Et la ou c'est drôle : de 80% à 100%, plus d'erreur ! 

Je suis preneur de vos lumières car la ca me dépasse..

J'ai fait mes tests en DSHOT300 donc, et ma FC est
BLITZ MINI F7 
Et ESC : BLITZ MINI 55A

 

Capture.png

Capture2.png

Modifié (le) par ManuBBXX
Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, ManuBBXX a dit :

Comment puis-je mettre 8K comme préconisé avec un DSHOT 600 ? 

Tu ne peux tout simplement pas, c'est une "limitation" du gyro BMI270 (on en parle demain sur la chaîne) 😉 

Il faut que tu mettes DShot300 mais surtout une boucle PID à 3.2 aussi.

Pour la chauffe moteur, faut regarder côté PID (D surtout) et filtres.

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, Motard Geek a dit :

Tu ne peux tout simplement pas, c'est une "limitation" du gyro BMI270 (on en parle demain sur la chaîne) 😉 

Il faut que tu mettes DShot300 mais surtout une boucle PID à 3.2 aussi.

Pour la chauffe moteur, faut regarder côté PID (D surtout) et filtres.

Réponse grandement utile, au top comme d'habitude, merci beaucoup ! 🙂
J'ai édité mon post, je venais justement de passer en 3.2 kHz haha 

Alors ca tombe bien que tu me parles de cela, je m'attaquais aux tutos des PID justement.

Concernant mes erreurs moteurs qu'a une plage donnée de niveau de throttle ( je viens d'éditer mon post pour expliquer ce que j'ai ), as-tu une idée à tout hasard ? 

Merci encore chef 🙂

EDIT : Je viens de trouver le pourquoi des erreurs moteur : j'avais activé dans le BLHeliSuite le variable PWM frequency by RPM, en suivant cet excellent tuto

https://oscarliang.com/best-blheli-32-settings/#pwm-frequency

Alors le truc a l'air top, mais si je sélectionne 96 kHz au lieu de By RPM pour le PWM frequency high, je n'ai certes plus le merveilleux variable PWM, mais je n'ai plus une seule once de % d'erreur moteur avec mon RPM filter, donc je préfère quand même ! 

Modifié (le) par ManuBBXX
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Alors, je reviens de mon vol d'essai après avoir mis le RPM filter en DSHOT300 ( mon gyro ne me permet pas d'aller en 600 ) 
Plus quelques réglages de maitre Jérôme que j'ai pu voir dans son magnifique guide de tuning Beta 4.3

Comment vous dire que ca change absolument TOUT ?
Moteurs carrément froids au lieu de bouillants ! ( après je débute donc j'envoie pas des coup de gaz de malade, mais pour ce même style de pilotage de débutant, avant c'était littéralement bouillant )

J'essaierai donc d'enlever un peu de filtrage puisque je pense clairement que la température des moteurs est parfaite pour le tenter, donc continuer à suivre le guide, mais je voulais d'abord m'assurer que la chaleur des moteurs n'était plus un problème st c'est bel et bien le cas ! 

Pour les ESC, je suis donc en variable PWM mais by throttle, non RPM car j'avais un peu d'erreur moteur sou Beta donc je ne préfère pas le tenter..
J'ai 24 kHz en low RPM et 96 kHz en high ( dernière valeur avant le BY-RPM qui me pose des problèmes )

Bref c'est sensass, merci encore pour tout ce que vous apportez à la communauté, c'est d'autant plus appréciable lorsque l'on arrive dans ce monde 🙂

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...