Aller au contenu
DroneBuilds
Nijinsky

Mon premier racer : un MRP 130

Messages recommandés

Bonjour à toutes et à tous,

Après un an de vol sur mon vortex 280, je me suis lancé dans la construction d'un petit racer. J'ai donc pris un MRP 130 d'Armattan et je me suis lancé dans la constructuction :
Chassis : MRP 130 Armattan 
Moteurs : EMAX RS1306 4000KV
ESC : esc quadrant 25A X-racer
Carte de vol : BETAFLIGHT F3
Recepteur radio : XSR FrSky
Caméra : Runcam mini swift, lentille 130°
Emetteur vidéo : émetteur Luminier TX5GPRO 200mW
Antenne : Antenne TBS 

Au fil de mon montage, j'aimerai vous partager des photos et tenir un petit journal jusqu'au premier décollage.

J'ai donc fait le montage du drone sans trop de soucis ( en vrai la caméra est pas simple à fixer j'ai du limer la tête des vis et retoucher le support de caméra pour qu'elle rentre bien) et j'ai commencé la programmation.
Tout content je regarde tout les tutos de We are FPV (merci beaucoup d'ailleurs) et je commence par binder ma radio au XSR. Je met la radio en EU LBT pour ce faire et je bind sans trop de soucis, puis je commence à paramétrer le récepteur avec ma radio commande pour visualiser les commandes sous betaflight (que je n'ai pas).

Je vais donc dans l'onglet Port, je teste les différents UART que je sélectionne avec le sérial RX. L'uart1 est selectionné par défault mais je n'ai pas les commandes, je met donc l'uart2 et là ! : mon moteur avant gauche Fume ! je débranche aussi tôt la lipo et je cherche l'erreur. Je n'ai pas vu de vis qui touchait les bobines, ni de mauvaises soudures ou encore de fil court-circuité. 

C'est la que j'ai besoin d'aide car

1) je ne sais pas si le problème vient du matériel (moteur ou ESC) ou d'une mauvaise manip.

2) Je ne sais pas dans quel ordre je dois procéder pour paramétrer mon drone.
 

Merci d'avance pour vos réponses :)

PS : je mettrai dès que possible les premières photos de mon drone.
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Donc voici les photos de mon montage.

J'ai choisi de mettre les ESC sur les bras de mon quad. Pour eviter de couper le fil à ras, j'ai fais une boucle sous l'ESC et j'ai mis une gaine thermo. J'ai remis une gaine thermo pour tenir l'esc avec le bras du quad.

Ensuite j'ai soudé le Récepteur, l'émetteur, la caméra et les esc sur la carte de vol et j'ai commencé  la configuration sur betaflight.

20170804_211945.jpg

20170803_101944.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Tes ESC sont ENORME :o ils vont exploser au moindre choc xD 

Pour la fumée de l'ESC : regarde ton cablage et teste au multimetre

Pour la configuration je procede comme ceci :

  • MAJ (si possible) puis Bind du RX
  • connection a BF avec sauvegarde (via le CLI avec la commande diff)
  • MAJ de BF
  • Je colle la config (sauvegardé du diff) dans le cli puis save et reboot
  • Je regarde la direction des moteurs et j'ajuste avec BlHeli si besoin (souvent je met a jour BLHeli)
  • Ensuite je selectionne le bon UART pour mon RX et je met la configuration en serial RX
  • Je fait mes endpoints et mes subtrim
  • Je config mes moteurs et les calibres si ils sont pas en DShot
  • Je met mes modes de vol et je regle le fail safe
  • Rates et Pids
  • je vais voler

En gros :D J'ai surement oublié des trucs 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est vrai qu'ils sont gros mes ESC ahah je les voyait plus petit.
J'ai racheté un moteur et un esc, apparemment le problème venait d'un défaut de l'esc... J'ai tout soudé et je suis retourné sur BF. Je voulais voir pourquoi rien n’apparaît dans l'onglet receiver. J'ai testé toutes les voies en RX ( UART 1,2 et 3) et à chaque fois je mettais SBUS dans l'onglet config. Pour le RX en voie 1, BF me remet les paramètres de défaut pour le RX (spectrum 1024) mais dans tout les cas les commandes de la radio n'apparaissent pas :( 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×