Aller au contenu
DroneBuilds
clems21

betaflight problème buzzer

Messages recommandés

bonjour,

Je n'arrive pas à faire fonctionner correctement mon buzzer.

Déja lorsque je mets le voltmètre sur les bornes correspondantes, je n'ai pas d'annonce de tension, lorsque je prends la masse ailleur (le - des leds) j'ai une annonce à 4.9 V.

Si je mets mon buzzer sur le + buzzer et le - led il sonne en continue.

J'ai attribué un inter seulement au buzzer, lorsque l'inter est en position buzzer la led bleue clignote sur la FC.

J'ai vérifié la tension de ma batterie (15.9v) ainsi que le calibrage sur BF, et la tension d'alarme sur BF (3.5v /élément )

J'ai fait des recherches sur le forum mais rien à faire ca buzz en continue.

Auriez vous une idée ?

 

merci

Modifié (le) par clems21

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Tu as quoi comme FC ?

Je viens d'avoir un problème similaire de buzzer qui sonnait en continu lorsque j'armais la FC et qui ne réagissais pas lorsque j'actionnais mon switch.

Si par hasard ta carte est une EMAX F4 ou CC3D F4 ou Flip32 F4 (flashée d'origine avec le firmware REVO 3.x), pour résoudre ce problème de buzzer il faut flasher la carte avec la target "AIRBOTF4".

Pour plus d'infos : 

https://www.rcgroups.com/forums/showthread.php?2732572-REVO-F4-STM32F405-Flight-Controller

Partager ce message


Lien à poster
Partager sur d’autres sites

salut,

 

effectivement, j'a une F4 flip 32,

par contre étant novice dans le drone, je ne connais pas la target "AIRBOTF4" .

c'est le firmware que je dois mettre à la place du REVO 3.1.7 ?

ça risque pas de ne plus marcher du tout après ?

j'ai tellement galérer pour le mettre en vol que ça m’embêterait de tout beuger pour un buzzer !

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, AIRBOTF4 c'est le firmware qu'il faut installer avec Betaflight sur ta carte à la place de REVO. Il y a pleins de tutos en vidéo sur Youtube qui t'expliquent comment flasher ta carte, c'est très simple mais si tu préfères ne pas toucher au firmware installé il y a une autre solution :

Tu peux utiliser un recepteur avec plusieurs voies qui fonctionnent en PPM (du style FrSky X4R ou X4RSB), tu le branches donc en PPM (voie 1 sur le récepteur ---> sur ta FC). Si je ne dis pas de conneries, en PPM tu as les channels 1 à 8 qui passent par cette voie 1 de ton récepteur. La voie 2 de ton récepteur ce sera donc la channel 9.

Sur cette voie 2, tu branches un buzzer (discovery buzzer de chez Hobby king : https://hobbyking.com/en_us/hobbykingr-discovery-buzzer.html?___store=en_us) et tu lui assignes un switch sur ta radio commande. Le buzzer sera donc piloté directement via ta radio commande, sans passer par ta carte de vol. J'ai fais ce montage sur 2 de mes quads et ca marche nickel. Le seul désavantage c'est que le buzzer du coup ne bip pas à l'armement et au désarmement de ta carte mais ça ne me dérange pas plus que ça.

Voici le type de récepteur que j'utilise : https://www.banggood.com/fr/FrSky-X4RSB-316-Channel-Telemetry-Receiver-p-955643.html?rmmds=myorder

Si je peux encore t'aider, n'hésites pas...

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste une petite précision, avec un buzzer à 2 fils (rouge/noir) classique, ça ne fonctionne pas, il faut absolument le fil pilote blanc comme sur le discovery de chez HK.

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour tes conseils,

lorsque tu mets un buzzer sur ton Rx, il ne sonnera pas lorsque ta batterie est basse ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Non puisqu'il a aucun moyen de connaître la tension. Il faudrai que tu programme sur ta radio, avec la télémétrie, y que ce canal (9) soit à 2000 quand la batterie est basse ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

ca tombe bien que tu me parles de ca !

j'ai un récepteur X4R SB, il est bindé à ma taranis.

quand je le connecte à BF, dans l'onglet recepteur, j'ai les 14 voies qui apparaissent mais quand je bouge les sticks ou inter rien ne se passe.

j'ai activé le serial rx de l'uart1 

j'ai reflashé ma carte avec le revo 3.1.7 puis airboltf4 mais ça ne change rien.

 

20170815_145651.jpg

20170815_145713.jpg

20170815_145734.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Ton montage et tes réglages sembles corrects.... y a un truc mais lequel ??? Honnêtement je ne vois pas pourquoi en SBUS tu n'as pas de réponse de ta radio, essayes éventuellement de bricoler l'activation/désactivation des UART dans l'onglet PORT.

Si quelqu'un a la réponse ça m'intéresse aussi !

J'ai le même montage que toi sauf que je suis en PPM sur la voie 1 du X4R SB et ça marche avec mes réglages ci-dessous (mais avant j'ai activé la fonction PPM sur le récepteur lui-même car d'origine il ne le fait pas (le lien : http://frskytaranis.forumactif.org/t2719-tuto-sortie-cppm-sur-les-recepteurs-x4r-x4r-sb).

 

599307789a849_02-Ports.thumb.JPG.f89d104d5bb02f9e94dcc9fd06f25968.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

As-tu résolu le problème de SBUS ?

Je viens de dénicher ces deux articles qui pourraient éventuellement expliquer pourquoi ça ne marche pas :

https://quadmeup.com/smartport-inverter-for-f4-flight-controllers/

et

https://oscarliang.com/uninverted-sbus-smart-port-frsky-receivers/

Partager ce message


Lien à poster
Partager sur d’autres sites

Mon problème n'est pas résolu.

Merci pour tes liens mais j'ai déjà du mal à suivre en français alors en anglais...

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaye avec l'uart 3, c'est normalement celui qui est fait pour le S-bus, si ça marche essayé avec l'uart 2

Envoyé de mon SM-G935F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai enfin réussi à faire voler mon quad, je l'utilise pour apprendre à piloter donc le buzzer n'est pas nécessaire.

Je vais me commander un deuxième que je vais équiper en fpv et la je vais essayer de faire ça avec buzzer, osd et récepteur X4R pour avoir la telemetry.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut clems 

 

Sinon tu fait sa a l'ancienne...lol

Tu mets un simple buzzer qui se branche sur la prise d'equilibrage de ta lipo ,et il sonnera au seuil voulu (tu peut le regler de 3v a 4v de memoire) sa coute pas bien chere et ces plutot pratique...lol

Sur se au plaisir et a bientôt

Tchuss

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×