Aller au contenu
DroneBuilds

betaflight Problème télémétrie


clems21
 Share

Messages recommandés

Bonsoir,

 

J'ai suivi le tuto pour configurer la télémétrie entre mon  X4RSB et ma Taranis.

Elle n'arrive pas à découvrir la dizaine de capteurs.

J'ai relié le Sport au Tx de l'uart3 de ma F4.

J'ai indiqué que la télémétrie était en Smartport dans l'onglet port.

Et activé télémétry output dans configuration.

Rien y fait je n'ai que les 4 capteurs de base quand je fais découvrir de nouveaux capteurs.

Est ce que je me suis loupé quelque part ?

 

20170915_231812.jpg

20170915_232738.jpg

20170915_232833.jpg

Lien vers le commentaire
Partager sur d’autres sites

  • 7 months later...

Salut à tous, je relance le post car j'ai exactement le même souci, les commandes fonctionnent mais quand je cherche les capteurs j'en découvre seulement 3 et pas d'autres, voici mon branchement avec une f4 hobbywing si vous avez des conseils je suis preneur ;)

 

x4rsbusf4.gif

Modifié (le) par McCyril
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Sortie télémétrie de Uart3 sur Smartport!

Edit: Mais comme il était tard et que je suis un boulet, on fera comme si on avait pas vu mon post hein! :$

Modifié (le) par Tonton
Lien vers le commentaire
Partager sur d’autres sites

il y a 47 minutes, Tonton a dit :

Sortie télémétrie de Uart3 sur Smartport! Et ça devrait le faire!

ok, je vais tester l'Uart3 , mais ce n'est pas censé fonctionner sur n'importe quel Uart, du moment qu'il est libre ?

Modifié (le) par McCyril
Lien vers le commentaire
Partager sur d’autres sites

il y a 40 minutes, clems21 a dit :

Si je comprends bien ton schema tu branches le smart port tx à l'Uart1 tx ?

J'ai bien l'impression aussi!

En fait je pense que c'est sur le X4R que ça va pas! Visiblement, tous les UART ne sont pas inversés sur la F4! Du coup, faut bidouiller sur le X4R!

x4r-sb-modification-768x529.jpg

La flèche verte vers le tx de ton choix!

Source: https://blck.mn/2016/06/smartport-the-frsky-xsr-and-betaflight/

Modifié (le) par Tonton
Lien vers le commentaire
Partager sur d’autres sites

il y a 14 minutes, goony a dit :

Sinon, il y a la solution du softserial qui ne nécessite pas de soudure délicate.
Tout est logiciel : https://oscarliang.com/betaflight-soft-serial/

merci, je vais me pencher sur la question (en essayant de ne pas basculer) :)

Lien vers le commentaire
Partager sur d’autres sites

je suis toujours empêtré avec le softserial  😓, dans le cli j'ai essayé la commande resource SERIAL_TX 11 A01 mais apparemment c'est déjà affecté a une autre fonction ( sonar trigger ? )

est il possible de supprimer cette fonction ?

 

lua.png

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / WE are FPV

×
×
  • Créer...