Jump to content
DroneBuilds
eponyme

quad qui bouge tout seul

Recommended Posts

Bonjour à tous,

J'ai un souci avec mon nouveau quad, un fanatic nano (dont je parlerai dans un autre post :) ). Il a tendance à partir tout seul en roll sur la droite et avoir aussi un peu le nez qui part vers le bas.

Lorsque je passe du mode horizon au mode accro et que je le redresse, la je n'ai plus le problème. Je n'ai pas encore essayé de recalibrer le drone pour m'assurer qu'il soit bien à plat, mais une autre chose me fait peur :

dans betaflight, dans l'onglet réception, je vois bien que dès que j'allume la radio, sur l'image en bas à droite, le quad par en roll, doucement mais surement. C'est pour cette raison que je me dis que ca ne vient peut etre pas du gyro, mais de la radio, sauf que je fait que ca ne me le fasse pas en mode accro me fait penser que c'est plutot le gyro .. .:(

 

Pouvez vous me donner des pistes ? Ou rechercher et quoi corriger ? J'ai entendu parler des "deadband" qui pourraient peut etre m'aider.

 

pour info je suis avec une FS-i6 et un récepteur ia-8, BF 3.2.1. FC HGLRC F4.

 

Merci pour l'aide que vous pourrez m'apporter.

 

epo

Share this post


Link to post
Share on other sites

je les ai effectivement corrigés. 

De base ils étaient un peu au dessus de 1500, mais jamais fixes. Maintenant ils oscillent entre 1499 et 1500. je ne sais pas pourquoi ca n'est pas fixe. Des parasites ?

Mais si c'était ca le problème, je l'aurais aussi en accro non ?

 

epo

Share this post


Link to post
Share on other sites

Si ça bouge c'est a cause des potentiomètres des sticks de ta radio c'est pas facile de lire la valeur

Tu l'aura aussi en accro mais si ça oscille pas beaucoup 1498-1502 c'est pas grave tu le sentira pas

Si toi ça oscille beaucoup faut que tu recalibre tout

Mais de toute façon faut que tu quitte les modes de vols stabilisés, vole en accro 

  • J'aime 1

Share this post


Link to post
Share on other sites

Oui je suis d'accord, mais comme le quad est tout neuf pour le moment je fais juste quelques tests :)

En y repensant j'ai un probleme équivalent sur un autre petit brushed, ca laisse donc penser que c'est effectivement un souci venant de la radio.

Je vais recalibrer et retester.

 

Merci pour ton aide.

 

epo

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Hello,

 

le truc c'est qu'en accro j'ai pas du tout le problème, donc j'ai tendance à plutot incriminer le gyro que la radio.

je recois bientot ma FC de spare, je pourrai faire un essai pour être sur.

 

epo

Share this post


Link to post
Share on other sites

oui effectivement c'est juste pour décoller. 

Apres je débute en accro donc j'aime bien avoir un switch qui me ramene en stable quand je sens que ca va pas le faire.

Mais pour le moment j'arrive à me débrouiller sans, donc ca va rester comme ca c'est pas tres grave.

 

epo

  • J'aime 1

Share this post


Link to post
Share on other sites

si je dit pas de con....e je croit que dans beta sur une page tu peu aussi mettre une valeur autour des neutres genre 2/3/4 sur les axe de la radio justement dans le cas d'un pti neutre pas toujours fixe a 1500  ... bon apres si t'a une difference de 10 points c'est pu la même ....

il me semble mais po sure ...

Share this post


Link to post
Share on other sites

non, l'accéléromètre probablement, mais ça peut venir de vibration, de l'état des hélices, etc... en stab c'est beaucoup plus sensible à la qualité du montage

Share this post


Link to post
Share on other sites

je pense que vous avez tout juste :) 

Je confondais l'action du gyro et de l'accelerometre. En faisant des recherche de mon probleme, axées sur l'accel, j'ai trouvé des topics décrivant le meme probleme que moi : un quad qui part d'un coté ou de l'autre, et cela de plus en plus fort jusqu'a carrément devenir impossible a remettre en position.

Partout ca parle de "trim d'acceleromter", avec cette procédure : quad désarmé, mettre le throttle à fond et ensuite donner des coup de stick la ou on veut trimer ..

Et d'un coup je me suis rappelé qu'au tout début ou j'ai eu mon quad, j'ai par inadvertance activé le trim : j'avais le pouce sur le throttle et ca a bippé. J'ai de suite tout coupé pensant que j'avais armé, alors que non, je venais d'entrer en mode trim :) Je ne me rappelle évidemment pas si j'ai aussi trimé d'un coté du coup ..

Il fait trop sombre pour que je refasse des tests, que je ferai demain, mais si je fais "reset settings" dans l'onglet setup, est ce que ca remet aussi à zero les trim de l'accelerometre ? 

 

epo

Share this post


Link to post
Share on other sites

Hello,

J'ai laissé tomber. Au final je ne vole qu'en accro et ça me fait progresser. 

Je me posais une question ce soir :

Je suis en ppm ( je n'ai pas réussi a faire marcher le ibus) du coup j'ai soudé que 3 fils du receiver et j'ai laissé celui du sbus libre ( mais isolé). Est ce que j'aurai du le souder aussi même s'il ne sert pas ? Je me dis que peut être ce fil non soudé peut perturber le récepteur. ..

 

Epo

Share this post


Link to post
Share on other sites

Yes !!!! Fixed !!!

J'avais laissé tomber ce problème puisque je ne volais qu'en accro, et ça m'allait très bien. 

J'ai ensuite pris la décision de passer mon petit brushed 90 de BF 3.1.7 a BF 3.2.4, et la ... le même problème est apparu à nouveau. Un drift qui s'accentue de plus en plus au fil des secondes ... Je me suis dis que c'était un indice et j'ai fait des recherches dans ce sens. Je suis tombé sur ce fil ou des personnes décrivent le même problème :

https://github.com/betaflight/betaflight/issues/4573

Mon niveau d'anglais et de débutant dans le hobby ne me permettent pas de comprendre les raisons qui sont expliquées, mais un patch a été commit et sera dispo dans la 3.3. 

J'ai laissé mon 2" en 3.2.2 et j'ai décidé de mettre une beta de la 3.3 sur mon brushed histoire de tester ... je l'ai prise ici : https://betaflight.qmd.cl/

 

Après avoir refait ma config, reparamétré mes endpoints et requalibré l'accel ... C'est de nouveau bien stable :D

BIen content de pouvoir voler avec la dernière version de BF sur mon brushed et d'avoir éclairci ce mystère :)

 

En espérant que ca puisse servir pour d'autres !

 

epo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...