Aller au contenu
DroneBuilds

Commander Runcam Split via radio


Arnotobus

Messages recommandés

Salut,

Je touche au but pour mon premier build mais il me manque encore une petite chose. J'ai suivi la doc de la Runcam Split pour contrôler l'enregistrement depuis la radio mais sans succès.

J'ai configuré le channel dans Betaflight comme pour les autres modes mais il ne se passe rien quand je bouge les switchs. J'ai testé avec le contrôle du wifi: idem.

Le switch fonctionne avec d'autres commandes. J'ai essayé aussi avec un autre UART.

Est-ce qu'il y a autre chose à faire, brancher ou configurer ?

 

Matos:

- Kakute F4 AIO + Split en SBUS

- Flysky i6 flashée en 10 voies

Lien vers le commentaire
Partager sur d’autres sites

Je n'y suis pas arrivé non plus, avec une carte contoleur YupiF4.

J'ai posé la question à Monsieur Yupi, il m'a dit qu'ils n'ont pas testé cette cam, mais que cela devrait fonctionner.
Voilà de la réponse constructive, je trouve !
(un peu comme la mienne, en fait xD )

Lien vers le commentaire
Partager sur d’autres sites

Sinon, tu fais comme moi : tu ne touches à rien et du coup tu enregistres systématiquement tous tes vols, et tu fais du vide à postériori sur ta carte SD.
Avec une 32Go, tu as de quoi enregistrer une petite quinzaine de vols

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Et après on va me dire que tout est beau et simple sous BF avec toutes les cartes qui sont pareil :D

Désolé pour ce commentaire non constructif je n'ai jamais essayé avec BF...

  • Triste... 1
Lien vers le commentaire
Partager sur d’autres sites

ahhh oui c'est mieux ;) et ta split elle est branchée a un UART ? parceque apres tu met le bon périphérique sur le bon port et tu as des modes de dispo normalement

Lien vers le commentaire
Partager sur d’autres sites

Dans mon cas, la Runcam Split est branchée sur un UART de ma carte Yupi
Le port Rx de l'UART vers le port Tx de la Split
Le port Tx de l'UART vers le port Rx de la Split
La masse reliée entre les 2

J'active l'UART dans Betaflight
Cela ajoute de nouveaux modes dans Betaflight
J'affecte un inter de la radio au mode permettant "normalement" d'activer / désactiver l'enregistrement vidéo.... et rien ne se passe.

Bof, pas grave, j'ai laissé tombé, et du coup çà enregistre systématiquement. Ce n'est pas plus mal, çà évite de louper un truc rigolo qui se serait passé pendant le vol.

Exemple vécu : je passe au milieu d'une touffe de roseaux, et je ressors de là avec plein de "plumeaux" collés sur la lentille de la cam.

Lien vers le commentaire
Partager sur d’autres sites

peu etre que je me trompe mais faut peu etre passer par l'osd nan ?  j'ai vue qu'on pouvais commander "l'osd" des runcam  comme ça

d'ailleurs si il y en a qui on déjà fait ça  m'intéresserais bien. même si j'ai jamais toucher aux réglages de la swift2 depuis que je l'ai

Modifié (le) par mc barret
Lien vers le commentaire
Partager sur d’autres sites

  • 3 months later...

Petite contribution qui ne va pas vraiment faire avancer le problème:

Runcam split v1 en version 2.0 janvier 2018 branchée sur l'uart 1 de ma matek F405 sous BF 3.2.5

Bah ça marche pas non plus. J'ai bien mis le tx sur le rx de chaque carte et vis versa, contrôle de continuité des soudures, runcam configuré sur flight controle dans sont osd.

J'ai pas envie de me prendre la tête pour une fonction très dispensable mais je serai curieux de savoir si ça marche chez quelqu'un qui a le même setup.

Lien vers le commentaire
Partager sur d’autres sites

Ça marche très bien sur les SPF3 avec FlySky i6 et des F4 avec Frsky. Testé et approuvé avec des splits v1. Faut juste respecter les branchements comme indiqué dans le manouel , affecter le Switch sur la Rc et le mode sur BF. Et c’est un bon petit plus je trouve de pouvoir piloter l’enregistrement depuis la RC.
#jaimetripoterlesswitchs

Lien vers le commentaire
Partager sur d’autres sites

Finalement j'ai quand même insisté un peu. J'ai voulu tenter le uart4 a la place du 1 mais sans succès. J'ai refait mes soudures: pareil. En dernier recourt j'ai inversé le TX et le RX... Ça fonctionne O.o.

Je reprend la notice en me demandant si je suis autant a la ramasse que ça mais non j'avais bien suivi le schéma au départ:

 

rc1.jpg.8374684f3305243a01285fd6f70162b7.jpg

 

Sauf que ce schéma de la notice actuellement dispo sur le site de runcam est faux!

Deux écran plus haut sur le même pdf il y a celui là:

rc2.jpg.5f0982efe86e870475c55ed93d4c02c0.jpg

Voila problème réglé pour moi. En espérant que ça puisse aider ceux qui se seront aussi fait avoir par ce schéma de branchement foireux.

Modifié (le) par Notec
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Ah ouais, lors du schéma du montage, ils ont inversé le RX et TX...

Y'avait pas des FC qui avaient le même problème ? Fallait brancher le RX sur le TX de la FC ? C'est peut-être le même gars qui confond. :D

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / WE are FPV

×
×
  • Créer...