Jump to content
DroneBuilds
OniFPV

DEMANDE D'aide install R XSR sur OmnibusF4SD

Recommended Posts

Hello, voila j'ai des doutes sur un montage, et des questionnements, alors je sollicite votre aide.
Je viens de recevoir mon R XSR pour remplacer le receiver tout pourri du Darkmax.
Sur une F3V3, pas trop de soucis particulier, smartport fonctionnel, sbus, tout qui va bien.

Mais là, je suis sur une OmnibusF4SD.

Sur le R XSR, j'ai 5 fils GND, 5v, S.port SBUS out/PPM , et SBUS IN  
Sur le quad, j'ai déjà un receiver Frsky, 3 fils, noir, rouge, jaune, sur une connectique 3 pins, la couleur jaune correspondant au S.port, je suis perplexe.
A coté j'ai un port libre nommé DSMX IBUS avec le 3.3v, le GND et RC IN.

1) Pour connecter le R XSR, me suffit il de connecter le GND, 5V, ET SBUS out/PPM sur la connectique 3 pins?
1Bis) Sur une OmnibusF4, n'ayant pas d'inverseur, j'ai un tout petit endroit sur le R XSR à souder dessus au lieu de la fiche, mais est il possible de passer par betaflight au lieu de faire ça?

2) Smartport impossible à installer? D'habitude je déporte sur un autre UART, mais là, possible de passer par le IBUS?

Je suis un peu perdu, besoin de lumière avant de me lancer..

Si vous avez un élément de réponse, je suis preneur.

Share this post


Link to post
Share on other sites

Personne n'a d'idée? J'avance un peu dans mes recherches, et une question reste sans réponse pour moi.
Sur Une Artower OmnibusF4, où connecter le smart port... ?
Sur l'image, led strip est prise par les leds, Vid est prise par la cam, Vbat + est prise par le VTX, Sbus/ppm est prise par le receiver.

Il reste de dispo DSM mais j'ai pu voir aussi TX 3 et RX 3 en possibilité de soudure directe.
Pensez vous que je puisse souder le smartport sur le RX3?
 

ARTOWER F4.jpg

Share this post


Link to post
Share on other sites

Alim, masse et SBUS suffisent. Pour la télémétrie j'ai lâché l'affaire avec ma Pro Corner.... Je crois que @Draacula a réussi avec un diode. Tu peux regarder sur le topic unique de la Pro Corner.

  • Merci ! 1

Share this post


Link to post
Share on other sites

Merci pour ta réponse. Désolé si le sujet est redondant! j'ai pourtant cherché mais peut être pas avec les bons mots clés
Penses tu qu'un simple raccordement suffise pour le R XSR? pas besoin de régler le souci d'inversion de signal?

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Merci pour le lien, et moi ce qui me chagrine, c'est que la Omnibus, c'est qu'il y a peu de slot à souder, beaucoup de prises. Alors j'essaie de chercher les correspondances.
Mais bon si tu me dis que 3 fils suffisent, je vais tenter quelques soudures ce soir.

Share this post


Link to post
Share on other sites

Ouaip ce principe de base, ça je l'ai. Sur une F3 je déporte le smartport sur un UART, mais là j'ai pas d'UART défini comme tel sur la F4.
Sur la F4, j'ai d'une part, pas de fiche supplémentaire (les connectiques ne ressemblent pas à celles de Diatone) je ne connais même pas le nom pour en trouver sur les shops, tu saurais me dire? 
Et d'autre part, pas déterminé l'endroit où placer ce fil pour le smartport. Mais si je peux oublier, alors je vais le faire.
Le reste j'ai deux choix possible, voir 3, je soude tout comme avec le précédent receiver, et ça marche, soit je soude le fil SBUS en re inverted, sur le tout petit rond prévu à cet effet sur le R XSR, soit j'essaie de bidouiller une commande dans le CLI de BF pour mettre la fonction en off. Affaire à suivre. lool. Je rame je rame! xD

Edited by OniFPV

Share this post


Link to post
Share on other sites
il y a 17 minutes, Motard Geek a dit :

Je soude tout sur la FC moi. T'as une photo de ta carte ? T'as pas un schéma de câblage ?

Le schéma est dans mon deuxième post. ce sont des fiches, des prises, mais je ne connais pas le nom de ces connectiques, et à priori, les nombres de broches diffèrent de ma spracingF3 Diatone... :/
Et sur le schéma de mon deuxième post, j'ai pu découvrir deux rond nommé TX3 et RX3.
20170912183323_27378.jpg

Share this post


Link to post
Share on other sites

Petite évolution, donc après soudure sbus /neutre /phase.
Tout à l'air de fonctionner, excepté le VFAS sur la Taranis...

Après découverte de capteurs, rien, juste trois choses, dont la télémétrie. Télémétrie que je place toujours sur Aux12.
Et pourtant j'ai bien la détection sur Bétaflight du voltage de ma batterie...
Qu'est ce qui cloche et pourquoi? Que je puisse comprendre?
 

VFAS betaflight.jpg

Share this post


Link to post
Share on other sites

Ce qui est étrange, mon masque le capte et me l'affiche, et bétaflight aussi... Je n'arrive pas à savoir comment. Et par contre j'en déduis que c'est uniquement le RXSR qui ne le transmet pas.

Share this post


Link to post
Share on other sites

Okay, donc pourquoi je l'ai sur les autres outils? l'info arrive dans mon OSD, via quoi en fait? le SBUS?
 

Edited by OniFPV

Share this post


Link to post
Share on other sites

Okay, donc la FC ou PDB sont capable de lire le voltage directement via la prise XT alors.. Merci pour tes lumières.
Et merci d'avoir suivi mon sujet, je me suis senti moins seul lol

Edited by OniFPV

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...