Aller au contenu
DroneBuilds
FroggyFPV

betaflight Tuto bonne valeur RSSI dans l'OSD avec Taranis et BF

Messages recommandés

Bonjour,

Comme j’ai un peu galéré à trouver et pour ceux que l’anglais rebute, je vous livre ce petit tuto pour avoir la bonne valeur de rssi sur l’OSD. (note aux admins : désolé si ça fait redondance avec un autre post mais j’ai pas trouvé sur le forum avec les mots clé « OSD RSSI TARANIS »)

Pour le petit historique, ma valeur de rssi plafonnait à 8-9% dans l’OSD alors que j’avais plus de 90db sur la Taranis. En bon newbie, j’avais activé RSSI (signal strength) dans onglet config de BF, hors j’ai lu ensuite que le signal RSSI n’était pas analogique !!

Bref ! 

Pour ce qui est de ma config, j’ai une X9D+ avec un R-XSR

Pré-requis :
- avoir une Taranis et un récepteur avec télémétrie (S.Port)
- Être connecté en SBUS ou PPM à la FC (je ne sais pas si ça marche de la même façon en PWM)
- Avoir fait une recherche des capteurs de télémétrie

Sur la Taranis, on commence par créer une nouvelle entrée avec comme source le RSSI et régler l’échelle à 100 :

5a353130becb4_EntreeRssi.thumb.png.66904c85bec001b0ff9b6627b3f1a8f5.png

Dans a page mixage, on attribue l’entrée précédemment créée sur une des voies non utilisée avec 200 au ratio et -100 au décalage car le RSSI ne varie que de 0 à 100 et d’une voie varie de -100 à 100 (en laissant les valeurs par défaut 100 au ratio et 0 au décalage, on aurait bien 100% de signal lorsque l’on a 100db mais lorsque que le signal est à 0db on aurait encore 50% au RSSI sur l’OSD) :

5a35317a9df56_MixageRssi.thumb.png.75f0826070b53b1a2f2f0120d56c51a1.png

Puis sous BF, on désactive « RSSI (signal strength) » si jamais il a été activé :

5a35319c79ec6_BFconfig.thumb.png.7c41db567cdcc5b938e61bf5a78d1d98.png

Puis dans l’onglet Receiver, on assigne la voie correspondante au RSSI (aux 4 si c’est la voie 8 et ainsi de suite en fonction de la voie sur laquelle a été configuré le RSSI sur la Taranis) :

5a3531c15dddb_BFreceiver.thumb.png.562adc45abe58a75e3629f97eac467dd.png

Si après cette manip ça ne fonctionne pas, il se peut que le nombre de voies déclarées ne soit pas suffisant. Pour le savoir, rdv dans CLI en tapant la commande « set aux » :

5a3531eb67efc_BFCLI.thumb.png.a81b4a69a0284cc0d9a34adc2b2f015f.png

Si jamais max_aux_channels est inférieur au numéro de l’aux choisi pour le RSSI, il suffit de taper la commande « set max_aux_channels = xx » (xx étant le nombre de voies auxiliaires qui vous souhaitez tout en restant dans la plage donnée par allowed range). Puis taper « save ».

Reste plus qu'a activer l'affichage du RSSI dans l'onglet OSD et le tour est joué.

Bye.

  • J'aime 3
  • Merci ! 2

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai oublié de préciser mes sources car je n'ai pas trouvé ça tout seul :

J’ai fouiné un peu et j’ai trouvé cette vidéo (en anglais) :

https://www.youtube.com/watch?v=LPxjT3Aosak

Ainsi que le très bon tuto d’Oscarliang :

https://oscarliang.com/rssi-ppm-channel-taranis/

Modifié (le) par FroggyFPV

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,
Sur quel UART faut-il activer le Smart Port ?
Merci de me renseigner

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

tout dépend sur quel UART tu as soudé le fil de télémétrie de ton RX. Pour a part j'ai une FC Matek F405 qui n'a pas d'UART inversé nécessaire au Smartport et comme je voulais pas m'embêter souder un fil sur le PAD non inversé du mon RX (démontage plus facile en débranchant uniquement la prise) je suis passé par un hack en Softserial. Du coup mon S.port est sur le PAD de signal du moteur 5 et j'ai réaloué la ressource à du serial TX. Et de ce fait mon Smartport est activé sur le port Softserial :

 

En espérant que ça va t'aider.

Screenshot at janv. 11 11-14-24.png

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour
Comme je débute en racer je l’ai acheter monté c’est un X220s :
Carte Omnibus F4 v3, récepteur Frsky R-XSR .
Sur bétaflight j’ai un port UART1 et UART3 de libre ou je devrais indiquer SmartPort ? Sur ma télécommande  Taranis X9D je peu voir sur la page télémétrie le capteur RSSI qui indique 93% et BtRx 4.8v mais si je vais dans l’onglet «Découvrir capteur»  je n’ai rien d’autres ? J’ai essayé sur les deux port mais je n’ai pas plus d’infos .
Je devrais il me semble pouvoir avoir d’autre infos ?

Partager ce message


Lien à poster
Partager sur d’autres sites

La tara voit le RSSI en retour direct depuis le RX, elle n'a pas besoin du smartport car c'est une info qui vient du RX et non de la FC, pour avoir le RSSI dans ton OSD il faut qu'il soit transmis à la FC via le Smart port. Est ce que tu as des infos dans ton affichage de l'OSD ? (Vbat, altitude,...). Normalement, ces infos devraient pouvoir apparaitre dans l'OSD puisque quelles viennent de la FC qui traite l'OSD

Il va falloir me donner un peu plus d'info sur le branchement de ton RX sur la FC, normalement tu dois avoir 4 fils qui vont du RX vers la FC (Gnd, +5V, S.port, SBUS out). Le fil du S.Port est jaune, il faut savoir sur quel PAD il est soudé à la FC. Est ce que tu as des photos du montage car je ne connais pas la carte et je sais que Eachine à tendance à customiser les FC pour leurs modèles.

Logiquement lorsque le smartport fonctionne, tu obtiens tout un tas de nouveaux capteurs sur la Taranis comme le Vbat, les accéléromètres, les gyros, le baromètre si il y en a un.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca fonctionne mais j’ai une valeur differente entre mon OSD et celle donnee par la taranis ?

Bizarre, non ? O.o

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Yann,

Il y a 8 heures, Yann a dit :

Ca fonctionne mais j’ai une valeur differente entre mon OSD et celle donnee par la taranis ?

Bizarre, non ? O.o

est-ce que tu as une grosse différence ? est-ce que cette différence est la même quand ton RSSI est haut et bas ou est-ce que la différence est plus grande sur les bas RSSI que pour les hauts RSSI ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

la valeur RSSI est bien configurée en input et output sur la TARANIS, ca bouge bien avec la distance, en revanche, la valeur reste fixe dans l'OSD.

En fait je n'arrive pas a faire sur Betaflight. Mon AUX12 configure comme RSSI sur la Taranis reste a une valeur fixe de 50% (valeur que je retrouve dans le premier onglet setup comme dans l'OSD).

J'ai bien verifie dans le CLI le set aux, c'est OK (valeur 14). J'ai essaye en reaffectant le RSSI a un autre channel sur la Taranis, meme chose ; OK sur la Taranis, rien ne bouge dans l'OSD...

Si quelqu'un a une idee je suis preneur...

Merci.

Yann

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Yann,

j'ai fait des tests en mettant le RSSI sur aux 12 et je n'ai eu aucun problème, je vois bien la valeur bouger dans l'onglet setup et elle est identique à la Taranis. Quest-ce que tu as comme récepteur ? est-ce que tu as bien configurer le smart port dans BF ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

FrSky XSR. Le probleme c’est que j’ai le meme probleme de RSSI sur mes deux quads :

- Chamaleon : FC = DYS AIO v2 Pro , receiver = FrSky XSR, SPort « hacké » connecté au RX3 (qui est en fait le TX3)

- Astro X : FC = Matek F4AIO , receiver = FrSky XSR, connectique normale, inversion faite via le CLI (conforme site Matek).

j’en deduis que j’ai loupe quelquechose pour les deux builds...

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 14/01/2018 at 20:27, Yann a dit :

- Astro X : FC = Matek F4AIO , receiver = FrSky XSR, connectique normale, inversion faite via le CLI (conforme site Matek).

j’en deduis que j’ai loupe quelquechose pour les deux builds...

En effet, il doit y avoir quelque chose de loupé, surtout avec la matek car j'ai quasi la même config et n'ai aucun pb. Peut-être revoir tes soudures et vérifier les paramètres du softserial pour le smartport. est-ce que dans l'onglet receiver, tu as un Aux qui a une valeur qui bouge quand tu fais varier la distance TX-RX ? normalement l'aux sur lequel est configuré le RSSI varie sur la plage 1000 - 2000, si ton aux ne bouge pas, c'est qu'il y a un souci au niveau du paramétrage de la taranis ou du smartport.

Est-ce que quand tu vas dans la page télémétrie sur la taranis, et que tu fais la recherche de capteur, tu obtiens les accéléromètres et autres capteurs dispo de ta FC ? si ce n'est pas le cas, c'est que ton smartport est mal paramétré ou qu'il y a un pb physique de liaison entre le RX et la FC.

Désolé de ne pouvoir t'aider plus, je suis plutôt novice dans le hobby et c'est mon premier build. Je ferais quelques recherches, mais je n'ai pas réussi à reproduire le défaut, le seule fois ou mon RSSI ne bougeait pas dans l'OSD c'est que je m'étais trompé dans le numéro de l'Aux.

Si jamais tu trouve la solution, je suis curieux de la connaître.

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors moi perso j’ai fait comme dans là vidéos , sa a fonctionné direct sur ma f405.

 

A partir de 20 min sur les vidéos .

 

 

 

Hésitez surtout pas à regarder cette chaîne, y’a un max d’infos sur tout ce qui est taranis , télémétrie, maj ...

 

Je viens de recevoir ma première taranis et j’ai déjà tout réussi à faire grâce à ces tutos.

 

6fa0344b5a294435b2ecb4040614bae4.jpg&key=0039319335c93748a54baf90d7680a261ca01dc8d43e2d7f268d802b8ce04aba

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 16/01/2018 at 11:03, AyZeun57 a dit :

Hésitez surtout pas à regarder cette chaîne, y’a un max d’infos sur tout ce qui est taranis , télémétrie, maj ...

Bonsoir AyZeun, est-ce que tu pourrais envoyer le lien de la vidéo car rien n'apparait dans ton post.

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/01/2018 at 17:45, FroggyFPV a dit :

En effet, il doit y avoir quelque chose de loupé, surtout avec la matek car j'ai quasi la même config et n'ai aucun pb. Peut-être revoir tes soudures et vérifier les paramètres du softserial pour le smartport. est-ce que dans l'onglet receiver, tu as un Aux qui a une valeur qui bouge quand tu fais varier la distance TX-RX ? normalement l'aux sur lequel est configuré le RSSI varie sur la plage 1000 - 2000, si ton aux ne bouge pas, c'est qu'il y a un souci au niveau du paramétrage de la taranis ou du smartport.

Est-ce que quand tu vas dans la page télémétrie sur la taranis, et que tu fais la recherche de capteur, tu obtiens les accéléromètres et autres capteurs dispo de ta FC ? si ce n'est pas le cas, c'est que ton smartport est mal paramétré ou qu'il y a un pb physique de liaison entre le RX et la FC.

Désolé de ne pouvoir t'aider plus, je suis plutôt novice dans le hobby et c'est mon premier build. Je ferais quelques recherches, mais je n'ai pas réussi à reproduire le défaut, le seule fois ou mon RSSI ne bougeait pas dans l'OSD c'est que je m'étais trompé dans le numéro de l'Aux.

Si jamais tu trouve la solution, je suis curieux de la connaître.

Salut,

je n’ai aucun aux qui bouge dans mon onglet receiver, c’esy bien tout le probleme.

et pourtant sur l’onglet telemetrie de la Taranis tout fonctionne parfaitement.

je vais continuer de chercher ;-)

Yann

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je suis un noob dans le fpv mais surtout en électronique...
J'ai actuellement sur mon drone une FC F3 Diatone et un VTX SP3 Diatone avec OSD et un recepteur X6B , que je le commande avec ma Turnigy Evolution.
J'aimerais voler de plus en plus loin mais je n'ai pas de retour RSSI et encore moins de RSSI dans l'OSD.

Je voudrais éventuellement passé sur une Taranis QX7 voir une X-Lite si possible (pour moi l'ergonomie de la Turnigy est le summum) avec un recepteur R-XSR.
Du coup, je voudrais profiter du RSSI sur OSD. Cependant, étant un noob je ne suis pas tout à fait sur de la démarche à suivre.


Tu as marqué qu'il fallait un s.port pour avoir la télémétrie ? Il faut le brancher où ce s.port ? Sur un pad TX ? 
Voici le branchement que je propose, c'est correct ? cf Image1 en pièce jointe.
 

Si c'est bien ça, dans betaflight je mets le serial RX correspondant au bon UART, et de même pour le s.port je mets smartport correspondant au bon UART.
Ensuite, je suis la procédure que tu as indiqué avec la radio et les voies AUX...
Si c'est toujours bien ça... Pour activer le RSSI sur mon OSD, il suffit de l'afficher en accédant à mon OSD ?(soit via MWOSD soit via la radio : Throttle mid, yaw left, pitch up)

Mais il ne faut rien activer d'autre dans betaflight ? Comme l'option TELEMETRY ?

Merci d'avance

Image1.jpg

Modifié (le) par Kisscool78

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Kisscool,

je ne connais pas ton électronique mais d'après ton schéma, tu as aussi un OSD sur ta FC (Video in et out sur le connecteur 10 pins en haut à droite). Je ne saurais trop te conseiller de passer par celui ci si tu veux ton RSSI avec le tutoriel ci-dessus, l'info du RSSI est renvoyé du Rx à la FC et donc elle ne transit pas par ton Vtx donc même si tu as un OSD sur celui-ci, il n'aura pas l'info. Tu peux continuer à alimenter ta caméra par le Vtx et ne faire passer que le signal vidéo par la FC (le Video vient de la caméra et le Video Out va vers le Vtx).

Pour la suite, il faudra que tu connectes le S.Port du Rx sur un pad TX d'un UART libre de la FC. Je vois sur ton schéma qu'il y a au moins 3 UARTs (RX/TX1 ; RX/TX2 et le SBUS qui est un UART inversé). A vérifier dans Betaflight sur quel UART est activé le Serial RX et tu prends un autre pour le smart port. L'option télémétrie doit être activé dans l'onglet Configuration. Normalement ça devrait fonctionner car le F3 accepte les protocoles non inversé de base.

Enfin tu suis le tutoriel et pour activer ton RSSI dans l'OSD, tu vas dans l'onglet OSD sous BF et tu actives le RSSI.

En espérant que ça t'aide.

PS : pense à passer par la rubrique présentation histoire de te faire connaitre des membres

Modifié (le) par FroggyFPV

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Froggy,

Ok ça va être plus compliqué que prévu ...

Oui j'ai un OSD sur la FC, mais je ne veux surtout pas l'utiliser ! J'ai de gros parasites/flash quand je passe par l'OSD de la FC, peu importe la manière d'alimenter la caméra. Du coup j'ai changer le VTX pour une version avec OSD. Actuellement, je passe par le VTX de la SP3 et c'est parfait, aucun parasites, aucune lignes noires ou blanches, aucun clignotement de l'OSD, bref c'est propre.
L'UART 3 (il me semble) c'est là où je connecte actuellement mon récepteur X6B. L'UART 2 c'est là où est connecté mon OSD. L'UART 1 est donc inutilisé.

Donc, comment faire pour obtenir le RSSI sur l'OSD du VTX ?😭

 

Edit:
Je viens de me rendre compte que sur le VTX du SP3 il y un pin/pad RSSI peut-être un début de piste ?
073831emetteur-diatone-vtx-sp3-osd-2.jpg

Modifié (le) par Kisscool78

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ton tuto

Modifié (le) par bleep
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×