Aller au contenu
DroneBuilds
golem13

betaflight Configuration / Msp : Perte Du Port Usb

Messages recommandés

Salut a tous.

 

 Bon ben voila, j'en ai encore fait une bonne !

 

Je viens d'installer un micro RX sur mon Diatone GT90-R.

je l'ai installé sur un autre UART que celui d'origine.

Au moment de valider la nouvelle config du RX sur Betaflight, à la page des ports, au lieu de déplacer mon RX au nouvel emplacement, par connerie mégarde j'ai déplacé la configuration/MSP:

De la ligne USB VCP, je l'ai déplacé en UART6, et j'ai sauvegardé !

Bien évidement en connectant a nouveau le quad par l'usb, et ben il me dit : échec connexion...  normal :(

 

Comment annuler cette bourde ?  ... et repasser sur le port usb

-BarPat-

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello, info prise ici

Citation

That should reset itself on the next reboot, unless you had another port selected for MSP. But anyhow, booting into DFU (boot pin / pad), and reflashing with 'Full chip erase' will fix.

J'espère que tu as un diff ou un dump quelque part... :)  (et que ça marchera)

Modifié (le) par toper

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai re-flasher la  FC , elle s'allume lors de la connexion, mais Betaflight me met toujours échec connexion.

Peut -etre un problème de port usb.

je vais voir de ce coté là.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu es sur du port com ? Il aurait pas changé ?

 

Envoyé de mon SM-J320FN en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 27 minutes, toper a dit :

Tu es sur du port com ? Il aurait pas changé ?

 

Envoyé de mon SM-J320FN en utilisant Tapatalk

Comment le savoir ?

Il m'affiche :Port : /dev/rfcomm0

Partager ce message


Lien à poster
Partager sur d’autres sites

En allant dans ton gestionnaire de périphériques Windows.

Envoyé de mon SM-J320FN en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah, ce port là. ^_^

J'ai eu l'info dans la soirée.

j’avais déjà tout remballé à c't'heure. Bazar étalé dans la cuisine ... et là, c'est pas moi le boss !:D

je regarde demain après le taf

      ...

(- c'est possible, la FC est connecté par un hub au pc ...)

Modifié (le) par golem13

Partager ce message


Lien à poster
Partager sur d’autres sites
Ah, ce port là.
J'ai eu l'info dans la soirée.
j’avais déjà tout remballé à c't'heure. Bazar étalé dans la cuisine ... et là, c'est pas moi le boss !
je regarde demain après le taf
      ...
(- c'est possible, la FC est connecté par un hub au pc ...)
Oula pas de hub...

Envoyé de mon SM-J320FN en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Réutilisé Zadig changer le driver en winusb si ça ne marche pas tu télécharge impulse RC tu le lance et seulement après tu branche ta FC en mode bootloarder ça devrait marcher après 

Partager ce message


Lien à poster
Partager sur d’autres sites

Re.

 

Commente faites vous pour repérer vos port usb ?

J'ai essayé de les débrancher, ça fonctionne pour le clavier, souris et stockage externe, mais celui ou la FC est supposé être branché est introuvable (aucun ne disparait quand je débranche le câble, et il n'apparait pas quand je le connecte sur un port qui est vérifié)

180205063931500653.png

Le nom exact de la FC n'apparait pas dans betaflight. c'est une Fury F4M. j'imagine que l'équivalent dans le configurateur est la : Fury F4.OSD

je me suis déjà servi de bétaflight, mais pour des réglages de base ( calibration, attribution des inters, etc...)

Quand a Zadig   ... je l'ai DL, mais  ...:S Je panne pas tout ( voir même nibe !)

Mon nivo en 1formatik est ékivallant... aiqivalen... èquivalent  égale à çui de mon hortaugrafe ! :(

 

        -1er de la classe-

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis pas sur qu'il faut que tu prenne la Fury osd sur betaflight ! Et doit être reconnue en serial périphériques USB prend voir une photo de ta liste plus ba ou dans les ports COM en bas ! 

Partager ce message


Lien à poster
Partager sur d’autres sites

Avec Zadig tu devrais voir un stm32 faut aller dans option et cocher alldevice tu devrais le voir et là tu remplace le driver avec winusb 

Partager ce message


Lien à poster
Partager sur d’autres sites

sur zadig, dans le déroulé, j'ai:

-External HDD

-USB Keyborard (interface 0)

-USB Keyborard  (interface 1)

-G500 laser gaming mouse(interface 0)

-G500 laser gaming mouse(interface 1)

-Element 1042

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ba la il y as rien déjà ! 

Tu sais lancer ta FC en mode bootloarder ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, le job a été fait ( merci doulbix)

j'ai d'abord passer la FC par ImpulseRC, et ensuite flasher avec un autre firmware que celui que j'utilisais.

... j'ai valider le nouveau profil du RX (autre uart, et passage sous Spektrum) dans betaflight,

j'ai binder la dx6e avec le quad.  : Nickel !

...Et le RX a rendu l'âme...O.o

A la deuxieme tentative, il est resté eteint :(

Mais c'est une autre histoire ( qui va se  finir rapidement par une nouvelle commande, je le sens venir...)

Merci a vous.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui vérifies la tension avec un voltmètre avant de toue mettre à la benne :)   

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, doulbix a dit :

Tu l'as bien branché sur le 5V ? 

C'est bizarre quand même ça 

Ben oui bizarre.

Ce matin par acquis de conscience, je la rebranche sur beta.... Échec. Comme au début.

Mais maintenant, je saurais faire. ;-)

Peut-être le mauvais firmware. Je reprends ca apres le taf...

Merci a vous.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hummm...

Spektrum c'est du 3.3v en général...

C'est un RX spektrum ou orange ? une réf exacte stp ?

Sinon ça explique pourquoi il a cramé..

Partager ce message


Lien à poster
Partager sur d’autres sites

2,4 g SP09X micro DSM2/DSMX 3.3v-5v satellite receiver.

Chez banggood. A 9.99 dollars

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de faire quelques recherches et çà à tout l'air d'être un problème récurent sur ce RX...Mort subite 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je dirai même plus; mort-né.

Mais j'ai la carte qui s'est remis en echec sur beta. Je vais d'abord voir la avant de le passer au compacteur...

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci d’être encore dans le coin

ça doit être le firmware

Quand j'ai fait la procédure de bind dans le CLI, avec le FuryF4 au moment de sauvegarder a la fin, beta m'affiche :  Echec de fermeture du port série

Si je laisse le quad sur l'usb, je peux binder la RC, je vois les "curseur des manches" bouger, les moteurs répondes en passant par béta, mais pas par la RC.

J'ai affilier mes 2 inters ( dx6e) aux mode de vol et a l'armement moteur

Donc je reflashe avec FuryF4OSD et rebind le zoziaux. c'est ca ?.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×