Jump to content
DroneBuilds
toper

R-xsr et Hobbywing Xrotor

Recommended Posts

Hello,

comment brancher le R-xsr à la xrotor ?

Le 5v, le gnd et le Sbus, ça ça va... 

mais le s-port va sur le pas "RSSI" de ma xrotor ? Ou sur un pad "Rx" ? 

Share this post


Link to post
Share on other sites

Hello

Vu que le UART1 est pris pour le SBUS, UART3-TX le mieux je pense il est juste à côté ou UART6-TX

Par contre j'ai pas l'impression que ce FC n'a  pas 2 inverters, donc soit tu récupère le signal non-inversé sur le petit pad ou alors softserial sur S5/S6 par exemple

Share this post


Link to post
Share on other sites

Alors j'ai arrêté de suivre à partir de "inverter". C'est quoi ? Moi je veux juste le rssi pour le moment.

Envoyé de mon SM-J320FN en utilisant Tapatalk

Share this post


Link to post
Share on other sites

C'est via smartport et télémétrie que tu pourras récupérer le RSSI et l'afficher sur l'OSD.

Le signal smartport et SBUS sont inversés chez FrSky et la plupart des F4 n'ont qu'un inverter hardware.

Donc soit tu soude un fil au bon endroit pour récupérer le signal smartport non-inversé  soit tu fais du softserial.

Sur le XSR classique le "hack" de soudure est facile mais sur le R-XSR il est proportionnelle à la taille du récepteur ¬¬ donc faut être méticuleux

frsky_r-xsr_rx_receiver_smartport_sbus_inverted_uninverted_pin.thumb.jpg.4266b7c17b8de5bcd0267ead2ee5a3bf.jpg

Edited by raskar
image

Share this post


Link to post
Share on other sites

Dak, donc si je soude un fil depuis le uninverted vers le pad RSSI de la FC, c'est good ? Et je n'ai pas compris l'histoire du proportionnel

Envoyé de mon SM-J320FN en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Youtube WE are FPV

Compris le proportionnel : il faut des doigts de fée ?
 

Edited by toper

Share this post


Link to post
Share on other sites
il y a 4 minutes, toper a dit :

Compris le proportionnel : il faut des doigts de fée ?
 

Waip, si tu as ton récepteur à porté, le pad doit faire 2/3 mm donc faut être doux sur la température du fer et rapide.

Le pad RSSI c'est pour les récepteur analogique style D4R, pour smartport il faut un UART-TX

Share this post


Link to post
Share on other sites

Je crois que j'ai réussi. Et sur ma FC je vais sur le pad rssi ou rx3 ?560efb8eee5a493f2866726f2dee04b4.jpg

Envoyé de mon SM-J320FN en utilisant Tapatalk

Share this post


Link to post
Share on other sites
il y a 6 minutes, toper a dit :

Je crois que j'ai réussi. Et sur ma FC je vais sur le pad rssi ou rx3 ?
 

UART3-TX serait nickel, juste à côté du SBUS

Protège bien la soudure avec de la colle chaude par exemple

Edited by raskar
ajout
  • Merci ! 1

Share this post


Link to post
Share on other sites

Je suis tombé là dessus avant de poster... Il a tort ?

Share this post


Link to post
Share on other sites

Y'a une erreur entre le sous titre qui dit de prendre le signal inversé (venant du connecteur jst) et le schéma qui montre clairement le pad du signal non-inversé vers un UART-TX du FC

image.thumb.png.78d5164a0ab34d0915ca003ea78d464b.png

==> c'est une vidéo de FrSky -_- bon c'est génant ce genre d'erreur venant du fabricant 9_9

Edited by raskar
image

Share this post


Link to post
Share on other sites

À deux lettres prêt....

Envoyé de mon SM-J320FN en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Tu t'embetes pour rien, dans le cli tu remappes le soft serial 11 et 12 sur ton rx et tx et c'est parti 

https://oscarliang.com/betaflight-soft-serial/

 

et pour l'inverted dans le cli aussi

set tlm_inverted = off ou on
Edited by ResO

Share this post


Link to post
Share on other sites

Salut, je me permets d'utiliser ton post car j'ai aussi un combo hobbywing et un r-xsr.
Pour résumer un peu tout ce que vous avez dit dans tes 2 post ( r-xsr rien ne bouge et celui-ci). Il faut que je coupe mon fil vert que je dois soudé sur le uninverted smartport du r-xsr et le soudé sur le rssi de la Fc. Le blanc je peu le couper j'en ai pas besoin. Le jaune du sbus out je le soude sur le sbus/ppm de la Fc.
Après dans betaflight il faut que je face quoi ?
Merci pour vos réponses. Je suis débutant et j'ai reçu mon rx et ma Fc, mais pas encore mes Esc 4in1 alors je me prépare déjà mentalement à faire mon premier build 7a8e11fd5a26525572f603091fe770cd.jpg

Envoyé de mon E5823 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Fais pas gaffe aux couleurs de mon schéma, mais à celles des fils de ton RX ! Je crois avoir inversé.... le jaune du "SBUS OUT" est en réalité vert

Ensuite, si tu branches comme c'est mis sur le schéma, tu n'a rien à faire. normalement le RX est déjà en sbus.

Sous BF, tu actives l'UART1 en RX, comme ci-dessous.

Si tu as des soucis pendant ton build, hésites pas à poster :)

uart.jpg

Share this post


Link to post
Share on other sites
Fais pas gaffe aux couleurs de mon schéma, mais à celles des fils de ton RX ! Je crois avoir inversé.... le jaune du "SBUS OUT" est en réalité vert
Ensuite, si tu branches comme c'est mis sur le schéma, tu n'a rien à faire. normalement le RX est déjà en sbus.
Sous BF, tu actives l'UART1 en RX, comme ci-dessous.
Si tu as des soucis pendant ton build, hésites pas à poster
uart.thumb.jpg.6509ad3d9c1f4ea394892b401bc02173.jpg
Okay alors je vais contrôler les couleurs ! Merci beaucoup en tout cas

Envoyé de mon E5823 en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Le 07/02/2018 at 09:34, ResO a dit :

Tu t'embetes pour rien, dans le cli tu remappes le soft serial 11 et 12 sur ton rx et tx et c'est parti 

https://oscarliang.com/betaflight-soft-serial/

 

et pour l'inverted dans le cli aussi


set tlm_inverted = off ou on

J’aime bien l’idée, mais du coup qu’est-ce qu’il faut faire concrètement ? Est-ce que j’ai besoin de souder un câble sur le r-xsr ou non ? 

Personelleent je cherche le plus simple en terme de raccordement et de soudures et plutôt de passer quelques lignes de commandes sur beta flight me paraît plus propre.. vu que tout est un peu parti dans tous les sens ce serait top si quelqu’un pourrait me récapituler les deux options parce que là j’avoue que je ne comprend plus grand chose :/

merci les gars ! C’est mon premier build alors j’ai un peu peur de faire des bêtises !

Edited by Brizoo64
Réponse auto

Share this post


Link to post
Share on other sites

Je viens de tester plusieurs choses et il m'est impossible de faire fonctionner la radio. 

1- j'ai essayé de faire fonctionner le F.Port puisque cela ne requiert qu'un seul cable, ça ma semblé interessant. J'ai bien la telemtry et le LUA script OK, je peut changer la puissance d'émission de mon transmetteur vidéo, changer mes pid etc. Par contre quand je bouge les sticks il ne se passe rien dans betaflight. Sachant que les commandes + la télémetry passent par le même cable, si l'un marche, l'autre devrait marcher aussi...

2- Je me suis dit, bon F.Port c'est trop récent, on va essayer la bonne vieille méthode. J'ai donc reflashé mon R-XSR avec le dernier firmware dispo (non f.port) 171009. J'ai branché le SBUS OUT sur le port SBUS de ma Xrotor et toujours rien.. 

Autre chose: lorsque l'on reste appuyé 5sec sur le r-xsr on change de mode (l'un avec une lumière bleu fixe en plus de la verte, et l'autre sans lumière bleu, juste la lumière verte de connexion radio). Savez vous lequel il faut mettre ? 

Pourtant sur cette vidéo, ummagawd a bien la xrotor et le r-xsr, il ne branche pas la telemetry mais il soude le SBUS OUT sur le port SBUS de la xrotor (les trois sont à coté : GND, 5v et SBUS). et tout fonctionne du premier coup sans rien configurer d'autre que le SBUS dans betaflight. 
 

Edited by Brizoo64

Share this post


Link to post
Share on other sites

C'est déja le cas. Je l'ai achetée sur bang**** donc, elle était déja en international. Je vais tout reflasher pour voir, histoire d'etre sur. Mais je l'ai mise a jour directement après l'avoir reçue, et pareil pour le r-xsr.. 

Share this post


Link to post
Share on other sites

Quand tu es sur bf et que tu met une batterie, t'arrive à faire tourné tes moteurs via la taranis?

Envoyé de mon E5823 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Ok j'ai réussi finalement ! 
J'ai reflashé donc le r-xsr avec le dernier firmware (NON F.Port)

J'ai connecté le Sbus Out du r-xsr sur le SBUS de ma xrotor F4

Le SmartPort non inversé (soudé sur le r-xsr, depuis la pad "P") connecté sur le UART 6 TX de ma xrotor F4

Dans Betaflight, j'ai activé le Serial RX sur UART1 et SmartPort sur UART6

J'espère que ça en aura aidé quelques uns :)

Share this post


Link to post
Share on other sites

Moi j'ai tjs pas les pid sur ma taranis quand je fais sa

Ok j'ai réussi finalement ! 
J'ai reflashé donc le r-xsr avec le dernier firmware (NON F.Port)
J'ai connecté le Sbus Out du r-xsr sur le SBUS de ma xrotor F4
Le SmartPort non inversé (soudé sur le r-xsr, depuis la pad "P") connecté sur le UART 6 TX de ma xrotor F4
Dans Betaflight, j'ai activé le Serial RX sur UART1 et SmartPort sur UART6
J'espère que ça en aura aidé quelques uns


Envoyé de mon E5823 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...