Jump to content
DroneBuilds
diegau

Taranis QX7/crossfire mcro/kiss

Recommended Posts

Salut à tous

 

Je ne comprends absolument pas le problème! Je voulais régler mes PID de ma kiss sur ma QX7 donc avec mon XSR ça marchait pas de souci avec le script LUA.

Je viens de passer sur crossfire micro donc j'ai changé le fichier LUA et mis le CF avec les fichier du dossier KISS (VTX, PID, RATES ETC) dans le dossier TELEMTRY de ma radio, et le plus fort, ça a marché un temps et maintenant j'ai toujours ce message: erreur syntaxe script Telemetry/kissCF.LUA:1 attempt to perform arith. 

J'ai juste rajouter un modèle en 4 (rien à voir avec le modèle que j'utilise pour le crossfire) mais sinon rien! je comprends absolument pas pourquoi, tout est bon mais ça doit M..dé qq part mas quoi  . . . 

Share this post


Link to post
Share on other sites

Bonjour,

il y en a un qui a résolu ça en re-flashant sa FC (https://github.com/flyduino/kissfc-tx-lua-scripts/issues/24)

Sinon essaie de re-télécharger le contenu du script et de l'écraser dans ta SD ?

Edited by toper

Share this post


Link to post
Share on other sites

Re flasher la kiss oui je vais essayer ça alors !

J ai essayé de l écraser oui mais même chose.

Share this post


Link to post
Share on other sites

Petite question, quand est-ce que le message apparaît ? J'ai un message du même qui apparait (mais avec le script SP car j'ai un XSR) quand je change de page du script trop rapidement. En fait si tu vas trop vite, le script a pas le temps de s'exécuter correctement. Il faut bien attendre que toutes les données se chargent sur la page, et après tu peux changer de page tranquillement.

Ca peut être une piste...

Edited by Jibz

Share this post


Link to post
Share on other sites

Salut Jibz

Le message apparaît dès que je lance le script LUA. Le plus bizarre, c'est que quand j'ai reflashé la KISS et en remettant le fichier LUA après avoir écrasé l'autre, ça a marché un temps et pof d'un coup ça me remets le message . . . . à rien y comprendre!

Share this post


Link to post
Share on other sites
Youtube WE are FPV

t'as mit les fichiers qui vont avec le LUA ?

Share this post


Link to post
Share on other sites

Là je les avais pas mis car avec ou sans j'avais la même chose, le même message!

Share this post


Link to post
Share on other sites

J'avais ce soucis avant, quand il n'y avait pas les fichiers fournis avec le LUA.

Mais depuis, jamais eu le cas... :S 

Share this post


Link to post
Share on other sites

Tes fichiers tu les copies sur la SD de la taranis alors qu'elle est en mode bootloader ou en mode stockage USB ?

Share this post


Link to post
Share on other sites

Je vais les remettre alors histoire de voir ...

Bonne question Jibz, en stockage USB jpense vu que je copie là !

Share this post


Link to post
Share on other sites

Essaie de le faire en mode bootloader aussi. J'ai aussi eu ce problème de script qui crash et je me souviens que j'avais essayé l'histoire du mode bootloader. A tester...

Share this post


Link to post
Share on other sites

Mais là question con, le mode bootloader sert à aller dans la radio et pas la SD? je sais pas comment faire là sinon ...

Share this post


Link to post
Share on other sites

Normalement, quand tu lances la radio en mode bootloader et que tu la connectes au PC, ça te permet d'aller dans la mémoire interne de la radio (mais là on s'en fout) ET dans la carte SD.

La seule différence que je vois, c'est que OpenTX ne tourne pas quand tu es en mode bootloader, alors qu'il est en cours d'exécution sur la radio si tu es en mode USB. Après ça a peut être zéro impact, c'est juste un truc que j'avais essayé...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...