Aller au contenu
DroneBuilds

Messages recommandés

Bonjour a tous.

Alors je vous expose le problèmo sur lequel je planche depuis un mois, oui oui vous avez bien lus 1 MOIS, je n'exagère pas, je rentrais du boulot et je faisais les recherches les essais mais finalement je n'ai rien réussi a faire avancer.

C'est mon premier drone monter par mes soins donc il peut y avoir erreur de montage même si j'en doute, car quand je le branche sur Betaflight et que j'arme les moteurs et touche au commande le drone réagit a la perfection comme il devrait le faire en vrai, donc déjà tout est bind correctement d'après moi, mais je ne comprends pas d'ou vient le problème

Sauf que dans la pratique ben... il bouge pas, cloué au sol ! j'ai brancher les 4 esc pareils sachant que avec BLheli Configurator on peut les inverser.

Ce qui m'étonne le plus c'est que les 4esc sont exactement les mêmes mais sous BLheli ils ont pas le même nom et n'avait pas le même firmware (que j'ai normaliser sur les 4 comme vous le verrait sur les photos)

Quand je branche une lipo il font TuT OuT TuT Tuuuuut puis c'est tout donc pas la musique complète et aucun moteur ne bouge ou ne tremble d'un yota.

MAIS quand je laisse brancher la lipo pendant un petit moment j'ai un moteur qui se met a tourner tout seul sans s'arrêter ceci arrive parfois mais pas tout le temps.

D'après vous ça vient des Esc ou autre choses ? 

Merci par avance de votre aide 

1.jpg

2.jpg

3.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,
Il s'agit donc d'un nouveau drone qui n'a jamais fonctionné, il n'y a quasiment aucun risque que les 4 ESC neufs aient la même panne donc il y a de fortes chances que ce soit un problème de montage ou de configuration, ou une erreur de flash.

Les ESC devraient avoir le même firmware et le même modèle, ce qui n'est pas le cas. Je pense qu'il faut mettre A-H-25.

Ta transcription écrite de la musique d'initialisation des ESC n'est pas très claire, peux-tu faire un enregistrement ?

Le "petit moment" après lequel un moteur tourne sans raison correspondrait-il au "beacon delay" (10 min) après lequel les ESC doivent faire sonner les moteurs s'ils ne reçoivent pas d'info.

La radio communique-t-elle bien avec BetaFlight ?
Quels sont les réglages ESC/Moteur dans BetaFlight ?
Dans le doute, donne-nous le résultat de la commande diff dans CLI.

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Bon je n'arrivais pas a flasher et finalement j'ai du cocher la case "Ignore inappropriate MCU and Layout"

Moi qui me pensait imitateur parfait d'ESC je suis déçu lol j'envois ça des demain car la je galère a transférer ça sur pc

Oui ça correspond au bacon delay

Elle communique parfaitement avec Betaflight

j'ai joint par photo la commande diff dans CLI ainsi que les réglages ESC/Moteur

En tout cas merci pour ta rapidité de réponse ;)

escmotor.png

diff.png

Partager ce message


Lien à poster
Partager sur d’autres sites

mets 2000 en "Maximum Throttle" et recalibre les ESC dans BetaFlight.

Partager ce message


Lien à poster
Partager sur d’autres sites

C’est chose faites mais toujours aucune réaction avec la radio. Sinon lors du calibrage les 4 moteurs ont réagir nickel

Partager ce message


Lien à poster
Partager sur d’autres sites

J'avais le même problème sur un Rodeo110, c'est dû à des vis qui touchaient le bobinage moteur.

Essaye de regarder par là et dis nous

Partager ce message


Lien à poster
Partager sur d’autres sites

La communication avec la radio fonctionne bien ? Les sticks font-ils bouger les barres dans l'onglet "recevier" de BetaFlight ?
Il n'y a pas de mode ARM configuré, comment armes-tu à la radio ?
D'ailleurs, quelle radiocommande as-tu ?

Les moteurs fonctionnent bien dans l'onglet "motors" de BetaFlight ?

Peux-tu nous donner le résultat de la commande status dans CLI ? (avec LiPo branchée et radiocommande allumée)

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui Oui !!! Les sticks font réagir parfaitement les barres dans onglet recevier

je ne sais pas ce qu'est le mode arm mais en tout cas j'ai configurer un "stick" de ma Spectrum dx6  (le H pour ceux qui connaissent) et quand j'actionne plus rien réagit sous Betaflight ou quand je le retouche tout fonctionne donc l'armement fonctionne bien je pense.

Oui oui les moteurs tourne a la perfection !

 

$M>e÷!¼ CLI # status
System Uptime: 234 seconds
Voltage: 0 * 0.1V (0S battery - NOT PRESENT)
CPU Clock=72MHz, GYRO=MPU6050, ACC=MPU6050.n
Stack size: 2048, Stack address: 0x10002000
I2C Errors: 3, config size: 2010, max available config: 4096
CPU:8%, cycle time: 501, GYRO rate: 1996, RX rate: 90, System rate: 9
Arming disable flags: CLI

#

 

je suis pas expert mais la je pense qu'il y a une couille par contre lol

 

Les vis ne touche pas le bobinage après vérification j'aurais tellement aimé que ça soit ça lol

Modifié (le) par Xlaw

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Xlaw a dit :

je ne sais pas ce qu'est le mode arm mais en tout cas j'ai configurer un "stick" de ma Spectrum dx6  (le H pour ceux qui connaissent) et quand j'actionne plus rien réagit sous Betaflight ou quand je le retouche tout fonctionne donc l'armement fonctionne bien je pense.

Il y a 4 canaux qui sont utilisés pour piloter le drone qui correspondent aux sticks (Throttle, Yaw, Pitch, Roll)
Selon ton récepteur, il y a aussi des canaux auxiliaires, AUX1, AUX2, AUX3, etc. qui correspondent généralement à des switchs (interrupteurs).
Dans l'onglet "modes" de BetaFlight, il faut assigner une plage de valeurs d'un AUX au mode ARM afin de pouvoir donner l'ordre d'armer les moteurs.

Par exemple, si un switch correspond à l'auxiliaire AUX1, il envoie la valeur 1000 quand il est en haut et 2000 quand il est en bas. Il faut configurer le mode ARM sur AUX 1 de 1950 à 2050. Quand le switch sera baissé, le mode ARM s'activera et, si toutes les conditions sont réunies, les moteurs s'armeront.

Je ne sais pas ce que tu as configuré sur ta Spektrum avec le H, mais ça n'est probablement pas ce qu'il fallait faire.
Je ne pourrai pas t'aider avec cette radiocommande, je ne la connais pas du tout.

Partager ce message


Lien à poster
Partager sur d’autres sites

ah ah jolie goony j'avais configurer l'armement uniquement sur la radio je l'ai configurer sur Betaflight et ça a l'air de marcher ! par contre quand j'arme les moteurs tourne en permanence hum hum

je vais plancher dessus pour voir ce que ça donne !

Modifié (le) par Xlaw

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est normal que les moteurs tournent quand tu armes, et ne s’arrêtent que quand tu désarmes.
Certaines personnes préfèrent que les moteurs ne tournent pas à l'armement mais uniquement quand on monte les gaz. Je trouve personnellement que c'est un peu dangereux car on peut ne pas savoir que les moteurs sont armés. Si tu ne veux pas que les moteurs tournent à l'armement, choisis l'option "MOTOR_STOP".
Tu devrais aussi régler le "minimum throttle" à environ 1070.
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui les hélices tournent quand tu armes, car "l'airmode" est activé dans BF.

L'airmode est génial pour le freestyle, ça permet de contrôler ton kwad avec les gaz à 0.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, GodsWarrior a dit :

Oui les hélices tournent quand tu armes, car "l'airmode" est activé dans BF.

Ca n'a rien à voir avec l'air mode, l'air mode permet juste de garder la position enregistré par le gyro lorsque tu as les gaz à 0 et comme tu dis c'est génial en freestyle.

En accro les moteurs tournent aussi lorsque tu as les gaz à zéro et tu peux même régler leur vitesse

Partager ce message


Lien à poster
Partager sur d’autres sites

vus que je compte faire que du freestyle avec ce quad ça sera parfait alors ! Je l'ai activer de manière permanente des l'armement

 

Par contre le réglage des moteur a 1070 ça va m'apporter quoi ?

Modifié (le) par Xlaw

Partager ce message


Lien à poster
Partager sur d’autres sites

Une petite marge de sécurité en bas de gaz pour être dans la plage de rotation moteur quoiqu'il arrive.

On ne veut pas qu'à 1% les moteurs tremblottent.Il faut qu'ils tournent proprement.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 26/03/2018 at 23:06, mickteul a dit :

Ca n'a rien à voir avec l'air mode, l'air mode permet juste de garder la position enregistré par le gyro lorsque tu as les gaz à 0 et comme tu dis c'est génial en freestyle.

En accro les moteurs tournent aussi lorsque tu as les gaz à zéro et tu peux même régler leur vitesse

Me suis trompé avec "MOTOR STOP"...

Partager ce message


Lien à poster
Partager sur d’autres sites

En tout cas merci bien pour vos réponses tout fonctionne a première vue ! Juste a peaufiner quelque réglages !

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×