Aller au contenu
DroneBuilds
goony

blackbox pour identifier un problème, besoin d'aide

Messages recommandés

Salut
J'ai un problème sur un drone... il se penche à gauche par à-coups. C'est assez rare, mais c'est très embêtant quand ça survient, jusqu'à la perte de contrôle. Je ne sais pas d'où ça vient, ni comment corriger le problème.

Même si je n'y comprends rien, j'ai voulu tester la blackbox. La puce a une petite capacité, je ne peux avoir qu'un vol à la fois.
Il aurait fallu une vidéo à superposer pour mieux identifier ce qu'il se passe et à quel moment, malheureusement mes cartes microSD sont mortes.

Voici le fichier : BTFL_BLACKBOX_LOG_Japalura_20180331_155057.bin

Mon analyse :
Il y a une dizaine de coupures de l'enregistrement, en particulier à la fin, alors que je n'ai jamais touché au switch assigné à la blackbox.
À 02:11, il y a un très court changement de mode ARM, sans raison.
À partir de 02:12, on voit des coups de roll à gauche très rapides et saccadés, ce n'est pas moi non plus. Il y en a d'autres après.
À 02:21, un changement de mode ANGLE, sans raison.
Après la coupure de 02:36, la position du quad et les mouvements de sticks ne me paraissent pas cohérents (mais je ne me souviens pas de ce qui s'est passé, j'ai peut-être fini en crash).
À la toute fin, plusieurs changements de mode qui ne sont pas de mon fait.

Du coup, malgré le peu d'informations que j'ai, je pense qu'il ne s'agit pas d'un problème de moteurs ou d'ESC, mais de transmission d'infos de la radio ou un bug de la carte de vol.
La radiocommande est une FrSky Taranis Q X7S, sous OpenTX 2.2.1
Le récepteur est un R-XSR, flashé avec le firmware R-XSRLBT171103.frk
La carte de vol est une Lumenier micro LUX F4, sous BetaFlight 3.3.0

NB : C'est mon seul drone qui vole actuellement, je n'ai donc pas pu en tester un autre pour voir si ça venait de la radiocommande elle-même.

Quel est votre avis ?
Avez-vous décelé quelque-chose dans la blackbox ?
Que dois-je faire pour pousser les investigations ?

Et surtout, putain de bordel de merde, ça me fait chier !

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai remonté un drone vite fait, aucun problème en vol, ça ne vient donc pas de la radiocommande elle-même.

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Je e suggère de revoir tes soudures. Je pencherais pour une soudure sèche ou un court-circuit aléatoire avec les vibrations.

Envoyé de mon BTV-DL09 en utilisant Tapatalk

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai revu les soudures, j'ai changé le récepteur, et... ÇA CONTINUE ! >:(
Je mets l'enregistrement du jour en pièce-jointe , les problèmes apparaissent surtout en fin du vol, principalement sur le pitch. Les autres canaux ont quelques aussi quelques sauts mais beaucoup moins.
image.thumb.png.c86fab8b5680d1558bd71afc5a671746.png

Je perds patience... personne n'aurait une piste ?

BTFL_BLACKBOX_LOG_Japalura_20180402_141508.bin

Partager ce message


Lien à poster
Partager sur d’autres sites

Il semblerait qu'il n'y ait plus de problème quand j'utilise le protocole F.Port !  (à vérifier un jour sans pluie, je n'ai pu faire qu'un vol)

J'aurais préféré savoir d'où ça vient, ce n'est ni la radio ni le récepteur... mais au moins je peux voler :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×