Jump to content
DroneBuilds
Nat42

Problème moteur 1 et 4 ne tourne pas

Recommended Posts

Hello tout le monde! 

Je reviens à nouveau vers vous, suite à la mise à jour de la FC (target pikoblx) de mon geprc mx3 sparrow, j'ai un soucis: que se soit avec la radio ou sur betaflight, les moteurs 1 et 4 ne tournent pas.

Avez vous une idée...?

Share this post


Link to post
Share on other sites

Tu n'as pas fait de dump avant la mise à jour ?

Share this post


Link to post
Share on other sites

En faite, je souhaitais passer sous butterflight, et c'est la que le problème à commencé. Je suis donc revenu sous betaflight et le problème persiste.

Share this post


Link to post
Share on other sites
Youtube WE are FPV
il y a 22 minutes, Lexus a dit :

Voici le dump d'origine MX3_CLI_BF3.1.5_Stock

du GepRC GEP-MX3 "Sparrow" 139mm 

Merci beaucoup, j'ai remis la version usine et sa fonctionne. Par acquis de conscience j'ai essayé à nouveau une mise à jour mais j'ai à nouveau les moteurs 1 et 4 qui ne tourne pas. Donc pas de mise à jour :(

Share this post


Link to post
Share on other sites
Merci beaucoup, j'ai remis la version usine et sa fonctionne. Par acquis de conscience j'ai essayé à nouveau une mise à jour mais j'ai à nouveau les moteurs 1 et 4 qui ne tourne pas. Donc pas de mise à jour
Essai de faire un DIFF et posté le jeudi regarde demain pour ta mise à jour

Share this post


Link to post
Share on other sites

Lol dsl pour le message, poste le diff je regarde demain pour la mise à jour

Share this post


Link to post
Share on other sites

Merci de m'aider LEXUS, voici le diff:

# diff
# Betaflight / PIKOBLX 3.1.7 Apr 3 2017 / 22:16:26 (e1c4b5c)
name NAT Sparrow
resource MOTOR 1 A01
resource MOTOR 4 A02
resource MOTOR 5 NONE
resource MOTOR 6 NONE

feature -RX_PARALLEL_PWM
feature RX_PPM
feature LED_STRIP
serial 2 64 115200 57600 0 115200
led 0 0,0::CT:5
led 1 15,0::CT:5
aux 0 0 1 1925 2100
aux 1 28 0 1925 2100
aux 2 1 0 900 1700
aux 3 13 255 1300 1700
set max_aux_channels = 6
set motor_pwm_protocol = DSHOT600
set serialrx_provider = SBUS
profile 0

set anti_gravity_gain = 1.000
set setpoint_relax_ratio = 25
set d_setpoint_weight = 190
set p_pitch = 22
set i_pitch = 40
set d_pitch = 14
set p_roll = 22
set d_roll = 14
set p_yaw = 50
set i_yaw = 40
rateprofile 0
rateprofile 0

set rc_rate = 110
set thr_expo = 100
set roll_srate = 80
set pitch_srate = 80
set tpa_rate = 30

#

Share this post


Link to post
Share on other sites

Lol mappage des moteurs


Regarde

resource MOTOR 1 A01
resource MOTOR 4 A02

  • J'aime 1

Share this post


Link to post
Share on other sites

Fait ta maj et copie le diff et normalement ton quad fonctionnera

Share this post


Link to post
Share on other sites

Je ferais sa demain. Je met la dernière mise à jour mais après je copie quel diff ?

Share this post


Link to post
Share on other sites

Je ne capte pas très bien ou tu veux en venir car, sur le diff que j'ai posté, les moteur affiché 1 et 4 sont ceux qui ne tournent pas donc sa ne fonctionnera pas mieux...

Share this post


Link to post
Share on other sites

Normalement avec une mise à jour et le diff complet que tu as cela va fonctionner

Share this post


Link to post
Share on other sites
Il y a 8 heures, Lexus a dit :

Normalement avec une mise à jour et le diff complet que tu as cela va fonctionner

Merci beaucoup pour ton aide, du coup je l'ai passé sous butterflight et j'y ai sauvé le diff. Nikel!

Encore merci

Share this post


Link to post
Share on other sites
Merci beaucoup pour ton aide, du coup je l'ai passé sous butterflight et j'y ai sauvé le diff. Nikel!
Encore merci
CT avec plaisir

Share this post


Link to post
Share on other sites
il y a 49 minutes, Lexus a dit :

Tu kiff butter ?

Les réglages de bases sont (selon ma petite experience) mieux optimisé (filtres, paramètre...) Je teste betaflight, butterflight pour un même quad et je garderai le soft et le firmware que je préfère.

Tu es plus un adepte de betaflight?

Share this post


Link to post
Share on other sites

Pour tester le "vol dans du beurre", je dois dire que c'est plutôt bien.

Pour ceux qui ont une carte standard (mono processeur), ça rajoute des possibilités de réglages (antigravité personnalisé sur chaque axe (imuf_w) et aussi le filtrage de chaque axe (imuf_w),  et pour ceux qui ont une HESP comme moi, ça permet des pid's moins élevés, donc des "D" (sur le Yaw aussi depuis la vesion 3.5.1) moins élevés et donc des moteurs moins agressée par le D, donc un quad plus souple tout en restant nerveux O.oO.o

  • J'aime 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...