Aller au contenu
DroneBuilds
Elanaerusif

betaflight Problème débutant : conf Rx dans BF sur diatone 2017 gt200

Messages recommandés

Bonjour, jai récemment fais l'acquisition  d' un diatone 2017 gt200s .

Je suis débutant dans le domaine du quad et tout ce qui s'y rapporte  (RC,electronique en générale ). 

Jai donc reussi à binder le x8r avec ma taranis x9d . 

Dans betaflight je bloque dès la première étape : attribué le bon port rx(onglet port) ,puis paramétrer le bon recepteur (onglet configuration).

Après sauvegarde et redémarrage tout redeviens comme avant.

Betaflight ne réagit pas quand je bouge mes commandes.

Dsl pour le vocabulaire imprécis, merci par avance de votre patience .

Je linke les quelques documentations que jai.

Screenshot_20180420-124540.png

Screenshot_20180420-113938.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello, j'ai pas mal bataillé avec une machine Diatone, j'avais le même souci que toi.

Première chose à vérifier : fais un dump CLI de la configuration betaflight, enregistre le en lieu sûr. Ensuite, mets à jour la machine sur la dernière version de betaflight et refais les réglages d'origine (en copiant collant le contenu du dump dans le CLI).

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Alors dans configuration je mets sbus

Je pense avoir bien fais le branchement sur le r8x dans les ports sbus.

Merci pour la réactivité , je teste ça ce soir apres le boulot et je vous dis ce qu'il en est.

Partager ce message


Lien à poster
Partager sur d’autres sites

(et au passage, joli pseudo mais tu as zappé un "s" :P )

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,
peux tu faire un copier/coller du résultat de la commande diff dans CLI ? (cette commande indique toutes les modifications par rapport aux réglages par défaut)

Dans l'onglet Configuration, voici les options à mettre :
   Mode du récepteur : RX Série
   Type de récepteur série : SBUS

Il faudrait aussi un schéma ou des photos montrant sur quel port tu as soudé/branché le X8R pour qu'on t'indique quoi modifier dans l'onglet Ports.
Concrètement, il faut brancher le signal SBUS sur un port rx disponible et cocher "Serial Rx" pour l'UART correspondant dans l'onglet Ports
 

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites

# diff
# Betaflight / FURYF3OSD (FY3O) 3.2.1 Oct 15 2017 / 19:35:24 (434db9a36) MSP API: 1.36
name Elanaerusif

feature -RX_PPM
feature RX_SERIAL
feature MOTOR_STOP
feature TELEMETRY
feature AIRMODE
feature DYNAMIC_FILTER
beeper -GYRO_CALIBRATED
beeper -DISARMING
beeper -ARMING_GPS_FIX
beeper -BAT_CRIT_LOW
beeper -RX_SET
beeper -ACC_CALIBRATION
beeper -ACC_CALIBRATION_FAIL
beeper -READY_BEEP
beeper -MULTI_BEEPS
beeper -ARMED
beeper -SYSTEM_INIT
beeper -ON_USB
beeper -BLACKBOX_ERASE
serial 0 64 115200 57600 0 115200
serial 1 64 115200 57600 0 115200
serial 2 64 115200 57600 0 115200
aux 0 0 0 1950 2100
aux 1 28 0 1950 2100
aux 2 4 0 900 2100
set gyro_notch1_hz = 0
set gyro_notch2_hz = 0
set moron_threshold = 32
set acc_trim_pitch = 2
set rssi_channel = 16
set serialrx_provider = SBUS
set min_throttle = 1000
set motor_pwm_protocol = DSHOT600
set motor_pwm_rate = 400
set vbat_min_cell_voltage = 34
set vbat_warning_cell_voltage = 36
set deadband = 2
set pid_process_denom = 2
set osd_vbat_pos = 2402
set osd_rssi_pos = 40
set osd_tim_1_pos = 438
set osd_tim_2_pos = 2422
set osd_flymode_pos = 419
set osd_throttle_pos = 225
set osd_vtx_channel_pos = 377
set osd_crosshairs = 200
set osd_ah_sbar = 200
set osd_ah_pos = 200
set osd_current_pos = 2465
set osd_mah_drawn_pos = 374
set osd_craft_name_pos = 2088
set osd_gps_speed_pos = 218
set osd_gps_lon_pos = 82
set osd_gps_lat_pos = 65
set osd_gps_sats_pos = 51
set osd_home_dir_pos = 302
set osd_home_dist_pos = 303
set osd_compass_bar_pos = 266
set osd_altitude_pos = 247
set osd_pid_roll_pos = 423
set osd_pid_pitch_pos = 455
set osd_pid_yaw_pos = 487
set osd_debug_pos = 1
set osd_power_pos = 321
set osd_pidrate_profile_pos = 345
set osd_warnings_pos = 329
set osd_avg_cell_voltage_pos = 76
set osd_pit_ang_pos = 257
set osd_rol_ang_pos = 289
set osd_battery_usage_pos = 392
set osd_disarmed_pos = 138
set osd_nheading_pos = 311
set osd_nvario_pos = 279
set osd_esc_tmp_pos = 82
set osd_esc_rpm_pos = 83
set osd_stat_max_spd = OFF
set osd_stat_min_batt = OFF
set osd_stat_min_rssi = OFF
set osd_stat_max_curr = OFF
set osd_stat_used_mah = OFF
set osd_stat_bbox = OFF
set osd_stat_bb_no = OFF
set osd_stat_tim_1 = ON
profile 1

set dterm_lowpass_type = PT1
set setpoint_relax_ratio = 30
set p_pitch = 53
set i_pitch = 52
set d_pitch = 28
set p_roll = 51
set i_roll = 50
set d_roll = 28
rateprofile 0

set rc_expo = 30
set roll_srate = 77
set pitch_srate = 77
set yaw_srate = 82

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai tester en ppm car je ne trouve pas le mode sbus dans la taranis.
Le problème pérciste .

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur la prise à laquelle tu as branché ton rx, les pins sont (de haut en bas) : Gnd, 5V, PPM, S-BUS, 3.3V
Il faut donc que le câble N°3 du X8R (qui correspond au signal S-BUS) soit relié au 4ème pin de la prise.
Sur la prise blanche, tu peux délicatement lever une languette pour retirer un câble. Il faut que tu retires les 2 câbles blanc et que tu changes l'emplacement du câble S-BUS.

Modifié (le) par goony
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans le diff, je vois qu'il y a pas mal de modifications par rapport à l'origine. As-tu touché à plein de trucs ou c'était d'origine ?

Concernant ton premier problème, je crois notamment que tous les UART sont cochés en Serial RX, alors qu'il ne devrait y en avoir qu'un (a priori je pense que c'est l'UART 3).
Peux-tu faire une capture d'écran de l'onglet Ports pour voir ce que tu as ?
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci !! le récepteur est bien reconnu par BF. 
A demain pour de nouvelles péripéties .  

Partager ce message


Lien à poster
Partager sur d’autres sites

De rien, si tu ne sais pas quel film regarder ce soir, fais-toi toute la playlist  :D
https://www.youtube.com/watch?v=XyQBNt0dsds&list=PLr-Mb5AXisr8Ccn7yrT0l4dk7Lro8ft4B&index=7

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 20/04/2018 at 17:16, Jibz a dit :

(et au passage, joli pseudo mais tu as zappé un "s" :P )

La première fois qu'il est apparus (pour un compte bnet je crois) je n'avais pas la place pour ce caractère :)

 

Alors merci à  vous ,ce soir jai effectué mes premier rebonds :) que de frayeur !!

Le quad part un peu trop en arrière en mode angle ,je vais calibrer le gyro et je testerai demain.

Je me présenterai avec photo du quad s'il survit à sa premiere semaine^^

Merci encore.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×