Aller au contenu
acheter dji air unit o3
DroneBuilds

Ma fc ne reconnait pas mes récepteurs :/


ArnaudF

Messages recommandés

Bien le bonjour tout le monde, j'ai reçu ma commande et j'ai passé des heures pour monter la moitié de ce petite engin , un 130 en 2.5 pouce mais j'ai un problème : j'ai deux récepteurs rx que j'ai testé et qui marche parfaitement avec d'autre fc , un est en PPM et SBUS et l'autre PPM et IBUS. Ma radio est bind avec les deux ( dans des modèle différents ) et la fc ne reconnait aucune des deux , j'ai testé les 4 pads : TX1 , RX1 , TX2 , RX2. Rien à faire , la FC  ne le reconnait pas ...

Pour info , la fc :

http://www.fullspeedrc.com/fsd328-28a-f3-flight-tower_p0106.html

Les deux récepteurs :

https://www.banggood.com/Flysky-FS-A8S-2_4G-8CH-Mini-Receiver-with-PPM-i-BUS-SBUS-Output-p-1092861.html?rmmds=detail-bottom-viewalsoview__12&cur_warehouse=USA

et 

https://www.banggood.com/fr/Flit10-2_4G-10CH-Micro-Telemetry-Flysky-Compatible-Ibus-Receiver-for-FS-I6X-FS-i6S-Turnigy-Evolution-p-1260238.html?rmmds=myorder&cur_warehouse=CN

J'ai besoin de votre aide ^^

IMG_20180707_002809.jpg

Modifié (le) par ArnaudF
Lien vers le commentaire
Partager sur d’autres sites

Tu veut que j'utilise qu'elle commande dans CLI ? Ou que je capture juste la config ? Car quand j'entre le type du récepteur , du style IBUS ou SBUS , quand je save et que je reviens , ils ne sont plus marquer.

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Salut,
Peux-tu nous faire un copier-coller de la commande diff dans CLI ?
D'après la capture d'écran, tu as mis le mauvais type de RX, il faut choisir IBUS.

Modifié (le) par goony
Lien vers le commentaire
Partager sur d’autres sites

Tien la voilà, en ce moment , le récepteur utilisé est un flysky a8s ( https://www.banggood.com/Flysky-FS-A8S-2_4G-8CH-Mini-Receiver-with-PPM-i-BUS-SBUS-Output-p-1092861.html?cur_warehouse=USA), compatible ppm , Sbus et Ibus, j'essaye tout les uarts de ma carte , c'est-à-dire , rx1 , rx2 , tx1 , tx2.. 

 

Pour info la fc :

http://www.fullspeedrc.com/fsd328-28a-f3-flight-tower_p0106.html

tt.JPG

Lien vers le commentaire
Partager sur d’autres sites

Flysky, par défaut c'est IBUS.
Mets donc IBUS au lieu de SBUS actuellement.

D'après ta capture d'écran, le RX Série est configuré sur l'UART 2.
Le signal est-il bien soudé au RX2 ?
NB : Sur le FS-A8S, il faut utiliser le 3ème cable i-BUS/S.BUS.  N'utilises pas le PPM.


Pas besoin de tester tous les UARTS, il suffit que la configuration corresponde au montage 😉

PS : Je vois qu'il y a un pad PPM/SBUS, par défaut, c'est là qu'il aurait fallu souder ton récepteur mais tu peux aussi le souder sur n'importe quel pad RX (pas TX). Par contre, il faut que l'onglet Ports soit bien configuré.
Peux-tu faire un copier/coller de la commande resource ?

Lien vers le commentaire
Partager sur d’autres sites

il y a 33 minutes, ArnaudF a dit :

Sinon j'ai soudé le cable Sbus / Ibus sur le pad TX c'est grave ?

C'est pas grave dans le sens où ça n'a rien bousillé, mais ça ne fonctionne pas.

Lien vers le commentaire
Partager sur d’autres sites

Je ne connais pas ta carte, d'après "resource" je pense que dans l'onglet Ports il y a 3 UART.
Comme le 1 et le 2 correspondent aux pads RX/TX 1 et 2 sur la carte, je suppose que le 3 correspond au pad SBUS.

Lien vers le commentaire
Partager sur d’autres sites

Oui c'était ce uart là, et du coup j'ai réussi à tout faire , à part un truc , quand j'arme et que les moteurs s'active, le quad faire n'importe quoi, il vibre, oscille énormement . ( moteurs dans un mauvais sens ? ou même autre chose ? )

Lien vers le commentaire
Partager sur d’autres sites

C'est un autre sujet, je te conseille d'ouvrir un autre post.
Dans tous les cas, commence à faire toutes les vérifications d'usage, sans hélices !

Teste chaque moteur dans BetaFlight.
Sont-ils à la bonne place ? Tournent-ils dans le bon sens ? de manière fluide ? etc.

Est-ce que le carte de vol est dans le bon sens ? Quand tu bouges le drone, le visuel 3D de l'onglet "Installation" bouge-t-il dans le bon sens ?

Edit : dans ton diff on voit qu'il y a des réglages "exotiques" quant à la position des capteurs (gyroscope, accéléromètre et magnétomètre) et au sens des moteurs. Aurais-tu modifié des paramètres sans les comprendre ?

 

Modifié (le) par goony
Lien vers le commentaire
Partager sur d’autres sites

Dans l'onglet Configuration,
Décoche "Sens de rotation inversé"
Remets les alignements du Gyro, de l'accéléromètre et du magnétomètre à la valeur par défaut.
Ne "joue" qu'avec les valeurs Degrés sur le Roll, sur le Pitch et sur le Yaw dans le même cadre "Sens de la carte et du capteur".
Comme je ne sais pas dans quel sens la carte est mise, je ne peux pas te dire quelles valeurs mettre, il faut que la représentation 3D bouge de la même manière que le vrai drone.

Lien vers le commentaire
Partager sur d’autres sites

Bon, après quelque jours, il marche enfin , il suffit juste que je fasse quelque réglage, c'est très bizarre, j'ai mit  à jour betaflight et le drone ne vibre plus du moins casiment pas, donc je peut le faire voler. 

Lien vers le commentaire
Partager sur d’autres sites

  • 4 months later...

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...