Aller au contenu
DroneBuilds

Messages recommandés

Bonjour les pilotes, comme toujours nouveau problème ! Cette fois-ci je ne comprend pas tellement... Quand je décolle et que je reste à bas régime le drone vole mais à 100% de throttle ou moins le drone se retourne. Hier j'ai juste changé le protocole des esc pour du multishot et j'ai tout calibré donc je ne pense pas que ce soit ça. Vous avez des idées? Je vous donne la blackbox.

image.thumb.png.8aa8df4397655683163270972334e7b4.png

BTFL_crash.BBL

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 36 minutes, CarlosMagni a dit :

Bonjour les pilotes, comme toujours nouveau problème ! Cette fois-ci je ne comprend pas tellement... Quand je décolle et que je reste à bas régime le drone vole mais à 100% de throttle ou moins le drone se retourne. Hier j'ai juste changé le protocole des esc pour du multishot et j'ai tout calibré donc je ne pense pas que ce soit ça. Vous avez des idées? Je vous donne la blackbox.

image.thumb.png.8aa8df4397655683163270972334e7b4.png

BTFL_crash.BBL

Une info qui serait utile aux autres, modéle de la FC et ESC. Je n'ai trouvé que le moyen de répondre pour pouvoir suivre ce sujet, je ne fais que passer.

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Salut,
il semblerait qu'il y ait un problème avec le moteur 1.
À la fin des courbes, on voit que la FC demande 100% au moteur 1 mais le drone se retourne en "tombant" vers l'arrière droite, vers le moteur 1. Ce qui signifie que le moteur 1 ne tournait pas, ou pas assez vite.

Tu passes de moins de 20% à de gaz durant tout le vol à 100% en une fraction de seconde. Peux-tu y aller plus progressivement pour voir à quel moment le problème se déclenche ?

Tu peux faire quelques essais sous BetaFlight, dans l'onglet moteur sans les hélices. Tu fais tourner les moteurs assez vite pour déclencher le problème (mais pas longtemps pour ne pas les faire chauffer). Il faut s'assurer que ça vienne bien uniquement du moteur 1. Ensuite, tu inverses deux moteurs et tu recommences. Soit le problème va suivre le moteur, soit il va rester sur le même ESC. Tu sauras qui est le fautif.
Si le test sans hélice ne déclenche pas le problème, tu peux essayer en sanglant solidement le quad à un support et en faisant très attention. Ça permet de tester les moteurs dans des conditions plus réalistes, et ça permet de faire des tests plus longs sans les griller mais c'est dangereux, donc prudence extrême..

Ce qui m'étonne le plus, c'est que le fichier BlackBox s'arrête à l'instant exact du problème, en 1/10e de seconde ! On ne voit pas le désarmement ou le crash.

Modifié (le) par goony

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse très précise! En faite c'était un vol de test juste pour voir le problème rapidement dans la black box. Le petit problème c'est que si je j'y vais petit à petit le drone va monter rapidement et si il se crash les dégâts seront plus important. Demain je test tout ça mais normalement hier le moteur 1 tournait correctement à fond sans hélices. Je ne comprends pas non plus pourquoi l'enregistrement s'arrête quand il se retourne

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour goony en faisant les test j'ai vu que mon moteur 1 fonctionne parfaitement ainsi que tout les autres. Mais j'ai remarqué que mon minimum throttle en désarmé est de 900 or c'est très bas donc je remonte cette valeur sauf que quand je met 1000 ou moins le drone ne "fini" pas la musique de démarrage et donc impossible de les faire tourner. Je ne peux pas mettre du dshot car j'ai que 3 esc sur 4 (esc 2 qui ne marche pas dans ce cas) qui fonctionnent dans ce protocole.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour vérifier la configuration, peux-tu faire un copier coller du résultat de la commande diff dans CLI ?

Après avoir bien réglé, il faudra calibrer de nouveau les ESC.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je dois mettre à 900 pour pouvoir faire démarrer les moteurs... C'est pas un peu bas non? Et malgrès ça ils se mettent à tourner brièvement sas armement.

Voilà mon diff

# diff
# Betaflight / SPRACINGF3 (SRF3) 3.4.0 Jul 8 2018 / 04:32:14 (cce8a59be) MSP API: 1.39

board_name SPRACINGF3
manufacturer_id
resource MOTOR 1 B08
resource MOTOR 2 B09
resource MOTOR 4 A07
resource MOTOR 5 NONE
resource MOTOR 6 NONE

aux 0 0 0 1900 2075 0
aux 1 1 1 900 1300 0
aux 2 2 1 1300 1700 0
rxfail 4 s 975
set gyro_sync_denom = 3
set acc_calibration = 60,37,128
set mag_hardware = NONE
set baro_hardware = NONE
set min_throttle = 1030
set min_command = 940
set dshot_idle_value = 300
set motor_pwm_protocol = MULTISHOT
set failsafe_throttle_low_delay = 10
set align_board_yaw = 90
profile 0

rateprofile 0
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Remets le min_command à 1000, le min_throttle à 1070, puis re-calibre les ESC.

Dans l'onglet Récepteur, la valeur des voies varie bien de 1000 à 2000 quand tu bouges les sticks ?

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est bon c'est fait mes moteurs démarrent normalement mais toujours ce problème de moteurs qui tournent brièvement sans armement mais bon.La valeur bouge bien entre 1000 et 2000 donc ça va. J'ai remarqué que mon moteurs 4 à un roulement usé (il l'avait déjà depuis que je les ai reçu) ce sont des DYS Wei 2207 2600KV. Pourtant à fond il l'air de fonctionner normalement enfin sans hélices, j'ai déjà entendu un bruit de frottement assez fort juste avant que mon quad se crash mais c'était avant les problèmes de retournement.

Partager ce message


Lien à poster
Partager sur d’autres sites

À tout hasard, peux-tu te connecter à BLHeli Configurator et m'indiquer les valeurs des PPM Min et Max Throttle de chaque ESC, pour voir s'il n'y a pas de valeur incohérente.
NB : ne modifie pas les réglages BLHeli

Partager ce message


Lien à poster
Partager sur d’autres sites

Voilà, et hier j'avais remarqué dans blheli 32 après les avoir calibrés que les valeurs étaient un peu différentes donc je l'ai avaient accordés ensemble et là avec ses changements et la calibration tout est redevenu comme avant avec les valeurs différentesimage.thumb.png.1901ade803e351fd34ca74161c978e25.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Autre information, je ne sais pas si ça à un rapport mais impossible de les flasher, c'est marqué "fail to openSSL" ou quelques choses dans le genre

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, CarlosMagni a dit :

[...] j'avais remarqué dans blheli 32 après les avoir calibrés que les valeurs étaient un peu différentes donc je l'ai avaient accordés ensemble [...]

Il ne faut pas chercher à avoir les mêmes valeurs, c'était peut-être la cause de tes problèmes. La calibration sert justement à définir les valeurs pour chaque ESC afin qu'ils soient synchronisés. Là, les valeurs sont cohérentes (ni 1000, ni 2020)
Ce n'est pas nécessaire de flasher les ESC si tu n'as pas une bonne raison, notamment si tu ne maîtrises pas, tu risques de faire plus de dégâts qu'autre chose.

Du coup, maintenant que la configuration semble bonne, tu peux refaire un test avec BlackBox. Fais quelques coups de gaz moyens avant de faire du 100% 😉

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Goony je viens de tester mon quad avec tout les réglages que tu m'as dit mais même problème... A partir de 1600 de throttle le drone se retourne, je ne comprends plus je te donne ma blackbox quand même

test0_222746.BBL

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 14 heures, CarlosMagni a dit :

Salut Goony je viens de tester mon quad avec tout les réglages que tu m'as dit mais même problème... A partir de 1600 de throttle le drone se retourne, je ne comprends plus je te donne ma blackbox quand même

test0_222746.BBL

Je ne suis pas un pro de la blackbox mais tu as des valeurs trés alléatoire, dans le rssi. Ta RC fonctionne avec d'autres machines?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Ludo, je n'ai qu'une machine avec cette radio donc je ne peux pas tester avec d'autres quad, les deux antennes récepteurs sont bien placées. En même temps ma radio est mauvaise c'est une flysky i6 donc il y a vraiment mieux, et j'ai pas le rssi sur ma radio donc j'ai jamais constater cela

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, CarlosMagni a dit :

Salut Ludo, je n'ai qu'une machine avec cette radio donc je ne peux pas tester avec d'autres quad, les deux antennes récepteurs sont bien placées. En même temps ma radio est mauvaise c'est une flysky i6 donc il y a vraiment mieux, et j'ai pas le rssi sur ma radio donc j'ai jamais constater cela

Dans la blackbox, tu demandes à faire apparaître la valeur rssi et pour que ce soit clair, supprime le reste et tu verras des signaux carrés avec des valeurs positives et négatives qui se suivent au moment du désarmement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, j'arrive après la bataille.
Dans la seconde blackbox, on voit bien qu'il y a encore un problème sur le moteur 1.
Si le changement de protocole ESC corrige le problème, ça signifie probablement que l'ESC du moteur 1 a un problème avec le MULTISHOT.
As-tu essayé le DSHOT ?

Le principal, c'est que ça vole.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut ! C'est pas grave lol, oui j'ai voulu dès que j'ai reçu mes esc de les mettre en dshot, or dans ce protocole le moteur 2 n'est pas reconnu WTF, et sur amazon ils vendent ma sp racing f3 et c'est bien marqué, protocole supporté: ONESHOT

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×