Jump to content
DroneBuilds
naviluminor

betaflight Retour "Telemetry" un peu d'aide SVP

Recommended Posts

Comme tu t'en es rendu compte, je suis une crêpe ☹️ alors de là à dire que j'ai laissé un truc trainer il n'y a pas des Kilomètres..

Tout dégager et recommencer à zéro le paramétrage ? pourquoi pas..  (je n'ai pas testé le retour de telemetry brut de flashage BF, cad avant l'injection de mon "diff")

Share this post


Link to post
Share on other sites

Au pire fait un diff, flash avec eprom reset, paramètre ton rx dans bf, coche telemetry et test...

Envoyé de quelque part avec un truc qui sert à envoyer des messages.

Share this post


Link to post
Share on other sites

Moi je reprend tout après chaque flash.
Au début c'est un peu plus long mais au fur et à mesure ça va de plus en plus vite et ça me permet de mieux comprendre BF. En cas de doute, tu peux te référer à ton Diff.

Envoyé de mon BTV-DL09 en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Il y a 4 heures, toper a dit :

Ben ça dépend de quelle FC tu as.

Envoyé de quelque part avec un truc qui sert à envoyer des messages.
 

J'ai une Hobbywing F4 version 1

Share this post


Link to post
Share on other sites
Youtube WE are FPV
il y a une heure, toper a dit :

Au pire fait un diff, flash avec eprom reset, paramètre ton rx dans bf, coche telemetry et test...

Envoyé de quelque part avec un truc qui sert à envoyer des messages.
 

Même loup d'absence de retour "current" après le (1000e) flashage, et en plus, si je ne rentre pas ma première sauvegarde après ledit flash, cette saleté refuse de s'armer, un bip à la con à la place.. rate profile, beeper tout marche sauf le démarrage des moteurs, faut je (re) fasse un statusse 🤓 pour piger ce qui fait que ma sauvegarde résout l'embrouille 🤔   

Share this post


Link to post
Share on other sites

@Joelamoule si c'est cette carte mets-toi sur le pad du moteur 5 (S5) et je crois que dans le CLI c'est:

resource SERIAL_TX 6 NONE
resource SERIAL_TX 11 A01

Share this post


Link to post
Share on other sites

Voici le diff historique avec lequel fonctionne mon zozio :

 

 


# name

# resources
resource MOTOR 1 B00
resource MOTOR 2 B01
resource MOTOR 3 A03
resource MOTOR 4 A02

# mixer

# servo

# servo mix


# feature
feature -BLACKBOX
feature CURRENT_METER
feature AIRMODE

# beeper

# map
map TAER1234

# serial
serial 0 1 115200 57600 0 115200
serial 5 32 115200 57600 0 115200

# led

# color

# mode_color

# aux
aux 0 0 0 900 1300
aux 1 2 1 1700 2100
aux 2 13 2 1700 2100

# adjrange
adjrange 0 0 3 900 1300 12 3
adjrange 1 0 3 1300 1700 12 3
adjrange 2 0 3 1700 2100 12 3

# rxrange

# rxfail

# master
set motor_pwm_protocol = DSHOT600
set align_board_roll = -1
set align_board_yaw = 90
set acc_trim_pitch = -14
set acc_trim_roll = 38

# profile
profile 0

set gps_posr_d = 1
set gps_nav_d = 0
set d_level = 0
rateprofile 1

# rateprofile
rateprofile 0


# rateprofile
rateprofile 1

set roll_srate = 85
set pitch_srate = 85

# rateprofile
rateprofile 2

set roll_srate = 100
set pitch_srate = 100

# restore original rateprofile selection
rateprofile 1

# profile
profile 1

rateprofile 0

# rateprofile
rateprofile 0


# rateprofile
rateprofile 1


# rateprofile
rateprofile 2


# restore original rateprofile selection
rateprofile 0

# profile
profile 2

rateprofile 0

# rateprofile
rateprofile 0


# rateprofile
rateprofile 1


# rateprofile
rateprofile 2


# restore original rateprofile selection
rateprofile 0

# restore original profile selection
profile 0

Share this post


Link to post
Share on other sites

Le truc con pour lequel tu es sur à 200000000%, mais que quand tu vérifies, ben tu t'es planté: tu as bien mis le Sbus sur le Sbus et le Sport sur le Sport ???????????? et pas l'inverse comme je faisais à chaque fois ?

Share this post


Link to post
Share on other sites

Hi tous

Le VTX de cette saleté (innova V4) refuse via le smart port d'enregistrer mes choix de fréquence et de puissance, tout se passe normalement mais à la remise en route : zob !!  🤬

Il y-a-t-il une méthode pour changer tout ça avec Betaflight ? (via le CLI par exemple)

Si oui comment faire ?

Merci d'avance tous 😘

Edited by naviluminor

Share this post


Link to post
Share on other sites
il y a 22 minutes, naviluminor a dit :

Hi tous

Le VTX de cette saleté (innova V4) refuse via le smart port d'enregistrer mes choix de fréquence et de puissance, tout se passe normalement mais à la remise en route : zob !!  🤬

Il y-a-t-il une méthode pour changer tout ça avec Betaflight ? (via le CLI par exemple)

Si oui comment faire ?

Merci d'avance tous 😘

Salut Navi, j'ai la même chose avec mon VTX (VTX5848 Lite) et ma Omnibus F4 AIO, il a fallu que je la flashe avec la version SD (OmnibusF4SD au lieu de la OmnibusF4 tout court...), par contre, pas de souci de fuel ou quoi, j'ai bien mes alertes tous les 100mAh consommés en direct, tous mes capteurs dans l'onglet télémétrie, j'ai juste eu besoin de faire du softserial à un moment pour avoir la télémétrie mais rien de méchant.

Concernant mon vtx, il se remet sur 200mw (par défaut) sachant qu'il peut aller jusqu'à 800mW maximum à chaque branchement de lipo, perso, ça me dérange pas mais les flics risquent de moins apprécier 😕 

Voilà ma config betaflight pour les ports si ça t'intéresse, pour le softserial, j'ai suivi le tuto d'Oscar Liang à ce sujet et ça m'a permis d'avoir le smartport très facilement, tuto que tu peux retrouver ici https://oscarliang.com/betaflight-soft-serial/

Comme lui, j'ai juste eu à remapper le TX1 avant d'assigner à la place le softserial comme ceci :

resource SERIAL_TX 11 A09
save


1867093160_VraieconfigurationR-XSROmnibusF4AIO-SoftserialTBSSmartAudio.thumb.png.488f5ad5cd4c324ab2ec2e544543006c.png

Si cela peut t'aider, je te mets aussi mon diff all (à défaut de pouvoir te passer mon dump pour comparaison) 

# version
# Betaflight / OMNIBUSF4SD (OBSD) 4.0.0 Mar 23 2019 / 22:25:33 (ae5c924c9) MSP API: 1.41

# start the command batch
batch start

# reset configuration to default settings
defaults nosave

board_name OMNIBUSF4SD
manufacturer_id 
mcu_id 00330058574850022039354b
signature 

# name
name QL5

# resources
resource SERIAL_TX 1 NONE
resource SERIAL_TX 11 A09

# timer

# dma

# mixer

# servo

# servo mix


# feature
feature -RX_PARALLEL_PWM
feature -DYNAMIC_FILTER
feature RX_SERIAL
feature MOTOR_STOP
feature SOFTSERIAL
feature TELEMETRY

# beeper
beeper -ARMING_GPS_FIX
beeper -READY_BEEP
beeper -ON_USB
beeper -BLACKBOX_ERASE

# beacon
beacon RX_LOST
beacon RX_SET

# map

# serial
serial 2 2048 115200 57600 0 115200
serial 5 64 115200 57600 0 115200
serial 30 32 115200 57600 0 115200

# led

# color

# mode_color

# aux
aux 0 0 0 1925 2100 0 0
aux 1 1 1 900 1200 0 0
aux 2 13 2 1350 2100 0 0
aux 3 36 3 1800 2100 0 0

# adjrange

# rxrange

# vtx

# rxfail

# display_name

# master
set gyro_lowpass2_type = BIQUAD
set acc_calibration = -4,60,-282
set mag_hardware = NONE
set baro_hardware = NONE
set min_check = 1035
set fpv_mix_degrees = 35
set serialrx_provider = SBUS
set motor_pwm_protocol = DSHOT1200
set bat_capacity = 1300
set deadband = 2
set yaw_deadband = 3
set pid_process_denom = 1
set osd_cap_alarm = 750
set osd_vbat_pos = 2528
set osd_rssi_pos = 2144
set osd_tim_1_pos = 2551
set osd_tim_2_pos = 2519
set osd_flymode_pos = 2488
set osd_vtx_channel_pos = 2112
set osd_crosshairs_pos = 2285
set osd_ah_sbar_pos = 238
set osd_ah_pos = 110
set osd_current_pos = 2432
set osd_mah_drawn_pos = 2400
set osd_power_pos = 2464
set osd_warnings_pos = 2474
set osd_avg_cell_voltage_pos = 2496
set osd_battery_usage_pos = 2505
set osd_disarmed_pos = 2453
set osd_stick_overlay_left_pos = 327
set osd_stick_overlay_right_pos = 335

# profile
profile 0

set feedforward_transition = 40
set abs_control_gain = 0

# profile
profile 1


# profile
profile 2


# restore original profile selection
profile 0

# rateprofile
rateprofile 0

set roll_rc_rate = 110
set pitch_rc_rate = 110
set yaw_rc_rate = 110
set roll_expo = 20
set pitch_expo = 20
set yaw_expo = 20
set roll_srate = 77
set pitch_srate = 77
set yaw_srate = 78

# rateprofile
rateprofile 1


# rateprofile
rateprofile 2


# rateprofile
rateprofile 3


# rateprofile
rateprofile 4


# rateprofile
rateprofile 5


# restore original rateprofile selection
rateprofile 0

# save configuration
save
# 
Edited by psixkho
  • Merci ! 1

Share this post


Link to post
Share on other sites

Merci pour ta réponse, mais j'ai baissé les bras depuis longtemps avec la télémétrie.. mais uniformiser les fréquences de me zozios simplifie la vie

1) Lorsque je modifie fréquence et puissance avec le smart audio cela ne se sauvegarde pas

2) Lorsque je modifie fréquence et puissance dans le CLI (merci Yann 😘) idem : zob !!

Pourtant maintenant quand je fais "get vtx" mes modifs apparaissent bien dans le CLI 🤔 mais cette daube (à l'usage) est toujours sur la fréquence et la puissance par défaut !!

C'est quoi encore cette embrouille ??

# get vtx
osd_vtx_channel_pos = 234
Allowed range: 0 - 3071

vtx_band = 5
Allowed range: 0 - 5
Default value: 4

vtx_channel = 4
Allowed range: 1 - 8
Default value: 1

vtx_power = 3
Allowed range: 0 - 4
Default value: 1

vtx_low_power_disarm = OFF
Allowed values: OFF, ON

vtx_freq = 5769
Allowed range: 0 - 5999
Default value: 5740

vtx_pit_mode_freq = 0
Allowed range: 0 - 5999

vtx_halfduplex = ON
Allowed values: OFF, ON

Share this post


Link to post
Share on other sites

Moi ça m’intéresse vos histoires de soft serial...
Impossible d’avoir le vbat sur ma taranis en suivant seulement le protocole uart tx -> smart port (avec télémétrie on sur bf)

Mais va falloir essayer de comprendre maintenant.
Pour info et pour les experts qui passeraient par là...je suis avec un vortex230(f3) et un rxsr

Comme Navi je voudrais avoir la télémétrie sur la taranis et pas uniquement dans l’osd

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...