Aller au contenu
acheter dji air unit o3
DroneBuilds

R-XSR et betaflight


polluxei

Messages recommandés

Bonjour,

je relance sur un sujet dont les dernières traces remontent à janvier dernier, à la sortie du R-XSR!

j'ai un Wizard X220S, avec un FC Omnibus F4 V3, et un R-XSR que j'ai branché comme c'est recommandé, voir les photos en PJ,

dans Betaflight, j'ai configuré SBUS et RX série dans l'onglet config,  ainsi que les ports UAT1 ou UART 6 (j'ai essayé les 2) comme Serial RX, sans succès. (voir pj)

je suis passé par le flash du R-XSR pour être en EU-LBT, comme ma radio (Taranis X9D+), et ils sont maintenant bien bound ( lumière bleu et verte fixes).

et malgré tout cela, je n'arrive pas à voir du mouvement dans l'onglet récepteur de Betaflight.

après plusieurs heures à écumer le web, je ne trouve pas ce que j'ai raté. 

 

merci de vote aide!

Polluxei

IMG_20190219_201152.jpg

IMG_20190219_201248.jpg

IMG_20190219_201126.jpg

FC x220s.jpeg

Capture d’écran 2019-02-19 à 20.21.14.png

Capture d’écran 2019-02-19 à 20.21.08.png

frsky_r-xsr_receiver_sport_sbus_inverted_uninverted.jpg

Modifié (le) par polluxei
ajout Pinout R-XSR
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV
Il y a 2 heures, quazardous a dit :

 

parce que sur le RXSR y'a pas de bleu

Hello,

sur le R-XSR,il y a bien une LED bleu, qui sert à indiquer le choix SBUS/CPPM. 

SI la LED est allumé, le mode utilisé est SBUS.

https://www.frsky-rc.com/r-xsr/

Lien vers le commentaire
Partager sur d’autres sites

il y a 52 minutes, polluxei a dit :

Hello,

sur le R-XSR,il y a bien une LED bleu, qui sert à indiquer le choix SBUS/CPPM. 

SI la LED est allumé, le mode utilisé est SBUS.

https://www.frsky-rc.com/r-xsr/

J'ai pas cette version moi juste 2 LEDs rouge et vert et je suis bien en sbus...

Je vais vérifier j'ai un doute lol

Modifié (le) par quazardous
  • Haha 1
Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...

Bonjour, je suis dans le même cas que décrit ci-dessus. Même drone, même FC et même récepteur.

J'utilise une QX7 ACCESS avec firmware radio et émetteur interne a la dernière version. Le récepteur est bien bindé a la radio avec la LED verte fixe et barres de réception sur la radio.

Le R-XSR est flashé avec le dernier firmware du site de frsky en ACCESS.

Le FC est flashé comme dit plus haut avec OMNIBUSF4SD.

SBUS, 5V et GND connectés comme sur la photo en début de conversation.

J'ai vérifié les connexions et normalement c'est OK.

Je n'arrive pas a avoir un retour dans betaflight du mouvement des sticks et je n'ai plus trop d'idées.

Je joins le dump si besoin.

Si quelqu'un a la possibilité de m'aider ce serait super. Merci beaucoup.

20201211_205903.jpg

BTFL_cli_XV220S_20201211_205053.txt

Lien vers le commentaire
Partager sur d’autres sites

il y a 21 minutes, SARDAUKAR a dit :

la radio avec la LED verte fixe et barres de réception sur la radio.

Tu as la led bleue?

le dump sert à rien, mets plutôt ta page port et configuration de betaflight!

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

Il me semble avoir vu un test de ce drone avec inversion entre sbus et ibus (probleme avec la carte.....) mais ca remonte a loin... Il fallait mettre sbus dans beta pour avoir l'ibus, ou l'inverse.....

Bon ca aide peut etre pas.....

Lien vers le commentaire
Partager sur d’autres sites

@SARDAUKAR

Il faut une fois que tu as le r-xsr alimenté, appuyer 2/3 secondes sur le bouton bind, afin d’allumer la led bleue (sans led=PPM, avec led=SBUS) la led bleue doit être fixe...

si cela ne fonctionne pas après, vérifier le point suivant :

en plus dans ton dump (à vérifier depuis CLI de betaflight) tu as serialrx_halfduplex=ON, il me semble que cela doit être OFF ?(je ne suis pas certain, mais presque)

 « Pas encore vu de ibus quelque part.. » rien à voir avec ton problème!

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

il y a 12 minutes, SARDAUKAR a dit :

Alors j'ai essayé de rester appuyer pour avoir la led bleue, les leds rouges et vertes se sont mises à clignoter puis la verte est restée fixe mais pas de led bleue

J'ai ensuite passé le halfduplex à off 

Je peux mtn voir les mouvements des sticks dans betaflight donc merci beaucoup !

tu dois avoir la led bleue ?! Tu es en access ou en accst avec ta radio ?
https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/R-XSR/R-XSR ACCST -Manual.pdf

tu as recherché les capteurs sur ta radio (dernière page de ton modèle)

 

edit : j’ai relus ton premier message... alors oui en Access la configuration est peut-être différente !

https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/R-XSR/R-XSR-ACCESS -Manual.pdf

Modifié (le) par Attafr
Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, Attafr a dit :

tu dois avoir la led bleue ?! Tu es en access ou en accst avec ta radio ?
https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/R-XSR/R-XSR ACCST -Manual.pdf

 

edit : j’ai relus ton premier message... alors oui en Access la configuration est peut-être différente !

Oui en effet je suis en Access ce qui change peut être un peu, en tout merci beaucoup ça m'a débloqué !

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...