Jump to content
DroneBuilds
David ML

Connection TARANIS-Drone et BETAFLIGHT

Recommended Posts

Je pensais que j'avais finalement finis mes paramétrages avec la Taranis sur Betaflight, et lorsque je reviens à nouveau faire quelques petits réglages j'ai encore eu un problème. J'allume bien ma Taranis, elle se connecte bien au drone (lumiere verte sur le R XSR) mais quand j'essaie de voir les jauges du throttle yaw etc bouger de 1000 à 2000 rien ne se passe (J'ai bien mis mon serial RX ou il faut ainsi que le recepteur S BUS sur betaflight)

Pourriez vous me dire si vous avez eu le même cas et comment je peux l'arranger?

Share this post


Link to post
Share on other sites

Ca va être compliqué de t'aider sans infos.

Si tu a sélectionné S Bus, le RX est bien relié à un port S Bus sur la FC, (Quelle FC, port inversé ou non). Les canaux sont bien configurés sur la Radio ?

Share this post


Link to post
Share on other sites

Oui il est relier avec un port inversé, la fc est celle du combo xrotor micro (F4 G2). Sur la radio j'ai juste binder en D16 canaux CH1-16 

Share this post


Link to post
Share on other sites

Quelques éléments à vérifier ici

Pour la radio il y a pas mal de tuto sur comment affecter les canaux, après je suis en Flysky donc mes connaissances sont limitées.

Share this post


Link to post
Share on other sites
Il y a 2 heures, SupraDolph a dit :

Quelques éléments à vérifier ici

Pour la radio il y a pas mal de tuto sur comment affecter les canaux, après je suis en Flysky donc mes connaissances sont limitées.

Le truc c'est que le R XSR reconnait la Taranis, j'arrive a le binder correctement, je vois bien la lumière verte. J'avais réussit à controler le drone avant hier, et là j'ai voulu modifier certaines choses sur les boutons et le problème maintenant c'est que lorsque j'utilise un bouton ou les joysticks, je n'arrive pas à voir les AUX dans betaflight

Share this post


Link to post
Share on other sites
Youtube WE are FPV

La réponse est donc dans les "certaines choses" que tu as modifié.

Reprend les bases de la configuration de ta radio.

Share this post


Link to post
Share on other sites
Il y a 20 heures, David ML a dit :

Oui il est relier avec un port inversé, la fc est celle du combo xrotor micro (F4 G2). Sur la radio j'ai juste binder en D16 canaux CH1-16 

alala ça sert à rien c'est bidule de rssi et uninverted sport....

branche gnd, 5v et sbus out.

ensuite dans BF/cli tape

set rssi

y'aura une valeur rssi error check quelque chose à OFF. copie/colle en faisant

set <nom de la valeur> ON

save

t'aura un RSSI calculé par BF par rapport aux trames comprises vs en erreur

Share this post


Link to post
Share on other sites

Ah je viens de comprendre un truc sur vos histoires de F4 et port inversé. En fait vous n'avez qu'une entrée inversée sur la carte donc soit c'est la S Bus soit c'est la S Port. Donc effectivement OSEF ^^

Share this post


Link to post
Share on other sites

Ça marche toujours pas, j'ai même recréé un nouveau modèle et rien. 

Sinon je me suis dis, j'avais sauvegardé au tout début des infos sur le CLI, je pourrais pas tout remettre à 0 grâce à ça et tout refaire ? 

Share this post


Link to post
Share on other sites
il y a 14 minutes, SupraDolph a dit :

Ah je viens de comprendre un truc sur vos histoires de F4 et port inversé. En fait vous n'avez qu'une entrée inversée sur la carte donc soit c'est la S Bus soit c'est la S Port. Donc effectivement OSEF ^^

He non 😁

Sur le r-xsr le uninverted sert y récupérer le signal RSSI vers la FC.

Et le sbus c'est pour le signal.

Share this post


Link to post
Share on other sites
il y a 4 minutes, David ML a dit :

Ça marche toujours pas, j'ai même recréé un nouveau modèle et rien. 

Sinon je me suis dis, j'avais sauvegardé au tout début des infos sur le CLI, je pourrais pas tout remettre à 0 grâce à ça et tout refaire ? 

T'as tout dessoudé sauf le RX ? 

Pour remettre à zéro tu flash en cochant raz. Puis tu copie colle les commande cli dans cli. Save et reboot.

Mais j'y crois pas. C'est assez simple le sbus.

Tout passe par un câble sur un RX de la FC qu'il faut noter comme étant serial dans la conf.

Tu dois avoir que 3 câbles branchés entre le RX et la FC. Gnd,5v et sbus_out.

Share this post


Link to post
Share on other sites

C'est ce que j'ai compris mais votre SBus doit être inversé d'où le port spécifique sBus sur le FC.

Share this post


Link to post
Share on other sites
il y a 1 minute, SupraDolph a dit :

C'est ce que j'ai compris mais votre SBus doit être inversé d'où le port spécifique sBus sur le FC.

Bien possible

Share this post


Link to post
Share on other sites
il y a 2 minutes, quazardous a dit :

T'as tout dessoudé sauf le RX ? 

Je parle des leds

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...