Jump to content
DroneBuilds
Hesiodes

Drone qui part en Deadroll...

Recommended Posts

Bonjour,

 

Suite à un crash dimanche mon drone part en Deadroll lorsque je fais un flip sur le Roll...

J'ai extrait des logs de la blackbox et visiblement le pb viendrait du motor 2... C'est assez étrange car avec du Roll léger aucun soucis... J'ai vérifié les esc sur bhelli pas de pb apparent, je suis revenu sur des PID stock... Le pb reste inchangé...

Le pire c'est que si j'ai suffisamment de hauteur, le drone arrive à se stabiliser...

J'ai un doute sur l'ESC du moteur concerné... Avant de tout démonter, un conseil? Une idée de test?

 

Ci-joint une vidéo du pb:

 

Merci d'avance pour vos conseils

 

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

 

 

Share this post


Link to post
Share on other sites

J'y ai pensé (à reflasher la carte) mais ça fait 2 mois que je vole avec cette config...

Non je n'ai pas été jeter un coup d'œil dans le CLI... Status te renvoies quel type d'info?

 

Merci pour ton aide :)

 

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

il vas te dir si ya pa exemple le gyro qui est desactiver ou des infos dans le genre, apres peut etre que tu peut rester sur ce setup. verifie qu'apres ton crash tes entretoises entre la fc et le chassis n'ont pas exploser, verifie que ton processeur ne soit pas trop charger (si cc'est le cas essaye de diminuer la frequence de rafraichissement ou le boucle PID. et le dernier  truc que je vois ca serais que tes esc ou ton esc dans ce cas la n'acceptent pas le protocole que tu leur impose via BF. ca peut venir de pleins de trucs, peut etre que si tu met a jour ta FC sur un BF plus recent ca corrigeras le probleme. d'ailleur c'est quoi ta FC?

Share this post


Link to post
Share on other sites

La FC c'est une Rotoriot hypertrain... Les entretoises sont nickel... Ce n'était pas un gros crash... Je vais vérifier la charge CPU... Merci je tiendrai à jour ce fil.

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Youtube WE are FPV
Je pense a ESC qui serait entrain de lâcher. J'essayerai d'inverser 2 moteurs pour écarter un problème moteur.
Ca peut vraiment venir d'un problème moteur? Parce que pour moi si ça tourne c'est qu'il y as pas de problème


Envoyé de mon SM-G955F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

J'ai inspecté le moteur, il a l'air nickel... Je l'ai vérifié au multimètre pas de pb apparent... Je penche aussi à l'ESC... Il y a pas un moins de le mettre en évidence avec la blackbox?5b8406537de64f73005ec8dc8774c94f.jpg

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites
J'ai inspecté le moteur, il a l'air nickel... Je l'ai vérifié au multimètre pas de pb apparent... Je penche aussi à l'ESC... Il y a pas un moins de le mettre en évidence avec la blackbox?5b8406537de64f73005ec8dc8774c94f.jpg&key=fcdfd813dc4ea63436dae02ac892b85243e917d8a965ca45c4cc7971f6587f58

Envoyé de mon Redmi Note 5 en utilisant Tapatalk


Teste tes moteurs dans bf à vide.
Tu regarde si les valeurs décalent toute seul.


Envoyé de mon SM-G955F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

C’est quoi tes moteurs ?
J’ai eu un problème de ce genre. Mon quad partait en deadroll quand je poussais un peu ( gros throttle, gros virage) mais c’était pas systématique. J’ai soupçonné l’esc 4-1 hobbywing, la fc (revolt) le rx ... jusqu’au jour j’ai décidé de remplacer tous les moteurs et plus rien.
J’avais des moteurs dys samguk 2207 2300 et je les ai remplacé par des t motor f40 pro II.
Depuis, je n’ai pas essayé de refaire voler les samguk mais je suis persuadé que mes deadroll étaient de leur faute...

Share this post


Link to post
Share on other sites

T-motor F40III
Je vais croiser 2 esc pour voir si le problème suit le esc.

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Bon j'ai testé de nouveau le drone en ayant croisé les esc... Le problème reste bien sûr le même moteur...
J'avais pourtant bien inspecté le bobinage (test de continuité électrique) et il n'y avait pas d'odeur de cramé...
Je vais essayer de mesurer l'impédance de chaque phase moteur...
Le deadroll serait peut-être dû à un pb d'efficience au niveau du moteur...
J'ai baissé les rates et la j'arrive à passer des Roll flip en y allant tout doux...

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Bon j'ai fait la mesure 0.18/0.18/0.25
Presque 40% d'écart ça fait bcp selon vous ?


Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Comment fais tu pour mesurer l’impédance sur les phases d’un moteur ?

Share this post


Link to post
Share on other sites

As tu mesurer un autre moteur qui ne pose pas problème ?

Share this post


Link to post
Share on other sites

Bah le pb de l'impédance c'est qu'il faut alimenter le moteur... La j'ai juste mesurer la résistance interne du moteur... Avec un multimètre professionnel.

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Oui, j'ai mesuré les autres moteurs et l'écart est bien plus faible entre 0.01 et 0.02 d'écart... Soit un max de 10% d'écart entre les phases...

J'ai même mesuré des moteurs DYS samguk, moteur moins qualitatif que les t-motor et l'écart au max est du même ordre environ 10%...

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Je pense que tu as trouvé le problème. Je serais quand curieux de voir comment ça se mesure en vidéo, je vais chercher ça

Share this post


Link to post
Share on other sites

C'est vraiment pas compliqué tu prends a chaque fois 2 fils de ton moteur et tu mesure avec le multimètre... Par contre si tu veux une mesure précise il faut un bon appareil... Ce sont des valeurs faibles.

 

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Et tu mesure la résistance en le faisant fonctionner ?
Tu te mets dans betaflight > motor et tu le fait tourner au ralenti ?

Share this post


Link to post
Share on other sites

Ok désolé j’avais pas suivi. Moteur en marche c’était l’impédance.
Bon, je vais mesurer la résistance entre les phases comme toi pour vérifier les moteurs dont je n’ai pas confiance.
Merci à toi.

Share this post


Link to post
Share on other sites

Pour aller au bout de mon investigation, il faudrait que je remplace le moteur défectueux par un autre moteur, genre un des dys samguk que j'ai d'avance...
Je pense que ça me permettrait de vérifier que le pb... Le drone ne serait pas super équilibré mais ça suffirait à éliminer le pb ...

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Tu me diras si toi aussi tu observes une différence.

Envoyé de mon Redmi Note 5 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...