Aller au contenu
DroneBuilds

Problème décollage drone


Hirotrex
 Share

Messages recommandés

Bonjour a tous,

j'ai un gros problème au décollage avec mon drone, dès que je met un peu les gas pour qu'il décolle, les moteurs se mettent à fond et s’arrentent aussitôt et donc il monte de 10 cm et retombe et après ça il se désarme tout seul.

setup: spracing f3

4 esc lightning 30a

4x emax 2300kv

émetteur + récepteur fs i6

ça fait environ 5 j que je cherche le problème donc voici les choses que j'ai essayé sans succès:

-reflasher mon FC avec cleanflight

-flasher mes escs en multishot

-calibrer mes escs

-désactiver l’accéléromètre

-ect...

j'ai effectué plusieurs tests:

d'abord sans les hélices, les 4 moteurs tournent à la même vitesse;

ensuite dans un étau avec les hélices, les 4 moteurs montent en régime à 100%;

enfin sur le sol, le drone met les moteurs à fond des que je monte un tut petit peu le stick de gas et se coupe aussitôt.

j'ai ici le graphe des moteurs pris dans la blackbox du drone sur le sol en condition de décollage normales:Capture.PNG.06a948363c2759fb38d1baa36e370f5c.PNG

je monte les gas et a un moment il y a 2 moteurs qui vont a fond puis il se désarme tout seul.

je précise que ce test à été effectué avec l’accéléromètre désactivé donc sans correction d'attitude.

dans l'étau avec les hélices montées, j'arrivait à monter le stick des gas à fond sans qu'il se désarme donc je ne pense pas que se soit un problème de surcharge et non plus un problème de moteur ou d'esc car j'ai réussi à faire monter les 4 moteurs à 100% avec hélices.

les courbes montrent que ce sont les moteurs 2 et 3 qui ralentissent ce qui corresponds à un mouvement de "yaw" mais avant qu'on me le demande, j'ai bien réglé ma télécommande et tout mes channels sont bien à 0 donc pas de problème de ce coté la.

désolé si je n'ai pas été très clair et merci d'avance pour tout aide même minime.

Lien vers le commentaire
Partager sur d’autres sites

Déjà bravo pour ta méthode !

Est-ce que les moteurs sont bien identifié 1 2 3 4 (fallait que je demande).

Ensuite est-ce que ton gyro répond bien ? Rapidement ? Dans betaflight configurator.

 

C'est quoi ta conf boucle ? 2K / 4K ?

 

Est-ce que t'as pensé à inverser les moteurs qui posent pb avec ceux qui semblent ok ?

Lien vers le commentaire
Partager sur d’autres sites

Merci beaucoup pour la réponse et le compliment 😀

J'ai oublié de dire que les moteurs sont bien branchés dans le bon ordre en configuration drone x classique.

De plus, au décollage, sans le faire décoller, je peux controller les 4 moteurs individuellement avec le stick droit de la télécommande e ce sont les bons moteurs qui répondent donc les branchements sont bon.

Je suis passé sur cleanflight en espérant que ça résolve le problème mais sinon le gyro répond bien et rapidement, la boucle est à 4 kHz et la charge cpu est à 20% donc le problème ne semble pas être ici et j'ai aussi changé le FC avec un autre donc il semble peu probable que le problème soit matériel genre gyro qui ne marche pas.

Ensuite je ne pense vraiment pas que le problème viennent des moteurs ou esc car j'ai réussis à pousser tout les moteurs à 100% dans l'étau avec les hélices montées comme on le voit ici donc pas utile de les inverser.

C'est mon premier drone et il à déjà volé c'est seulement après avoir changé le châssis (imprimé en 3D) et reflasher le FC que le problème est apparu donc pour moi le problème viens du FC.

1267797130_Canpture.thumb.PNG.6e33deaf5734e945de8d668588bb6e27.PNG

Apres plus de test et avoir approfondis l'analyse de la blackbox lors d'un décollage normal(sans accéléromètre), je trouve ça:

Cvnbcapture.thumb.PNG.d321c5931cce00657132aad836b10176.PNG

Au milieu on voit les moteurs donc avec le moteur 2 et 3 qui s'arretent et le 1 et 4 qui continuent à monter en régime, on voit que c'est typique d'un mouvement "yaw".

Cependant la télécommande ne donne pas de signal yaw (enfin un 2 mais c'est pas assez pour ca et c'est difficile de rester à 0 quand je met les gas(sur le même stick)).

On voit aussi que je suis que à 1283 de throttle(gas) et c'est à peu près la que le drone est sensé commencer à décoller et on voit.

Et ce que je viens de remarquer, c'est que c'est le pid(yaw) qui lui donne cette commande yaw comme on le voit sur la courbe du bas et en particulier le P. 

Le coupable serait donc le pid et après quelques recherches j'ai trouvé que un truc comme ça s'appelait un "yaw spin to the moon" sauf que sur les cas que j'ai vu c'était lors de figures et non pas au décollage.

Je précise encore que ça me la fait avec 2 FC différents et que ça serait très peu probable que ce soit un problème matériel.

Donc voila ce qui me semble être le problème maintenant je ne sais pas du tout ce qui peux causer ça donc je prie pour que quelqu'un ait une idée de ce que ça pourrait être. 😁

Modifié (le) par Hirotrex
Lien vers le commentaire
Partager sur d’autres sites

J'ai donc réglé le P du yaw à 0 et le problème est atténué, j'arrive maintenant, au lieu de faire un petit saut et retomber, à faire un survol tout en faisant faire des tours sur lui même au drone mais il devient vite incontrôlable.

Ça n'est donc pas une solution mais je suis maintenant sur que le problème viens de là.

Merci d'avance pour toute aide 😀

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Nan aucun problème de ce coté là c'est mon 2ème et je l'ai justement épaissis pour augmenter sa rigidité, il ne plis pas du tout. Et le premier volait très bien.

Merci pour la question.

Edit: Je pense que c'est un probleme d'alignement de gyro mais il apparait correctement dans betaflight.

Edit: enfait non l'alignement est bon

Modifié (le) par Hirotrex
Lien vers le commentaire
Partager sur d’autres sites

J'ai eu un problème un peu identique, cela était du à du jeu dans mes prises xt60, les vibrations occasionnaient des coupures et le multi se crachait moteurs coupés.

depuis que j'ai éliminé ce jeux, cela fonctionne correctement.

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...

Je reviens après un certain temps désolé.

Donc J'ai réussi, après avoir inversé des moteurs et plein d'autres trucs, à déduire que le problème vient des esc.

En effet en mettant tout les pid à 0 le drone tourne vers la gauche et en échangeant les moteurs il tourne toujours à gauche donc le problème vient des escs.

Le moteur 2(avant droit) tournerait donc plus vite que les 3 autres ce qui ferait tourner le drone vers la gauche. J'ai remplacé cet esc car celui d'avant était mort avec exactement le même et le problème est apparu juste après.

Donc j'ai reflashé,calibré tout mes escs avec blheli et bien vérifié que tout les paramètres soient les mêmes et malgré ça j'ai toujours le problème.

J'ai même joué avec le "motor gain" pour ralentir celui qui tournerait trop vite, ca l'empeche de tourner mais ca le fais pencher en avant donc bon...

Donc si quelqu’un pourrais m'expliquer comment régler ce problème ça serait super 😁

Merci d'avance!

Modifié (le) par Hirotrex
Lien vers le commentaire
Partager sur d’autres sites

Ta FC est-elle flashée avec le dernier firmware ?

Si oui essaie de la flasher avec un firmware antérieur, de l'année 2018

dernièrement j'ai eu un problème ou les moteurs montaient en accélération et je ne pouvais plus couper les gaz qu'en désarmant. Cela venait du firmware (récent) qui faisait buguer la FC

ma carte est une spracing f3 , j'ai du réinstaller un firmware de novembre 2018 et tout est rentré dans l'ordre.

Lien vers le commentaire
Partager sur d’autres sites

  • 1 year later...

Bonjour,

Desolé pour le deterrage de post, mais j ai un ami qui rencontre exactement le meme probleme.
As tu reussi a solutionner ce probleme @Hirotrex ?
Si oui, comment ?
Si d autres gens ont des pistes je suis interessé bien sur.

Merci beaucoup

Lien vers le commentaire
Partager sur d’autres sites

il y a 40 minutes, SanO a dit :

Bonjour,

Desolé pour le deterrage de post, mais j ai un ami qui rencontre exactement le meme probleme.
As tu reussi a solutionner ce probleme @Hirotrex ?
Si oui, comment ?
Si d autres gens ont des pistes je suis interessé bien sur.

Merci beaucoup

Merci beaucoup à toi aussi de passer nous faire coucou 😉

https://forum.wearefpv.fr/15-présentation/

Lien vers le commentaire
Partager sur d’autres sites

Salut @SanO,

J'ai pas posté la résolution du problème désolé j'ai oublié --'

Du coup bah en fait c'était tout con, c'était juste la case inverser le sense de rotation qui était pas coché dans betaflight. (juste en dessous du dessin avec les moteurs numérotés)

En gros les esc faisaient tourner les moteurs dans le sens inversé donc vers l'extérieur et le FC croyais qu'ils tournaient vers l'intérieur et du coup bah quand tu décolles le FC comprends pas pourquoi les corrections se font pas etc.

Meme si tu te dit "ouai j'ai déjà vérifié ca" va revérifier parce que je suis resté bloqué 2 mois sur ce truc con parce que je croyait que c'était bon. xD

Et aussi vérifie que tes hélices sont toujours dans le bon sens par rapport au sens de rotation des moteurs.

J'espere que ca aidera ton ami 😀

Lien vers le commentaire
Partager sur d’autres sites

  • 1 month later...

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...