Aller au contenu
DroneBuilds

Micro Swift 3 V2 et réglages via BetaFlight


naviluminor
 Share

Messages recommandés

Hi

La V2 se pilote de deux façons, soit via le joystick, soit via un UART (3)

Alors voila, je ne parviens jamais à la commander avec ma radio ☹️

Déjà avec mon multi à la con en titane j'avais séché.. c'était pourtant une autre FC et une autre camera !

J'ai vérifié moult fois les connections (TX cam vers RX3 et RX cam vers TX3) et aussi coché "runcam device" dans BF en face de l'UART 3

Lors de sa mise en route, la camera affiche pendant un court instant le mode de contrôle, et là elle est bien "sous UART"

  Mais ZOB ça veut pô 😬 GRrrrrrrrrrrrrrrrrrrr

Il y-a-t-il quelque chose à faire dans la radio ou dans BF que j'aurais zappé ? 

 

Ps : ma FC est une hobbywing XRotor, mon RX un nano CRSF

Lien vers le commentaire
Partager sur d’autres sites

Hello,

Tu n'aurai pas fait des modifs sur ta radio au niveau des sticks ?

Si les butées ne vont pas au bout il est possible que la caméra ne reçoive pas l'info.

Tu arrives à la contrôler via le joystick ?

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, JijO a dit :

Tu n'aurai pas fait des modifs sur ta radio au niveau des sticks ?

Heuu ben nan, enfin pas que je sache 🤔 (ceci étant je ne sais pas grand chose ☹️)

Où est situé la page qui conditionne les butées ?

Il y a 1 heure, JijO a dit :

Tu arrives à la contrôler via le joystick ?

Ce sera le test du soir si je ne parviens pas à me débrouiller avec l'UART, mais cela me surprendrai que ce soit la camera, comme écrit plus haut, c'est pas la première fois que je sèche comme une buse sur ce problème 🤬

Lien vers le commentaire
Partager sur d’autres sites

Fait au plus simple, vérifie les valeurs des butées sur betaflight,

Je viens de trouver une vidéo intéressante pour toi,  le mec accède à l'OSD mais c'est bizarre, il doit pousser le pitch vers le haut pendant X secondes pour activer l'interface :

C'est entre 2:50 et 4:00

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

  • Motard Geek changed the title to Micro Swift 3 V2 et réglages via BetaFlight
Youtube WE are FPV
Il y a 3 heures, JijO a dit :

Si les butées ne vont pas au bout il est possible que la caméra ne reçoive pas l'info

J'ai réfléchie à ta phrase, et à la réflexion, ma taranis commande parfaitement le Smart Audio qui lui fonctionne sur le même principe (manches en buté)

Je vais suivre ton lien youtube et je reviens donner des news..  

Lien vers le commentaire
Partager sur d’autres sites

J'ai réfléchie à ta phrase, et à la réflexion, ma taranis commande parfaitement le Smart Audio qui lui fonctionne sur le même principe (manches en buté)
Je vais suivre ton lien youtube et je reviens donner des news..  


Effectivement dans ce cas les butées ne posent pas de problème


Envoyé de mon iPhone en utilisant Tapatalk
Lien vers le commentaire
Partager sur d’autres sites

@naviluminor t'a camera est en mode joystick control. c'est pour ça que ça ne fonctionne pas via un uart. Pour changer de mode contrôle il faut short le tx et rx au démarrage. le mode de contrôle est indiqué vite fait par la camera pendant le démarrage.

https://www.runcam.com/download/MicroSwift3-Manual-V2.pdf

Lien vers le commentaire
Partager sur d’autres sites

Nan nan malheureusement c'est pas ça, ça je l'ai pigé dés le début, de plus la cam te "prévient" lors de la mise sous tension (pendant un brève instant) du mode dans lequel elle est

Le système du shunt lui fonctionne parfaitement (heureusement) 

Non c'est autre chose, mais quoi ?

Lors de l'achat de cette camera j'avais repéré ce système de switch, sans lui je ne l'aurais pas choisie  

Lien vers le commentaire
Partager sur d’autres sites

J’essaie bien de voir sur la photo si y aurait pas une coquille au niveau de la FC mais je n’y vois pas grand chose vu qu’il y a deux paires jaune / blanc ...

 

Parce qu’à part ça, si en plus l’UART 3 est bien déclaré sous BF... ben je sèche aussi

 

Envoyé de mon iTruc en utilisant Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

Il y a 2 heures, Grimm95 a dit :

Ton uart3 n'a pas un inverseur dessus pour le sbus/smartport qui pourrait perturber le truc?

Ben 🤔, ta remarque dépasse (d'une vache) mes compétences 😬

Lien vers le commentaire
Partager sur d’autres sites

  • 4 weeks later...

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...