Aller au contenu
DroneBuilds

Pb Mode et OSD dans BetaFlight avec un BetaFPV 65 Pro 2


Xev
 Share

Messages recommandés

Bonjour,

Je débute avec un BetaFPV 65 Pro 2.

Cela fait deux jours que je l'ai et je n'arrive plus à accéder à la partie OSD et Modes de BetaFlight.

J'ai essayé sur deux pc et en utilisant des versions différentes de BetaFlight Configurator et le problème est toujours le même alors que ça fonctionnait hier.

Sinon l'OSD fonctionne et le quad aussi. C'est juste ces deux menus dans BetaFlight Configurator qui ne sont plus accessibles.

Que puis-je faire ?

Merci pour votre aide.

 

OSD

image.thumb.png.1df6079c11717857bb427b33ba6d0d62.png

Modes :

image.thumb.png.84b0db3f846e65b9bb2272b2b9b6511d.png

Modifié (le) par Xev
Lien vers le commentaire
Partager sur d’autres sites

Pour l'onglet OSD, ça m'arrive aussi quelques fois mais en changeant d'onglet et en y retournant, ca s'affiche. Pour l'onglet mode, il y a un truc à cocher du style masquer les modes non utilisés ou quelques choses du style pour tout voir. 

J'ai aussi installé une appli sur mon Phone (speedybee) qui me permet de régler le quad sur le terrain avec un dongle, très pratique quand on soupçonne un bug de configurator.

Lien vers le commentaire
Partager sur d’autres sites

Merci pour vos réponses.

Ce soir le drone ne vol plus et je n'ai plus non plus l'affichage OSD dans les lunettes.

Je viens d'essayer de flasher la carte en choisissant OMNIBUSF4SD puis 4.0.5 - OMNIBUS4SD - 01-08-20109 15:11

Ça fait 10mn que l'opération est en cours.

En général, il faut combien de temps ?

Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV

Oui il faut maintenir enfoncé le bouton boot et le brancher

La led bleue reste fixe pour indiquer qu'il est dans le mode DFU boot mais si je commence le flash, ça m'indique : STM32 communication échouée, réponse incorrecte, attendu :121(0x79) reçu : (0x0)

Modifié (le) par Xev
Lien vers le commentaire
Partager sur d’autres sites

Je suis d'accord, là c'est critique

Est-ce que ça peut pas venir d'un mauvais choix de firmware ?

J'ai essayé MatekF411rx mais aussi OmnibusF4SD

Modifié (le) par Xev
Lien vers le commentaire
Partager sur d’autres sites

  • 3 months later...

je me permet de revenir sur le sujet car j'ai exactement le même problème avec un Trashcan tout neuf et à la première configuration l'onglet OSD et MODE sont vides et plantent BF 4.0 quand je clique dessus. J'ai le configurateur 10.5.1 et le BF installé est le 4.0.0. J'ai essayé de diminuer la vitesse de la boucle PID à 2.67 kHz et le CPU tourne à 19%.

Autre particularité dans l'onglet Alimentation les différentes tensions sont à 0 et lorsque je les modifie et que je sauvegarde elles repassent à 0.

As tu pu résoudre ton problème?

Lien vers le commentaire
Partager sur d’autres sites

J'ai finalement résolu mon problème en faisant un diff all puis en ré-installant betaflight et en recopiant mon Diff all dans le nouveau betaflight installé. J'ai donc pu enfin réaliser mon premier vol qui a duré 30 secondes jusqu'à ce que je casse une hélice.

Il semblerait que ce ne sera pas la dernière.

20191219_123630.jpg

Lien vers le commentaire
Partager sur d’autres sites

Peut-être une faiblesse dans le plastique car c'est au moment où le quad à toucher le sol que l'hélice a cassé.

Vu la protection qui entoure les hélices sur un whoop, je ne pensais pas avoir besoin de beaucoup d'hélice d'avance mais je pense qu'il va falloir que j'en commande.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour à tous,j'ai eu le même problème pour paramétrer mon eachine us65,je n'avais aucun mode et si je cliquais sur l'onglet mode betaflight plantais,mais aussi une alerte de la radio qui se deconnectais de la télémétrie sans arrêt,et ce matin on l'a paramétrer sur un autre ordinateur qui avait une ancienne version de bêta car pas mise à jour et là tout fonctionne nickel'il me manque juste des infos non affichée sur mes lunettes mais cocher dans l'osd 

Lien vers le commentaire
Partager sur d’autres sites

  • 2 months later...

Bonsoir à tous ! Plutôt que de créer un nouveau thread, je me permets de remonter celui ci car vous avez, à priori , rencontré les mêmes problèmes que moi...

Je viens de recevoir mon Eachine Trashcan. Je l'ai bindé sur ma Taranis X9D et je l'ai connecté à Betaflight.

Jusque la tout va bien, je réussi à régler les commandes sur la page récepteurs, tout est ok.

Ensuite dès que j'ai voulu passé à la page "mode", je n'y arrivais pas... je ne réussis pas à me connecter aux modes (pour armer les moteurs), ni à l'OSD.

En cherchant un peu j'ai remarqué que mon Betaflight configurator est en 10.6.0 alors que le Trashcan est en 4.0.0 (CRAZYBEEF4FR) ! Arffff la loose ! 

Et puis je suis tombé sur ce thread en fouillant un peu...

J'ai essayé de chopper une version 4.0 de Betaflight pour l'installer sur l'ordi de ma compagne (pour ne pas remplacer ma version 10.6.0 qui me permet de me connecter à mon autre drone et foutre le bordel sur mon portable) mais je n'en ai pas trouvé de version 4.0 de Betaflight.

Savez vous ou l'on peut trouver la version 4.0 de Betaflight?

J'ai vu sinon que l'on pouvait flasher la carte du drone pour installer une nouvelle version (soit CRAZYBEEF4FR en 4.1.1 legacy ou CRAZYBEEF4FR en 4.1.4 hamo).

Est ce que je dois flasher la carte du Trashcan ?

D'ailleurs quelle est la différence entre legacy et Hamo ?

Du coup à l'aide les gars je ne sais pas quoi faire lol

Maiday Maiday

Modifié (le) par Aiolos
Lien vers le commentaire
Partager sur d’autres sites

Coucou. 

Le version du configurateur n'a pas d’incidence sur la version de firmware que tu peu installer. 226372052_Annotation2020-02-24031336.thumb.png.eeffac8f535a188a76251d56e2896630.png

Tu as deux sorte de firmware, le propriétaire ( celui de la marque ) et le legacy ( le Générique ).

Je ne serai te dire si tu a intérêt à le flasher ou pas, mais en tout cas si tu compte le faire, pense à bien sauvegarder tes CLI et Diff. (tuto youtube)

Lien vers le commentaire
Partager sur d’autres sites

Salut Hennep et merci pour ta réponse !

Ben oui je suis bien embêté, je ne sais pas quoi faire non plus !  Si je flashe oui je pensais sauvegarder avant comme tu me le conseilles aussi, j'y ai pensé hier soir !

Et au niveau des versions de Betaflight personne n'a moyen de m'envoyer une version 4.0.0 ?  (je ne réussi pas à trouver un lien de téléchargement de la version 4.0).

Je ne pensais pas que j'aurai pu être bloqué par cela, juste pour une version de logiciel ! Étonnant que personne n'en parle.

Sinon quelles sont les autres solutions ? vous avez déjà rencontré ces problèmes ?

Aidez moi, au secours lol

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Depuis mon dernier post, je suis passé du configurateur 10.5 au 10.6

Comme te le dit Hennep42, tu peux être en configurator 10.6 et flasher un betaflight 4.0.0.

Sur la copie d'écran ci-dessous, mon configurateur 10.6 me donne la possibilité de mettre betaflight 3.5.5 jusqu'à 4.1.1.

Si tu as besoin de betaflight 4.0.0, tu flash le microprogramme de ton trashcan dans cette version.

Après avoir re-flashé le firmware du quad (j'étais en 4.0.0 et j'y suis resté), mon trashcan a fonctionné normalement et j'avais les modes et l'osd.

Le flashage, qui peut sembler difficile, et en fait une opération assez simple pour peu que tu suives les différentes vidéos sur internet. J'avoue que quand le quad a redémarré sans problème, j'étais soulagé.

Bon courage.

IMG_20200224_123659.jpg

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...