Aller au contenu
DroneBuilds

Moteurs qui s'emballent (résolu)


Bwucce
 Share

Messages recommandés

Salut les gars !

Le montage de mon Tyro99 est terminé et j'ai installé le strict minimum du package ( je n'ai pas branché le vtx et la cam ) sachant que c'est un drone d apprentissage je compte bien rester a vu de mon appareil et ne compte donc pas utiliser la vidéo pour le moment.

Bref mon problème ne se situe pas là...

Situation :  Je suis sous phase de réglage betaflight et découverte du programme.

Je tourne avec toutes options de base, je n'ai pas touché à tous les curseurs/valeurs sans réfléchir.

Drone à plat, hélices enlevées. Calibration effectuée x3

Protocol ESC Dshot600

Angle mode ON et Air mode ON

La FC (matek F405) est flashée et à jour. Les moteurs sont tous dans l'ordre et tourne dans le bon sens sans présenter de problèmes ou bruit particuliers.

Problème : Quand je teste l'ordre des moteurs ou leur sens en utilisant le "master" ou l'activation 1 par 1 dans l'onglet "moteur" aucun soucis. Ils se stabilisent tous à la consigne donnée.

Par contre quand je branche ma radio (x9 lite) en bougeant le pitch et le roll les moteurs réagissent nikel. Ils prennent de la courbe et reviennent en position mais alors quand j'augmente le Throttle ça grimpe normalement et 2 sec après j'ai le moteur 1 et 4 qui prennent des tours sans aucune consigne de ma part et ne redescendent que lorsque je mets le stick a 1000 ( gaz a zero quoi )

Option 1 : La commande des moteurs avec sa radio à plat, sans hélice sous BF fait péter un boulard a l'accélerometre qui n'arrive pas à compenser donc accélere encore et encore pour essayer de rétablir l'assiette.

Option 2 : Je donne ma langue au chat !

A votre bon coeur pour un petit coup de main ou avis sur mon problème.

Capture d’écran (3).png

 

 

 

Modifié (le) par Bwucce
Lien vers le commentaire
Partager sur d’autres sites

Édit : Je crois avoir trouvé la solution avec cette vidéo car c est exactement mon problème !

Comportement normal apparemment quand il n y a pas d hélices.

Topic clos

Modifié (le) par Bwucce
Lien vers le commentaire
Partager sur d’autres sites

Salut,

C'est l'airmode qui créé ce "problème", c'est récurrent chez tout le monde lors de la phase de test des moteurs quand on vérifie qu'ils tournent nickel. Le fait qu'il n'y a pas d'hélices sur le drone au moment des tests fait que celui-ci cherche à compenser par tous les moyens possibles et fait en sorte que les moteurs s'emballent et commencent à accélérer de plus en plus jusqu'à tourner à fond. En vol, tu n'auras pas de problème, au contraire, tu pourras garder le contrôle sur ton quad même avec les gaz à zéro.

Désactive l'airmode lors de tes phases de test si tu ne veux pas que ça recommence et quand tu as fini, tu le réactives ou alors, tu ne dépasses pas le min throttle (entre 1030 et 1050 en général selon les préférences) si tu ne veux pas que ça se produise, juste mettre des petits coups de gaz histoire de vérifier que les moteurs tournent dans le bon sens et qu'ils fonctionnent correctement 🙂

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Par sécurité on peut aussi désactiver l'airmode quand le throttle est bas ainsi que la boucle des PID.

Je n'ai pas essayé sans hélices mais comme ça désactive la boucle des PID à min throttle ça doit résoudre le soucis.

set pid_at_min_throttle = OFF
set airmode_start_throttle_percent = 15
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Merci a toi pour cette réponse complète.

C est ce que j' ai fait tout a l heure j ai désactivé l "air mode" le "problème" était le même, les moteurs 1 et 4 prennait des tours et le seul moyen de les couper c était de désarmer.

La prochaine fois j utilise le contrôle par le master mais quelle frayeur quand tu te retrouves la 1ere fois seul face a ton drone qui s enerve 😁😁

Modifié (le) par Bwucce
Lien vers le commentaire
Partager sur d’autres sites

Youtube WE are FPV
à l’instant, Bwucce a dit :

Merci a toi pour cette réponse complète.

C est ce que j' ai fait tout a l heure j ai désactivé l "air mode" le "problème" était le même, les moteurs 1 et 4 prennait des tours et le seul moyen de les couper c était de désarmer.

C'est quoi ta config en détail stp ? Ton câblage général est bon ? Surtout au niveau ESC / moteurs / FC plus précisément 🙂 

Sur blheli32suite, ça donne quoi le réglage des ESC et des moteurs ? Merci 🙂 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 14 heures, psixkho a dit :

C'est quoi ta config en détail stp ? Ton câblage général est bon ? Surtout au niveau ESC / moteurs / FC plus précisément 🙂 

Sur blheli32suite, ça donne quoi le réglage des ESC et des moteurs ? Merci 🙂 

Merci de ton intérêt l ami !

Config ok à jour (FC (MF405)Rx TX), Blheli ok à jour

Câblage loin d être parfait niveau soudure j ai pas utilisé la bonne technique mais c est solide et tout est au bon endroit.Sur un Tyro99 y a pas grand chose a souder a part les moteurs la xt60 et le Sport

Au final j ai monté les hélices ce matin et suis parti dans le champ d a côté pour tester.

RAS. Le quad vole très bien ça prend du roll un tantinet mais y avait une légère brise aussi.

Premier vol super mais je sens le crash dans pas longtemps 😁😁😁

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

C'est clair que des crashs, tu vas en prendre, c'est un truc à accepter dès le départ, j'en ai fait les frais comme tout le monde sur le fofo je pense x) 

Vaut mieux prendre du spare d'avance, c'est toujours utile même si ça prend un peu la poussière pendant un certain temps ^^''

Après, tant mieux si ton drone vole correctement, dans la mesure du possible, essaye d'éviter de voler quand il y a du vent, surtout de face, ça tire sur les lipos à fond et ça flingue la chimie beaucoup plus vite que la normale @Bwucce 😕 

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 11 heures, psixkho a dit :

C'est clair que des crashs, tu vas en prendre, c'est un truc à accepter dès le départ, j'en ai fait les frais comme tout le monde sur le fofo je pense x) 

Vaut mieux prendre du spare d'avance, c'est toujours utile même si ça prend un peu la poussière pendant un certain temps ^^''

Après, tant mieux si ton drone vole correctement, dans la mesure du possible, essaye d'éviter de voler quand il y a du vent, surtout de face, ça tire sur les lipos à fond et ça flingue la chimie beaucoup plus vite que la normale @Bwucce 😕 

Ah ben pour le vent c est râpé ici en vallée du Rhône c est très fréquent !

Bien sûr qu avec des rafales importantes je ne volerais pas ne serait ce que par sécurité mais avec 10km/h je pratique sinon autant arrêter le drone de suite 😁

Lien vers le commentaire
Partager sur d’autres sites

Salut

Vérifie aussi ton rc deadband il faut pas le mettre a 0.

Sinon si les valeurs fluctuent tu peux avoir ce genre de comportement. 

Ca m'est arrivé et je comprenais pas.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Share

×
×
  • Créer...