Jump to content
DroneBuilds
Sign in to follow this  
Yak

Hey du Sud Ouest !

Recommended Posts

Bonjour à tous,

Pour faire rapide sans déballer ma life entière, 35 ans du Sud-Ouest dans les landes et dans peu de temps je migre légèrement au nord direction le bassin d'Arcachon.

Niveau centres d'intérêts, musicien, motard, gamer, et depuis peu FPViste (arf je suis pas certain du terme, le Larousse ne m'en dit rien !)

Toujours eu appétence pour le modélisme (forcément la Tamiya RC dans ma jeunesse :D), j'ai donc décidé de passer au quad FPV.

Ne sachant pas trop quoi prendre, je me suis laissé tenter par un X220s, et franchement, j'ai grave accroché (j'ai bien sûr fait ma petite 15h de Liftoff comme il se doit) !

Depuis le temps que je parcours le forum, je décide donc de m'inscrire en espérant avoir des conseils d'avertis et de passionnés (je n’en doute pas une seconde) !

 

D'ailleurs, en parlant de conseils, forcément, j'en aurai bien besoin ! Je ne sais pas si l'ouverture d'un topic est indispensable, mais au cas où, je vous pose la question ici 😄

J'ai commandé une puce GPS bn-220 que j'ai installé sur mon OMNIBUS F4 V3. Soudure faites sur le UART 1 (RX1 / TX1 / 5V / GND). Jusqu'ici no problems même si je ne suis pas un expert de la soudure (petite pensée aux profs de techno du collège).

Ensuite, passage dans Betaflight (3.1.7) , j'ai mis « GPS » dans l’entrée capteur sur le UART 1. A fortiori, pas de difficultés.

J'ai en suivant activé le GPS dans la configuration puis mis le protocole UBLOX. Parfait !

Sauf qu’ensuite, pas de réception GPS ni de logo GPS d’allumé dans Bétaflight.

J’ai laissé la bête un bon 20 minutes dehors (GPS bien en évidence, je lui ai même imprimé un petit nid douillet) mais rien de change.

J’ai pourtant parcouru la toile, j’ai regardé des vidéos, en français, en anglais, en espagnol (là j’ai rien compris), mais rien n’y fait !

Avez-vous des pistes ?!

Merci par avance la communauté et bonne journée !

Share this post


Link to post
Share on other sites

Coucou et bienvenue a toi !

Pour la question du GPS, les pros vont pas tarder à passer... Etant newbie, je ne pourrai pas t'apporter plus que de la sympathie... au moins sur se coup là... désolé 😕 

Bonne journée et bon courage... Tu vas y arriver 😉 

Share this post


Link to post
Share on other sites

salut et bienvenue à toi

 

pareil, j'ai le meme gps, mais pas encore monté donc......

Share this post


Link to post
Share on other sites

Bon bé en inversant le fil RX et TX, le logo GPS s'active, youpy ! je continue les investigations 😄

  • J'aime 1

Share this post


Link to post
Share on other sites

Si peut être que... 

Faut pas activé l' I2C sur l'UART spécifié ?
T'es sur que l'UART1 gère l'I2C ? 
Ou alors inversion du SDA / SCL ? 

Houhou ! les pros du GPS et du contrôleur !!! A L'AIDE !!! 

Essai d'ouvrir un poste dans électronique peut être que...  😉 

Share this post


Link to post
Share on other sites
Youtube WE are FPV

haha !!

juste en même temps... enfin presque ^^

Share this post


Link to post
Share on other sites

Merci pour ton retour ! effectivement, ça c'est joué à la seconde près !

ça à l'air de capter du gps, bonne nouvelle, je testerai demain en extérieur du coup 🙂

En revanche, je ne vois pas l'option dans l'OSD pour ajouter les coordonnées GPS, ni les home direction et home distance...une idée ? je me demandais si c'était une histoire de version de betaflight ? j'ai bien pourtant la possibilité d'ajouter la vitesse GPS, les satellites...

merci par avance 🤗

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...