Jump to content
DroneBuilds
Chanmard

montage led avec buzzer et GPS BN-220 sur Nazgul5 6s

Recommended Posts

Bonjour,

Je viens vers vous afin d'être sûr de ne pas me tromper sur le soudage de ma carte Matek WS2812B LED avec Buzzer ainsi que du GPS BN-220.

J'ai trouvé une fiche technique pour le buzzer mais je ne sais pas si je suis en TX, FC ou TX FC...

J'ai la version du Nazgul5 6S avec le R-XSR

Je met des photos des articles ainsi que de ma carte afin de facilité l'explication ^_^

Merci d'avance

20200309_170909.thumb.jpg.92b49b292077a01f49ae5f9f101a588a.jpg20200309_171023.thumb.jpg.d1bd6f65ea8e4d28c9738c10bc84fa94.jpg20200309_170918.thumb.jpg.9c333383dad4a7fb7818fb61b3e75a7c.jpg2812-BH_Manual_EN.pdf

Share this post


Link to post
Share on other sites

Pour le buzzer, tu as les pads B - et B + sur ta carte 👍

Pour les leds, tu as également les pads à côté 👍. Le DIN sur Led, le G sur G et le 5 v sur un5 v. 
tout est sur ta carte en bas à gauche sur ta photo. 😉

Hervé

  • Merci ! 1

Share this post


Link to post
Share on other sites

Merci beaucoup pour ta réponse tu m'enlèves un grosse épine du pied pour moi, c'est la 1ère fois que je vais souder sur mon drone et avant de souder j'ai préféré être sûr ayant vu plusieurs possibilitées sur leur fiche 😃

Par contre pour le gps sais tu ou je dois le brancher ? pourrais je le mettre en doublon sur un 5V n'ayant plus de 5V dispo après ?

Bon week end à toi 😉

Share this post


Link to post
Share on other sites

Pour le gps, tu peux le mettre en T1 et R1 en inversant : tx sur R1 et Rx sur T1. Ensuite sur BF, tu notes en UART1 le gps.  Normalement ça doit fonctionner 👍. N’hésites pas si ça fonctionne pas 😉. Pour le 5v, pas de soucis 😇
Hervé 😎

Edited by Rv83600
  • J'aime 1

Share this post


Link to post
Share on other sites

Merci encore pour ton aide rapide 😉

Il y a plus qu'a ce mettre au travail !!!

j'enverrai une photo une fois fini pour montrer le résultat final.

Bon week end et bon vol 🤩

Share this post


Link to post
Share on other sites
Youtube WE are FPV

J'ai enfin fini la soudure c'est pas top mais cela fait le taf... Je me souvenais pas que cela était aussi compliqué surtout seul !!! bon ok cela fait 20 ans que j'avais pas soudé 😁

tout s'allume correctement c'est déjà une bonne chose par contre le gps ne fonctionne pas.

j'ai été dans betaflight pour l'activé mais cela ne fonctionne toujours pas voici ce que j'ai ( sachant que le vtx était déjà positionné en uart1 mais même en le positionnant sur le uart3 cela fonctionne)😅

j'ai aussi test les 2 protocoles gps sans succes.

20200318_122530.thumb.jpg.dca84e5bd73dbfc4c6321e1ac39b5562.jpgconfig.thumb.jpg.f0bf33089bbfff7aab3f80fe1acc2311.jpg20200318_130639.thumb.jpg.46a5002712c4fda92078ac7705052405.jpgport.thumb.jpg.df2f1afac27c69ceb9a7f05c5a696b01.jpg

Share this post


Link to post
Share on other sites

Le GPS est il déjà sous tension (led) quand tu alimentes ton kwad ? (Un + 5v et une masse -)

As tu bien mis le fil RX du GPS sur le pad TX de ta FC ? (UART 1 semble t'il) 

As tu bien mis le fil TX du GPS sur le pad RX de ta FC (toujours su le même UART 1 )

  • Merci ! 1

Share this post


Link to post
Share on other sites

oui j'ai une petite led rouge qui clignote en "pps" mais pas celle du "tx" mais je sais pas si c'est normal...

Je pense qu'il le reconnait sous betaflight car c'est lui qui le met directement en 57600 lorsque je met automatique.

J'ai entouré mes branchements sur la fc lorsqu'elle était encore belle 🤣 en me basant sur cette photo. J'ai juste mis sur le GND d'en face car je n'arrivais pas à le faire tenir en le mettant en double avec celui du buzzer/ led

769646941_codecouleurgps.thumb.jpg.1367a1f92d263b54903bde50f62a6c21.jpg134078155_branchementgps.thumb.jpg.b8dffc36d268543dbd18d0ffdd64745d.jpg

Share this post


Link to post
Share on other sites

et cela me met ca lorsque je fais get gps :

# Building AutoComplete Cache ... Done!
#
# get gps
gps_provider = UBLOX
Allowed values: NMEA, UBLOX, MSP
Default value: NMEA

gps_sbas_mode = AUTO
Allowed values: AUTO, EGNOS, WAAS, MSAS, GAGAN

gps_auto_config = ON
Allowed values: OFF, ON

gps_auto_baud = ON
Allowed values: OFF, ON
Default value: OFF

gps_ublox_use_galileo = OFF
Allowed values: OFF, ON

gps_set_home_point_once = OFF
Allowed values: OFF, ON

gps_rescue_angle = 32
Allowed range: 0 - 200

gps_rescue_initial_alt = 50
Allowed range: 20 - 100

gps_rescue_descent_dist = 200
Allowed range: 30 - 500

gps_rescue_ground_speed = 2000
Allowed range: 30 - 3000

gps_rescue_throttle_p = 150
Allowed range: 0 - 500

gps_rescue_throttle_i = 20
Allowed range: 0 - 500

gps_rescue_throttle_d = 50
Allowed range: 0 - 500

gps_rescue_velocity_p = 80
Allowed range: 0 - 500

gps_rescue_velocity_i = 20
Allowed range: 0 - 500

gps_rescue_velocity_d = 15
Allowed range: 0 - 500

gps_rescue_yaw_p = 40
Allowed range: 0 - 500

gps_rescue_throttle_min = 1200
Allowed range: 1000 - 2000

gps_rescue_throttle_max = 1600
Allowed range: 1000 - 2000

gps_rescue_throttle_hover = 1280
Allowed range: 1000 - 2000

gps_rescue_sanity_checks = RESCUE_SANITY_ON
Allowed values: RESCUE_SANITY_OFF, RESCUE_SANITY_ON, RESCUE_SANITY_FS_ONLY

gps_rescue_min_sats = 8
Allowed range: 5 - 50

gps_rescue_min_dth = 100
Allowed range: 50 - 1000

gps_rescue_allow_arming_without_fix = OFF
Allowed values: OFF, ON

gps_rescue_use_mag = ON
Allowed values: OFF, ON

frsky_gps_format = 0
Allowed range: 0 - 1

osd_warn_no_gps_rescue = ON
Allowed values: OFF, ON

osd_warn_gps_rescue_disabled = ON
Allowed values: OFF, ON

osd_gps_speed_pos = 14425
Allowed range: 0 - 15359
Default value: 234

osd_gps_lon_pos = 234
Allowed range: 0 - 15359

osd_gps_lat_pos = 2282
Allowed range: 0 - 15359
Default value: 234

osd_gps_sats_pos = 14336
Allowed range: 0 - 15359
Default value: 234

Share this post


Link to post
Share on other sites

enfin tt fonctionne !!!!🤩

Avant toute chose un GRAND GRAND merci à CriTof pour son aide via message pour toute son aide afin de resoudre mon problème car cela n'a pas été facile pour moi mais je pense pour lui aussi 🤣

j'ai isolé le branchement du gps aussi bien pour le 5V que le G et regroupé le 5v buzzer/led et G du buzzer/led.

J'ai aussi refait tte mes soudures sur le buzzer/led car elles étaient vraiment pas belle non plus...😅

J'ai été voir sur betaflight en effet je peux pas changer la couleur des LED mais bon cela me l'affiche en orange ca change aussi !!!! et tout le reste fonctionne et j'ai enfin le gps d'affiché sous betaflight....

Donc a retenir pour le GPS ( si lors du branchement il y a que la led du pps qui clignote en rouge (de facon non régulière d'ailleurs) c'est le voltage (soit le 5V ou le G) qui pose problème car les seul soudures que je n'ai pas touché c'est celle du TX et RX 😉

Voila les amis encore merci à tous et bon vol (lorsqu'on pourra bien sur 😔 )

Pour le moment je m'entraine chez moi avec mon beta85X HD j'ouvre toute les fenêtre et rentre et sort en faisant le tour de la maison !!! 😍

Voici une photo de ma FC finale

20200325_140134.thumb.jpg.e902cb9dbf0e631605079ca3c920995b.jpg20200325_140144.thumb.jpg.40e7d68d0bf6e2a0149639bb70ccb058.jpg

20200325_152738.thumb.jpg.3bef325e23f411fc91c4c828078499cc.jpg

  • J'aime 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...