Aller au contenu
drone débutant pas cher
JBF

Connecter un récepteur externe à une carte de vol AIO 16x16

Messages recommandés

Salut ! J’ai arraché l’antenne d’une tinyfish f3 et j’ai un xsr pour faire un rx externe, comment puis-je faire en sorte que la carte prenne le signal du rx externe et pas de celui qui est intégré ? Si ça marche y aura sans doute la vidéo manquante du pepperfish sur la chaîne waf avec le test 😛  Merci d’avance 😉 

D94C4171-BEF4-4704-8BCB-B1A71B9EECA8.jpeg

Partager ce message


Lien à poster
Partager sur d’autres sites

Connecter classiquement ton Rx sur un UART libre, réaffecter depuis CLI (#resource) les ports, puis caler tout ça depuis config, ports et receiver ? Enfin je partirais sur cette piste.

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur les F3 le SBUS va tout simplement sur un UART RX qu'il faut définir dans l'onglet port. Normalement c'est pas plus compliqué 🙂 

Par contre je vois pas de TX libre pour le Smart Port (ça peut pas être le même UART que le SBUS).

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, Yannkee75 a dit :

Connecter classiquement ton Rx sur un UART libre, réaffecter depuis CLI (#resource) les ports, puis caler tout ça depuis config, ports et receiver ? Enfin je partirais sur cette piste.

Hummm ça paraît logique mais je ne vois pas de resources liés au sbus, il n’y a que celle de l’uart 3 mais ça m’etonnerait qu’il faille la changer. j’ai déjà essayé de souder le sbus à l’uart 3 et cocher serial rx sur cet uart, et rien a faire, que d’alle dans l’onglet receiver 😞 merci quand même 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Motard Geek a dit :

Sur les F3 le SBUS va tout simplement sur un UART RX qu'il faut définir dans l'onglet port. Normalement c'est pas plus compliqué 🙂 

Par contre je vois pas de TX libre pour le Smart Port (ça peut pas être le même UART que le SBUS).

Yo, donc j’ai soudé le sbus au pad uart3 rx, activé le serial rx de l’uart 3, bindé le rx, et toujours rien dans l’onglet receiver... perso avoir la télémétrie je m’en fou un peu 😉 😛 

Modifié (le) par JBF

Partager ce message


Lien à poster
Partager sur d’autres sites
Youtube WE are FPV

Yo ! Finalement j’ai réussi en galérant un peu faut l’avouer, fallait souder un fil sur une broche minuscule d’un composant pour récupérer le signal sbus non inversé du xsr 😛 et la miracle ça a marché ! Merci à tous pour votre aide 

Partager ce message


Lien à poster
Partager sur d’autres sites
Yo ! Finalement j’ai réussi en galérant un peu faut l’avouer, fallait souder un fil sur une broche minuscule d’un composant pour récupérer le signal sbus non inversé du xsr  et la miracle ça a marché ! Merci à tous pour votre aide 

Bien! Content pour toi. T’as soudé quoi sur quoi ? Ce serait cool si tu débriefais un peu plus précisément au cas où quelqu’un aurait le même objectif. En revanche c’est étonnant cette histoire de Sbus inversé sur une F3.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, Yannkee75 a dit :


Bien! Content pour toi. T’as soudé quoi sur quoi ? Ce serait cool si tu débriefais un peu plus précisément au cas où quelqu’un aurait le même objectif. En revanche c’est étonnant cette histoire de Sbus inversé sur une F3.

Si tu veux mais on trouve des images sur Google du petit composant à souder en marquant sbus inverted xsr 😉 en gros faut souder un câble sur cette partie 😛 et si tu te pose la question, OUI, J’AI GALÉRÉ  😄 

834BCFCF-604A-409F-9248-3A1B25315F15.jpeg

Partager ce message


Lien à poster
Partager sur d’autres sites
Si tu veux mais on trouve des images sur Google du petit composant à souder en marquant sbus inverted xsr  en gros faut souder un câble sur cette partie  et si tu te pose la question, OUI, J’AI GALÉRÉ   
834BCFCF-604A-409F-9248-3A1B25315F15.jpeg.20f0e78c6cf4ec685d5baf864a7e218a.jpeg

Ah oui ok, le classique sur ce Rx , j’avais un doute si c’était sur la FC.
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui moi aussi je pensais que c’était que pour les F4 qui n’avaient pas d’inverseur de sbus 😉 mais apparament cette f3 n’en avais pas de base 🙂 

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...